%global _empty_manifest_terminate_build 0
Name:		python-UW-RestClients-AdSel
Version:	1.9
Release:	1
Summary:	A library for connecting to the AdSel API at the University of Washington
License:	Apache License, Version 2.0
URL:		https://github.com/uw-it-aca/uw-restclients-adsel
Source0:	https://mirrors.aliyun.com/pypi/web/packages/e1/a1/8eab779634d1cf126dbf6689f03730d7ee5c3b6dee2550b6d919205807d5/UW-RestClients-AdSel-1.9.tar.gz
BuildArch:	noarch

Requires:	python3-UW-RestClients-Core
Requires:	python3-mock
Requires:	python3-dateutil

%description

See the README on `GitHub
<https://github.com/uw-it-aca/uw-restclients-adsel>`_.




%package -n python3-UW-RestClients-AdSel
Summary:	A library for connecting to the AdSel API at the University of Washington
Provides:	python-UW-RestClients-AdSel
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-UW-RestClients-AdSel

See the README on `GitHub
<https://github.com/uw-it-aca/uw-restclients-adsel>`_.




%package help
Summary:	Development documents and examples for UW-RestClients-AdSel
Provides:	python3-UW-RestClients-AdSel-doc
%description help

See the README on `GitHub
<https://github.com/uw-it-aca/uw-restclients-adsel>`_.




%prep
%autosetup -n UW-RestClients-AdSel-1.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-UW-RestClients-AdSel -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.9-1
- Package Spec generated