%global _empty_manifest_terminate_build 0
Name: python-ampel-ztf
Version: 0.9.0
Release: 1
Summary: Zwicky Transient Facility support for the Ampel system
License: BSD-3-Clause
URL: https://ampelproject.github.io
Source0: https://mirrors.aliyun.com/pypi/web/packages/7a/61/3ef95337f4996d8918d61035f11c37eaca24960c92bd5aa5e82aa4821568/ampel_ztf-0.9.0.tar.gz
BuildArch: noarch
Requires: python3-astropy
Requires: python3-matplotlib
Requires: python3-aiohttp
Requires: python3-nest-asyncio
Requires: python3-backoff
Requires: python3-fastavro
Requires: python3-requests
Requires: python3-requests-toolbelt
Requires: python3-confluent-kafka
Requires: python3-healpy
Requires: python3-light-curve
Requires: python3-ampel-ztf-archive
Requires: python3-ampel-interface
Requires: python3-ampel-core
Requires: python3-ampel-photometry
Requires: python3-ampel-alerts
Requires: python3-ampel-plot
Requires: python3-pandas
Requires: python3-scipy
Requires: python3-planobs
%description
# ZTF support for AMPEL
ZTF-specific implementations for Ampel such as:
- An _AlertSupplier_ compatible with IPAC generated alerts
- Shaper classes for ingestion
- Encoding utilities for ZTF names (AMPEL requires integer ids)
- Classes for archiving alerts
%package -n python3-ampel-ztf
Summary: Zwicky Transient Facility support for the Ampel system
Provides: python-ampel-ztf
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ampel-ztf
# ZTF support for AMPEL
ZTF-specific implementations for Ampel such as:
- An _AlertSupplier_ compatible with IPAC generated alerts
- Shaper classes for ingestion
- Encoding utilities for ZTF names (AMPEL requires integer ids)
- Classes for archiving alerts
%package help
Summary: Development documents and examples for ampel-ztf
Provides: python3-ampel-ztf-doc
%description help
# ZTF support for AMPEL
ZTF-specific implementations for Ampel such as:
- An _AlertSupplier_ compatible with IPAC generated alerts
- Shaper classes for ingestion
- Encoding utilities for ZTF names (AMPEL requires integer ids)
- Classes for archiving alerts
%prep
%autosetup -n ampel_ztf-0.9.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ampel-ztf -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.9.0-1
- Package Spec generated