%global _empty_manifest_terminate_build 0
Name: python-beacontools
Version: 2.1.0
Release: 1
Summary: A Python library for working with various types of Bluetooth LE Beacons.
License: MIT
URL: https://github.com/citruz/beacontools
Source0: https://mirrors.aliyun.com/pypi/web/packages/be/34/2ce4821fe67c9c3246edc974a371ec8a9ae8365573d87c5817a77e6284f8/beacontools-2.1.0.tar.gz
BuildArch: noarch
Requires: python3-construct
Requires: python3-ahocorapy
Requires: python3-check-manifest
Requires: python3-coveralls
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-mock
Requires: python3-check-manifest
Requires: python3-pylint
Requires: python3-readme-renderer
Requires: python3-docutils
%description
|PyPI Package| |Build Status| |Coverage Status| |Requirements Status|
A Python library for working with various types of Bluetooth LE Beacons.
Currently supported types are:
* `Eddystone Beacons `__
* `iBeacons `__ (Apple and Cypress CYALKIT-E02)
* `Estimote Beacons (Telemetry and Nearable) `__
* Control-J Monitor (temp/humidity/light)
* `COVID-19 Exposure Notifications `__
The BeaconTools library has two main components:
* a parser to extract information from raw binary beacon advertisements
* a scanner which scans for Bluetoth LE advertisements using bluez and can be configured to look only for specific beacons or packet types
%package -n python3-beacontools
Summary: A Python library for working with various types of Bluetooth LE Beacons.
Provides: python-beacontools
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-beacontools
|PyPI Package| |Build Status| |Coverage Status| |Requirements Status|
A Python library for working with various types of Bluetooth LE Beacons.
Currently supported types are:
* `Eddystone Beacons `__
* `iBeacons `__ (Apple and Cypress CYALKIT-E02)
* `Estimote Beacons (Telemetry and Nearable) `__
* Control-J Monitor (temp/humidity/light)
* `COVID-19 Exposure Notifications `__
The BeaconTools library has two main components:
* a parser to extract information from raw binary beacon advertisements
* a scanner which scans for Bluetoth LE advertisements using bluez and can be configured to look only for specific beacons or packet types
%package help
Summary: Development documents and examples for beacontools
Provides: python3-beacontools-doc
%description help
|PyPI Package| |Build Status| |Coverage Status| |Requirements Status|
A Python library for working with various types of Bluetooth LE Beacons.
Currently supported types are:
* `Eddystone Beacons `__
* `iBeacons `__ (Apple and Cypress CYALKIT-E02)
* `Estimote Beacons (Telemetry and Nearable) `__
* Control-J Monitor (temp/humidity/light)
* `COVID-19 Exposure Notifications `__
The BeaconTools library has two main components:
* a parser to extract information from raw binary beacon advertisements
* a scanner which scans for Bluetoth LE advertisements using bluez and can be configured to look only for specific beacons or packet types
%prep
%autosetup -n beacontools-2.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-beacontools -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.1.0-1
- Package Spec generated