%global _empty_manifest_terminate_build 0
Name:		python-pyinsteon
Version:	1.4.2
Release:	1
Summary:	Open-source Insteon home automation module running on Python 3.
License:	MIT License
URL:		https://pypi.org/project/pyinsteon/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/af/2d/a6f0a82f50fafdd37a13f01cb069cbfc0f73889dac4f8f4166b3a34663a0/pyinsteon-1.4.2.tar.gz
BuildArch:	noarch

Requires:	python3-pyserial
Requires:	python3-pyserial-asyncio
Requires:	python3-aiohttp
Requires:	python3-pypubsub
Requires:	python3-aiofiles
Requires:	python3-voluptuous

%description
-  Python 3.8, 3.9, 3.10 or 3.11
-  Posix or Windows based system
-  Some form of Insteon PLM or Hub
-  At least one Insteon device

%package -n python3-pyinsteon
Summary:	Open-source Insteon home automation module running on Python 3.
Provides:	python-pyinsteon
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pyinsteon
-  Python 3.8, 3.9, 3.10 or 3.11
-  Posix or Windows based system
-  Some form of Insteon PLM or Hub
-  At least one Insteon device

%package help
Summary:	Development documents and examples for pyinsteon
Provides:	python3-pyinsteon-doc
%description help
-  Python 3.8, 3.9, 3.10 or 3.11
-  Posix or Windows based system
-  Some form of Insteon PLM or Hub
-  At least one Insteon device

%prep
%autosetup -n pyinsteon-1.4.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pyinsteon -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.2-1
- Package Spec generated