%global _empty_manifest_terminate_build 0
Name:		python-openvpn-status
Version:	0.2.2
Release:	1
Summary:	Parse OpenVPN status logs in Python
License:	MIT
URL:		https://github.com/tonyseek/openvpn-status
Source0:	https://mirrors.aliyun.com/pypi/web/packages/f7/93/4f74dc81ca438c8ad16e5d0e9dd00a84f4cfe735372befa34e9eefced221/openvpn-status-0.2.2.tar.gz
BuildArch:	noarch

Requires:	python3-six
Requires:	python3-humanize
Requires:	python3-netaddr
Requires:	python3-ipaddress

%description
**openvpn-status** is a Python library. It parses OpenVPN status log and turns
it into Python data structure for you.
It is compatible with Python `2.7`, `3.6` to `3.10`, and PyPy.

%package -n python3-openvpn-status
Summary:	Parse OpenVPN status logs in Python
Provides:	python-openvpn-status
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-openvpn-status
**openvpn-status** is a Python library. It parses OpenVPN status log and turns
it into Python data structure for you.
It is compatible with Python `2.7`, `3.6` to `3.10`, and PyPy.

%package help
Summary:	Development documents and examples for openvpn-status
Provides:	python3-openvpn-status-doc
%description help
**openvpn-status** is a Python library. It parses OpenVPN status log and turns
it into Python data structure for you.
It is compatible with Python `2.7`, `3.6` to `3.10`, and PyPy.

%prep
%autosetup -n openvpn-status-0.2.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-openvpn-status -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.2-1
- Package Spec generated