%global _empty_manifest_terminate_build 0
Name:		python-social-analyzer
Version:	0.45
Release:	1
Summary:	API, CLI & Web App for analyzing & finding a person's profile across 300+ social media websites (Detections are updated regularly)
License:	AGPL-3.0
URL:		https://github.com/qeeqbox/social-analyzer
Source0:	https://mirrors.aliyun.com/pypi/web/packages/44/46/0b94ae6758dab6b0857c125987690530c5cd2a680a5d565603eca14c45e7/social-analyzer-0.45.tar.gz
BuildArch:	noarch

Requires:	python3-BeautifulSoup4
Requires:	python3-galeodes
Requires:	python3-langdetect
Requires:	python3-lxml
Requires:	python3-requests
Requires:	python3-termcolor
Requires:	python3-tld

%description
Websites and applications that enable users to create and share content or to participate in social networking - Oxford Dictionary

%package -n python3-social-analyzer
Summary:	API, CLI & Web App for analyzing & finding a person's profile across 300+ social media websites (Detections are updated regularly)
Provides:	python-social-analyzer
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-social-analyzer
Websites and applications that enable users to create and share content or to participate in social networking - Oxford Dictionary

%package help
Summary:	Development documents and examples for social-analyzer
Provides:	python3-social-analyzer-doc
%description help
Websites and applications that enable users to create and share content or to participate in social networking - Oxford Dictionary

%prep
%autosetup -n social-analyzer-0.45

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-social-analyzer -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.45-1
- Package Spec generated