%global _empty_manifest_terminate_build 0
Name:		python-appspace
Version:	0.5.4
Release:	1
Summary:	easy application construction with easy building blocks
License:	BSD
URL:		https://bitbucket.org/lcrees/appspace
Source0:	https://mirrors.aliyun.com/pypi/web/packages/aa/4b/a1e98099b5a7fee2eff4e9a08ea431b6ea247700915df0bdaf43a5fdf10e/appspace-0.5.4.tar.bz2
BuildArch:	noarch


%description
*appspace* is a component injection framework that allows any mishmash of Python 
classes, objects, functions, or modules to be dynamically cobbled together into 
an application. 

An appspaced application is built with an appconf (application configuration) 
similar to a Django urlconf:

>>> from appspace import patterns
>>> appconf = patterns(
...    'helpers',
...    ('square', 'math.sqrt'),
...    ('fabulous', 'math.fabs'),
...    include('subapp', 'foo.bar.apps')
... )

Once configured, application components can be accessed as object attributes,
dictionary keys, or by calling the component manager directly:

>>> fab1 = plug.helpers.fabulous
>>> fab2 = plug['helpers']['fabulous']
>>> fab1(2)
2.0
>>> fab2(2)
2.0
>>> plug.helpers.fabulous(2)
2.0
>>> plug('fabulous', 2)
2.0

%package -n python3-appspace
Summary:	easy application construction with easy building blocks
Provides:	python-appspace
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-appspace
*appspace* is a component injection framework that allows any mishmash of Python 
classes, objects, functions, or modules to be dynamically cobbled together into 
an application. 

An appspaced application is built with an appconf (application configuration) 
similar to a Django urlconf:

>>> from appspace import patterns
>>> appconf = patterns(
...    'helpers',
...    ('square', 'math.sqrt'),
...    ('fabulous', 'math.fabs'),
...    include('subapp', 'foo.bar.apps')
... )

Once configured, application components can be accessed as object attributes,
dictionary keys, or by calling the component manager directly:

>>> fab1 = plug.helpers.fabulous
>>> fab2 = plug['helpers']['fabulous']
>>> fab1(2)
2.0
>>> fab2(2)
2.0
>>> plug.helpers.fabulous(2)
2.0
>>> plug('fabulous', 2)
2.0

%package help
Summary:	Development documents and examples for appspace
Provides:	python3-appspace-doc
%description help
*appspace* is a component injection framework that allows any mishmash of Python 
classes, objects, functions, or modules to be dynamically cobbled together into 
an application. 

An appspaced application is built with an appconf (application configuration) 
similar to a Django urlconf:

>>> from appspace import patterns
>>> appconf = patterns(
...    'helpers',
...    ('square', 'math.sqrt'),
...    ('fabulous', 'math.fabs'),
...    include('subapp', 'foo.bar.apps')
... )

Once configured, application components can be accessed as object attributes,
dictionary keys, or by calling the component manager directly:

>>> fab1 = plug.helpers.fabulous
>>> fab2 = plug['helpers']['fabulous']
>>> fab1(2)
2.0
>>> fab2(2)
2.0
>>> plug.helpers.fabulous(2)
2.0
>>> plug('fabulous', 2)
2.0

%prep
%autosetup -n appspace.tar-0.5.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-appspace -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.4-1
- Package Spec generated