%global _empty_manifest_terminate_build 0
Name: python-cf-units
Version: 3.2.0
Release: 1
Summary: Units of measure as required by the Climate and Forecast (CF) metadata conventions
License: BSD
URL: https://github.com/SciTools/cf-units
Source0: https://mirrors.aliyun.com/pypi/web/packages/5a/f4/1d9aa224fe8f70034e9ea524d1dac511b0976bae6a82d664bd4e84ed026c/cf-units-3.2.0.tar.gz
BuildArch: noarch
Requires: python3-antlr4-python3-runtime
Requires: python3-cftime
Requires: python3-jinja2
Requires: python3-numpy
Requires: python3-pre-commit
Requires: python3-sphinx
Requires: python3-codecov
Requires: python3-cython
Requires: python3-jinja2
Requires: python3-pip
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-sphinx
Requires: python3-codecov
Requires: python3-cython
Requires: python3-jinja2
Requires: python3-pip
Requires: python3-pytest
Requires: python3-pytest-cov
%description
# [cf-units](https://cf-units.readthedocs.io/en/latest/)
#### Units of measure as defined by the Climate and Forecast (CF) Metadata Conventions.
[comment]: # (https://shields.io/ is a good source of these)
[](https://github.com/SciTools/cf-units/actions/workflows/ci-tests.yml)
[](https://github.com/SciTools/cf-units/actions/workflows/ci-wheels.yml)
[](https://github.com/SciTools/cf-units/actions/workflows/ci-locks.yml)
[](https://cf-units.readthedocs.io/en/latest/?badge=latest)
[](https://codecov.io/gh/SciTools/cf-units)
[](https://results.pre-commit.ci/latest/github/SciTools/cf-units/main)
\
[](https://anaconda.org/conda-forge/cf-units)
[](https://pypi.org/project/cf-units/)
[](https://github.com/SciTools/cf-units/releases)
[](https://doi.org/10.5281/zenodo.3723086)
\
[](https://github.com/psf/black)
[](https://github.com/PyCQA/flake8)
[](https://pycqa.github.io/isort/)
\
[](LICENSE)
[](https://github.com/SciTools/cf-units/graphs/contributors)
[](https://github.com/SciTools/cf-units/commits/main)
## Table of Contents
[comment]: # (NOTE: toc auto-generated with
https://github.com/jonschlinkert/markdown-toc
$> markdown-toc -i --bullets='-' README.md)
[comment]: # (This entire README can be markdown linted with
https://github.com/igorshubovych/markdownlint-cli
$ markdownlint README.md)
- [Overview](#overview)
- [Example](#example)
- [Get in Touch](#get-in-touch)
- [Credits, Copyright and License](#credits-copyright-and-license)
## Overview
Units of measure as required by the Climate and Forecast (CF) metadata
conventions.
Provision of a wrapper class to support Unidata/UCAR UDUNITS-2 library, and the
cftime calendar functionality.
Documentation can be found at .
### Example
>>> from cf_units import Unit
>>> km = Unit('kilometers')
>>> m = Unit('meters')
>>> m.convert(1500, km)
1.5
## Get in Touch
- Questions, ideas, general discussion or announcements
of related projects: use the
[Discussions space](https://github.com/SciTools/cf-units/discussions).
- Report bugs:
[submit a GitHub issue](https://github.com/SciTools/cf-units/issues).
- Suggest features: see our [contributing guide](.github/CONTRIBUTING.md).
## Credits, Copyright and License
cf-units is developed collaboratively under the SciTools umbrella.
A full list of code contributors ("cf-units contributors") can be found at
https://github.com/SciTools/cf-units/graphs/contributors.
Code is just one of many ways of positively contributing to cf-units, please
see our [contributing guide](.github/CONTRIBUTING.md) for more details on how
you can get involved.
cf-units is released under a BSD-3 license. See [LICENSE](LICENSE) for full
terms.
The [Met Office](https://metoffice.gov.uk) has made a significant
contribution to the development, maintenance and support of this library.
All Met Office contributions are copyright on behalf of the British Crown.
%package -n python3-cf-units
Summary: Units of measure as required by the Climate and Forecast (CF) metadata conventions
Provides: python-cf-units
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cf-units
# [cf-units](https://cf-units.readthedocs.io/en/latest/)
#### Units of measure as defined by the Climate and Forecast (CF) Metadata Conventions.
[comment]: # (https://shields.io/ is a good source of these)
[](https://github.com/SciTools/cf-units/actions/workflows/ci-tests.yml)
[](https://github.com/SciTools/cf-units/actions/workflows/ci-wheels.yml)
[](https://github.com/SciTools/cf-units/actions/workflows/ci-locks.yml)
[](https://cf-units.readthedocs.io/en/latest/?badge=latest)
[](https://codecov.io/gh/SciTools/cf-units)
[](https://results.pre-commit.ci/latest/github/SciTools/cf-units/main)
\
[](https://anaconda.org/conda-forge/cf-units)
[](https://pypi.org/project/cf-units/)
[](https://github.com/SciTools/cf-units/releases)
[](https://doi.org/10.5281/zenodo.3723086)
\
[](https://github.com/psf/black)
[](https://github.com/PyCQA/flake8)
[](https://pycqa.github.io/isort/)
\
[](LICENSE)
[](https://github.com/SciTools/cf-units/graphs/contributors)
[](https://github.com/SciTools/cf-units/commits/main)
## Table of Contents
[comment]: # (NOTE: toc auto-generated with
https://github.com/jonschlinkert/markdown-toc
$> markdown-toc -i --bullets='-' README.md)
[comment]: # (This entire README can be markdown linted with
https://github.com/igorshubovych/markdownlint-cli
$ markdownlint README.md)
- [Overview](#overview)
- [Example](#example)
- [Get in Touch](#get-in-touch)
- [Credits, Copyright and License](#credits-copyright-and-license)
## Overview
Units of measure as required by the Climate and Forecast (CF) metadata
conventions.
Provision of a wrapper class to support Unidata/UCAR UDUNITS-2 library, and the
cftime calendar functionality.
Documentation can be found at .
### Example
>>> from cf_units import Unit
>>> km = Unit('kilometers')
>>> m = Unit('meters')
>>> m.convert(1500, km)
1.5
## Get in Touch
- Questions, ideas, general discussion or announcements
of related projects: use the
[Discussions space](https://github.com/SciTools/cf-units/discussions).
- Report bugs:
[submit a GitHub issue](https://github.com/SciTools/cf-units/issues).
- Suggest features: see our [contributing guide](.github/CONTRIBUTING.md).
## Credits, Copyright and License
cf-units is developed collaboratively under the SciTools umbrella.
A full list of code contributors ("cf-units contributors") can be found at
https://github.com/SciTools/cf-units/graphs/contributors.
Code is just one of many ways of positively contributing to cf-units, please
see our [contributing guide](.github/CONTRIBUTING.md) for more details on how
you can get involved.
cf-units is released under a BSD-3 license. See [LICENSE](LICENSE) for full
terms.
The [Met Office](https://metoffice.gov.uk) has made a significant
contribution to the development, maintenance and support of this library.
All Met Office contributions are copyright on behalf of the British Crown.
%package help
Summary: Development documents and examples for cf-units
Provides: python3-cf-units-doc
%description help
# [cf-units](https://cf-units.readthedocs.io/en/latest/)
#### Units of measure as defined by the Climate and Forecast (CF) Metadata Conventions.
[comment]: # (https://shields.io/ is a good source of these)
[](https://github.com/SciTools/cf-units/actions/workflows/ci-tests.yml)
[](https://github.com/SciTools/cf-units/actions/workflows/ci-wheels.yml)
[](https://github.com/SciTools/cf-units/actions/workflows/ci-locks.yml)
[](https://cf-units.readthedocs.io/en/latest/?badge=latest)
[](https://codecov.io/gh/SciTools/cf-units)
[](https://results.pre-commit.ci/latest/github/SciTools/cf-units/main)
\
[](https://anaconda.org/conda-forge/cf-units)
[](https://pypi.org/project/cf-units/)
[](https://github.com/SciTools/cf-units/releases)
[](https://doi.org/10.5281/zenodo.3723086)
\
[](https://github.com/psf/black)
[](https://github.com/PyCQA/flake8)
[](https://pycqa.github.io/isort/)
\
[](LICENSE)
[](https://github.com/SciTools/cf-units/graphs/contributors)
[](https://github.com/SciTools/cf-units/commits/main)
## Table of Contents
[comment]: # (NOTE: toc auto-generated with
https://github.com/jonschlinkert/markdown-toc
$> markdown-toc -i --bullets='-' README.md)
[comment]: # (This entire README can be markdown linted with
https://github.com/igorshubovych/markdownlint-cli
$ markdownlint README.md)
- [Overview](#overview)
- [Example](#example)
- [Get in Touch](#get-in-touch)
- [Credits, Copyright and License](#credits-copyright-and-license)
## Overview
Units of measure as required by the Climate and Forecast (CF) metadata
conventions.
Provision of a wrapper class to support Unidata/UCAR UDUNITS-2 library, and the
cftime calendar functionality.
Documentation can be found at .
### Example
>>> from cf_units import Unit
>>> km = Unit('kilometers')
>>> m = Unit('meters')
>>> m.convert(1500, km)
1.5
## Get in Touch
- Questions, ideas, general discussion or announcements
of related projects: use the
[Discussions space](https://github.com/SciTools/cf-units/discussions).
- Report bugs:
[submit a GitHub issue](https://github.com/SciTools/cf-units/issues).
- Suggest features: see our [contributing guide](.github/CONTRIBUTING.md).
## Credits, Copyright and License
cf-units is developed collaboratively under the SciTools umbrella.
A full list of code contributors ("cf-units contributors") can be found at
https://github.com/SciTools/cf-units/graphs/contributors.
Code is just one of many ways of positively contributing to cf-units, please
see our [contributing guide](.github/CONTRIBUTING.md) for more details on how
you can get involved.
cf-units is released under a BSD-3 license. See [LICENSE](LICENSE) for full
terms.
The [Met Office](https://metoffice.gov.uk) has made a significant
contribution to the development, maintenance and support of this library.
All Met Office contributions are copyright on behalf of the British Crown.
%prep
%autosetup -n cf-units-3.2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cf-units -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 3.2.0-1
- Package Spec generated