%global _empty_manifest_terminate_build 0
Name:		python-centerline
Version:	1.0.1
Release:	1
Summary:	Calculate the centerline of a polygon
License:	MIT License
URL:		https://github.com/fitodic/centerline
Source0:	https://mirrors.aliyun.com/pypi/web/packages/40/aa/5233e300e8a2629d1105092b2e79d5522ce604b9f315155920d5ce7e5973/centerline-1.0.1.tar.gz
BuildArch:	noarch

Requires:	python3-Fiona
Requires:	python3-Shapely
Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-Click
Requires:	python3-ipdb
Requires:	python3-tox
Requires:	python3-sphinx
Requires:	python3-GDAL
Requires:	python3-flake8
Requires:	python3-isort
Requires:	python3-black
Requires:	python3-coverage
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-pytest-sugar
Requires:	python3-pytest-runner

%description
Roads, rivers and similar linear structures are often represented by
long and complex polygons. Since one of the most important attributes of
a linear structure is its length, extracting that attribute from a
polygon can prove to be more or less difficult.
This library tries to solve this problem by creating the the polygon's
centerline using the `Voronoi diagram
<https://en.wikipedia.org/wiki/Voronoi_diagram>`_. For more info on how
to use this package, see the
`official documentation <http://centerline.readthedocs.io/>`_.
Features
^^^^^^^^
* A command-line script for creating centerlines from a vector source file and saving them into a destination vector file: ``create_centerlines``
    $ create_centerlines input.shp output.geojson
* The ``Centerline`` class that allows integration into your own workflow.
    >>> from shapely.geometry import Polygon
    >>> from centerline.geometry import Centerline
    >>> polygon = Polygon([[0, 0], [0, 4], [4, 4], [4, 0]])
    >>> attributes = {"id": 1, "name": "polygon", "valid": True}
    >>> centerline = Centerline(polygon, **attributes)
    >>> centerline.id == 1
    True
    >>> centerline.name
    'polygon'
    >>> centerline.geometry.geoms
    <shapely.geometry.base.GeometrySequence object at 0x7f7d24116210>

%package -n python3-centerline
Summary:	Calculate the centerline of a polygon
Provides:	python-centerline
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-centerline
Roads, rivers and similar linear structures are often represented by
long and complex polygons. Since one of the most important attributes of
a linear structure is its length, extracting that attribute from a
polygon can prove to be more or less difficult.
This library tries to solve this problem by creating the the polygon's
centerline using the `Voronoi diagram
<https://en.wikipedia.org/wiki/Voronoi_diagram>`_. For more info on how
to use this package, see the
`official documentation <http://centerline.readthedocs.io/>`_.
Features
^^^^^^^^
* A command-line script for creating centerlines from a vector source file and saving them into a destination vector file: ``create_centerlines``
    $ create_centerlines input.shp output.geojson
* The ``Centerline`` class that allows integration into your own workflow.
    >>> from shapely.geometry import Polygon
    >>> from centerline.geometry import Centerline
    >>> polygon = Polygon([[0, 0], [0, 4], [4, 4], [4, 0]])
    >>> attributes = {"id": 1, "name": "polygon", "valid": True}
    >>> centerline = Centerline(polygon, **attributes)
    >>> centerline.id == 1
    True
    >>> centerline.name
    'polygon'
    >>> centerline.geometry.geoms
    <shapely.geometry.base.GeometrySequence object at 0x7f7d24116210>

%package help
Summary:	Development documents and examples for centerline
Provides:	python3-centerline-doc
%description help
Roads, rivers and similar linear structures are often represented by
long and complex polygons. Since one of the most important attributes of
a linear structure is its length, extracting that attribute from a
polygon can prove to be more or less difficult.
This library tries to solve this problem by creating the the polygon's
centerline using the `Voronoi diagram
<https://en.wikipedia.org/wiki/Voronoi_diagram>`_. For more info on how
to use this package, see the
`official documentation <http://centerline.readthedocs.io/>`_.
Features
^^^^^^^^
* A command-line script for creating centerlines from a vector source file and saving them into a destination vector file: ``create_centerlines``
    $ create_centerlines input.shp output.geojson
* The ``Centerline`` class that allows integration into your own workflow.
    >>> from shapely.geometry import Polygon
    >>> from centerline.geometry import Centerline
    >>> polygon = Polygon([[0, 0], [0, 4], [4, 4], [4, 0]])
    >>> attributes = {"id": 1, "name": "polygon", "valid": True}
    >>> centerline = Centerline(polygon, **attributes)
    >>> centerline.id == 1
    True
    >>> centerline.name
    'polygon'
    >>> centerline.geometry.geoms
    <shapely.geometry.base.GeometrySequence object at 0x7f7d24116210>

%prep
%autosetup -n centerline-1.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-centerline -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.1-1
- Package Spec generated