%global _empty_manifest_terminate_build 0
Name:		python-Assemble
Version:	0.2.2
Release:	1
Summary:	Assemble: Assemble the packages!
License:	MIT
URL:		https://github.com/CorverDevelopment/Assemble/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/4e/ef/99c850084ec3fcb157c2afc1deadc2f09b69090084212e05eeda54fe4499/Assemble-0.2.2.tar.gz
BuildArch:	noarch

Requires:	python3-click
Requires:	python3-pip
Requires:	python3-Levenshtein
Requires:	python3-setuptools

%description
Assemble enables simplistic package building.
* Free software: MIT license
* Documentation: http://documentation.creeer.io/assemble/
* Source-code: https://github.com/corverdevelopment/assemble/
A quick example::
    # file: setup.py
    from assemble import get_package
    package = get_package()
    keywords = [
        "about", "this", "package"
    ]
    classifiers = [
        # https://pypi.python.org/pypi?%3Aaction=list_classifiers
        "Development Status :: 3 - Alpha",
        "Intended Audience :: Developers",
        "Natural Language :: English",
        "License :: OSI Approved :: MIT License",
        "Operating System :: OS Independent",
        "Programming Language :: Python",
        "Programming Language :: Python :: 2",
        "Programming Language :: Python :: 2.7",
        "Programming Language :: Python :: 3",
        "Programming Language :: Python :: 3.5",
        "Programming Language :: Python :: Implementation :: CPython",
        "Topic :: Software Development :: Libraries :: Python Modules",
    ]
    if __name__ == "__main__":
        package.setup(keywords, classifiers)
While developing your package, you can use the `test` command to run all your written tests
and you can use `requirements-scan` to build a list of all used packages.
    assemble test
    assemble requirements-scan > requirements.txt
When your package is ready and your repository is up-to-date, you can
register your package, patch the version, build your distribution,
upload it to PyPi and tag your repository.
    assemble version
    assemble build
    assemble upload
    assemble tag
When you have a clean GIT repository, ran your tests and want to publish right-away, you
can use the `publish` shortcut to run `version`, `build`, `upload` and `tag`.
    assemble publish
To register your package with PyPI, simple call `register` and Assemble will do the rest.
    assemble register

%package -n python3-Assemble
Summary:	Assemble: Assemble the packages!
Provides:	python-Assemble
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Assemble
Assemble enables simplistic package building.
* Free software: MIT license
* Documentation: http://documentation.creeer.io/assemble/
* Source-code: https://github.com/corverdevelopment/assemble/
A quick example::
    # file: setup.py
    from assemble import get_package
    package = get_package()
    keywords = [
        "about", "this", "package"
    ]
    classifiers = [
        # https://pypi.python.org/pypi?%3Aaction=list_classifiers
        "Development Status :: 3 - Alpha",
        "Intended Audience :: Developers",
        "Natural Language :: English",
        "License :: OSI Approved :: MIT License",
        "Operating System :: OS Independent",
        "Programming Language :: Python",
        "Programming Language :: Python :: 2",
        "Programming Language :: Python :: 2.7",
        "Programming Language :: Python :: 3",
        "Programming Language :: Python :: 3.5",
        "Programming Language :: Python :: Implementation :: CPython",
        "Topic :: Software Development :: Libraries :: Python Modules",
    ]
    if __name__ == "__main__":
        package.setup(keywords, classifiers)
While developing your package, you can use the `test` command to run all your written tests
and you can use `requirements-scan` to build a list of all used packages.
    assemble test
    assemble requirements-scan > requirements.txt
When your package is ready and your repository is up-to-date, you can
register your package, patch the version, build your distribution,
upload it to PyPi and tag your repository.
    assemble version
    assemble build
    assemble upload
    assemble tag
When you have a clean GIT repository, ran your tests and want to publish right-away, you
can use the `publish` shortcut to run `version`, `build`, `upload` and `tag`.
    assemble publish
To register your package with PyPI, simple call `register` and Assemble will do the rest.
    assemble register

%package help
Summary:	Development documents and examples for Assemble
Provides:	python3-Assemble-doc
%description help
Assemble enables simplistic package building.
* Free software: MIT license
* Documentation: http://documentation.creeer.io/assemble/
* Source-code: https://github.com/corverdevelopment/assemble/
A quick example::
    # file: setup.py
    from assemble import get_package
    package = get_package()
    keywords = [
        "about", "this", "package"
    ]
    classifiers = [
        # https://pypi.python.org/pypi?%3Aaction=list_classifiers
        "Development Status :: 3 - Alpha",
        "Intended Audience :: Developers",
        "Natural Language :: English",
        "License :: OSI Approved :: MIT License",
        "Operating System :: OS Independent",
        "Programming Language :: Python",
        "Programming Language :: Python :: 2",
        "Programming Language :: Python :: 2.7",
        "Programming Language :: Python :: 3",
        "Programming Language :: Python :: 3.5",
        "Programming Language :: Python :: Implementation :: CPython",
        "Topic :: Software Development :: Libraries :: Python Modules",
    ]
    if __name__ == "__main__":
        package.setup(keywords, classifiers)
While developing your package, you can use the `test` command to run all your written tests
and you can use `requirements-scan` to build a list of all used packages.
    assemble test
    assemble requirements-scan > requirements.txt
When your package is ready and your repository is up-to-date, you can
register your package, patch the version, build your distribution,
upload it to PyPi and tag your repository.
    assemble version
    assemble build
    assemble upload
    assemble tag
When you have a clean GIT repository, ran your tests and want to publish right-away, you
can use the `publish` shortcut to run `version`, `build`, `upload` and `tag`.
    assemble publish
To register your package with PyPI, simple call `register` and Assemble will do the rest.
    assemble register

%prep
%autosetup -n Assemble-0.2.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Assemble -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.2-1
- Package Spec generated