%global _empty_manifest_terminate_build 0
Name:		python-jottalib
Version:	0.5.1
Release:	1
Summary:	A library and tools to access the JottaCloud API
License:	GPLv3
URL:		https://github.com/havardgulldahl/jottalib
Source0:	https://mirrors.aliyun.com/pypi/web/packages/aa/4b/7a5dea988a7a76842738fa23ff8e397109ccb0a85702d10153ce9e46c3ca/jottalib-0.5.1.tar.gz
BuildArch:	noarch


%description
|Join the chat at https://gitter.im/havardgulldahl/jottalib|
|Requirements Status| |Build status master branch| |pypi version| |pypi downloads| |coverage|
This is a rich, pythonic interface to the Jottacloud backup/cloud
storage service. The service itself exposes a nice and simple HTTP REST
api, and this library wraps that interface in a python module, in the
hope that it may be useful.
This is a community project, not an official Jottacloud product. It is
developed `according to the company founder's
instructions <http://forum.jotta.no/jotta/topics/api_http>`__, with
write support reverse engineered `explicitly blessed by company
staff <http://forum.jotta.no/jotta/topics/jotta_api_for_remote_storage_fetch#reply_14928642>`__.
All code is GPLv3 licensed, and the `documentation is
online <https://pythonhosted.org/jottalib/>`__.
In addition to the general library, you'll also find different backup
tools, some different plugins as well as a FUSE implementation in here.

%package -n python3-jottalib
Summary:	A library and tools to access the JottaCloud API
Provides:	python-jottalib
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-jottalib
|Join the chat at https://gitter.im/havardgulldahl/jottalib|
|Requirements Status| |Build status master branch| |pypi version| |pypi downloads| |coverage|
This is a rich, pythonic interface to the Jottacloud backup/cloud
storage service. The service itself exposes a nice and simple HTTP REST
api, and this library wraps that interface in a python module, in the
hope that it may be useful.
This is a community project, not an official Jottacloud product. It is
developed `according to the company founder's
instructions <http://forum.jotta.no/jotta/topics/api_http>`__, with
write support reverse engineered `explicitly blessed by company
staff <http://forum.jotta.no/jotta/topics/jotta_api_for_remote_storage_fetch#reply_14928642>`__.
All code is GPLv3 licensed, and the `documentation is
online <https://pythonhosted.org/jottalib/>`__.
In addition to the general library, you'll also find different backup
tools, some different plugins as well as a FUSE implementation in here.

%package help
Summary:	Development documents and examples for jottalib
Provides:	python3-jottalib-doc
%description help
|Join the chat at https://gitter.im/havardgulldahl/jottalib|
|Requirements Status| |Build status master branch| |pypi version| |pypi downloads| |coverage|
This is a rich, pythonic interface to the Jottacloud backup/cloud
storage service. The service itself exposes a nice and simple HTTP REST
api, and this library wraps that interface in a python module, in the
hope that it may be useful.
This is a community project, not an official Jottacloud product. It is
developed `according to the company founder's
instructions <http://forum.jotta.no/jotta/topics/api_http>`__, with
write support reverse engineered `explicitly blessed by company
staff <http://forum.jotta.no/jotta/topics/jotta_api_for_remote_storage_fetch#reply_14928642>`__.
All code is GPLv3 licensed, and the `documentation is
online <https://pythonhosted.org/jottalib/>`__.
In addition to the general library, you'll also find different backup
tools, some different plugins as well as a FUSE implementation in here.

%prep
%autosetup -n jottalib-0.5.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-jottalib -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.1-1
- Package Spec generated