%global _empty_manifest_terminate_build 0
Name: python-pcg-gazebo
Version: 0.7.12
Release: 1
Summary: A Python package for rapid-prototyping and scripting of simulations for Gazebo
License: Apache-2.0
URL: https://github.com/boschresearch/pcg_gazebo
Source0: https://mirrors.aliyun.com/pypi/web/packages/2c/4d/54f64c004da3282e443765c702b08f1a4926301eb6686c9754ae274b2871/pcg_gazebo-0.7.12.tar.gz
BuildArch: noarch
Requires: python3-psutil
Requires: python3-Jinja2
Requires: python3-rospkg
Requires: python3-progress
Requires: python3-bokeh
Requires: python3-scikit-image
Requires: python3-noise
Requires: python3-yasha
Requires: python3-trimesh[easy]
Requires: python3-descartes
Requires: python3-lxml
Requires: python3-matplotlib
Requires: python3-numpy
Requires: python3-fcl
Requires: python3-triangle
Requires: python3-networkx
Requires: python3-pycollada
Requires: python3-jsonschema
Requires: python3-PyYAML
Requires: python3-xmltodict
Requires: python3-tabulate
Requires: python3-shapely
Requires: python3-psutil
Requires: python3-Jinja2
Requires: python3-lxml
Requires: python3-nbconvert
Requires: python3-rospkg
Requires: python3-matplotlib
Requires: python3-numpy
Requires: python3-pytest
Requires: python3-fcl
Requires: python3-pytest-console-scripts
Requires: python3-progress
Requires: python3-triangle
Requires: python3-bokeh
Requires: python3-networkx
Requires: python3-pypandoc
Requires: python3-scikit-image
Requires: python3-pycollada
Requires: python3-jsonschema
Requires: python3-noise
Requires: python3-yasha
Requires: python3-PyYAML
Requires: python3-mkdocs-awesome-pages-plugin
Requires: python3-pydoc-markdown
Requires: python3-mkdocs-material
Requires: python3-trimesh[easy]
Requires: python3-xmltodict
Requires: python3-descartes
Requires: python3-tabulate
Requires: python3-jupyterlab
Requires: python3-shapely
Requires: python3-psutil
Requires: python3-Jinja2
Requires: python3-lxml
Requires: python3-nbconvert
Requires: python3-rospkg
Requires: python3-matplotlib
Requires: python3-numpy
Requires: python3-fcl
Requires: python3-progress
Requires: python3-triangle
Requires: python3-bokeh
Requires: python3-networkx
Requires: python3-pypandoc
Requires: python3-scikit-image
Requires: python3-pycollada
Requires: python3-jsonschema
Requires: python3-noise
Requires: python3-yasha
Requires: python3-PyYAML
Requires: python3-mkdocs-material
Requires: python3-pydoc-markdown
Requires: python3-trimesh[easy]
Requires: python3-xmltodict
Requires: python3-descartes
Requires: python3-tabulate
Requires: python3-shapely
Requires: python3-psutil
Requires: python3-Jinja2
Requires: python3-lxml
Requires: python3-rospkg
Requires: python3-matplotlib
Requires: python3-numpy
Requires: python3-fcl
Requires: python3-progress
Requires: python3-triangle
Requires: python3-bokeh
Requires: python3-networkx
Requires: python3-scikit-image
Requires: python3-pycollada
Requires: python3-jsonschema
Requires: python3-noise
Requires: python3-yasha
Requires: python3-PyYAML
Requires: python3-trimesh[easy]
Requires: python3-xmltodict
Requires: python3-descartes
Requires: python3-tabulate
Requires: python3-jupyterlab
Requires: python3-shapely
Requires: python3-psutil
Requires: python3-Jinja2
Requires: python3-lxml
Requires: python3-nbconvert
Requires: python3-rospkg
Requires: python3-matplotlib
Requires: python3-numpy
Requires: python3-pytest
Requires: python3-fcl
Requires: python3-progress
Requires: python3-triangle
Requires: python3-bokeh
Requires: python3-networkx
Requires: python3-scikit-image
Requires: python3-pycollada
Requires: python3-jsonschema
Requires: python3-noise
Requires: python3-yasha
Requires: python3-PyYAML
Requires: python3-trimesh[easy]
Requires: python3-xmltodict
Requires: python3-descartes
Requires: python3-tabulate
Requires: python3-shapely
%description
|Python application| |Discord| |GitHub issues| |License| |PyPI| |PyPI -
Python Version|
The ``pcg_gazebo`` Python package is an Open Source Project extending
the simulation capabilities of the robotics simulator
`Gazebo `__ for automation and scripting of
Gazebo simulations.
Visit the `documentation
page `__ for more
information.
%package -n python3-pcg-gazebo
Summary: A Python package for rapid-prototyping and scripting of simulations for Gazebo
Provides: python-pcg-gazebo
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pcg-gazebo
|Python application| |Discord| |GitHub issues| |License| |PyPI| |PyPI -
Python Version|
The ``pcg_gazebo`` Python package is an Open Source Project extending
the simulation capabilities of the robotics simulator
`Gazebo `__ for automation and scripting of
Gazebo simulations.
Visit the `documentation
page `__ for more
information.
%package help
Summary: Development documents and examples for pcg-gazebo
Provides: python3-pcg-gazebo-doc
%description help
|Python application| |Discord| |GitHub issues| |License| |PyPI| |PyPI -
Python Version|
The ``pcg_gazebo`` Python package is an Open Source Project extending
the simulation capabilities of the robotics simulator
`Gazebo `__ for automation and scripting of
Gazebo simulations.
Visit the `documentation
page `__ for more
information.
%prep
%autosetup -n pcg_gazebo-0.7.12
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pcg-gazebo -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.7.12-1
- Package Spec generated