%global _empty_manifest_terminate_build 0
Name: python-pup
Version: 1.0.0a17
Release: 1
Summary: Pluggable Micro Packager
License: MIT
URL: https://github.com/mu-editor/pup/
Source0: https://mirrors.aliyun.com/pypi/web/packages/a5/5e/fc93b41f85e74f60aa46a6d11d9b5886c3b53449d30cf9a854e6d271362c/pup-1.0.0a17.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-httpx
Requires: python3-wheel
Requires: python3-pkginfo
Requires: python3-cookiecutter
Requires: python3-zstandard
Requires: python3-Pillow
Requires: python3-requirements-parser
Requires: python3-importlib-metadata
Requires: python3-importlib-resources
Requires: python3-dmgbuild
Requires: python3-coverage
Requires: python3-sphinx
Requires: python3-towncrier
Requires: python3-sphinx
Requires: python3-towncrier
Requires: python3-twine
Requires: python3-coverage
%description
``pup`` is (in the early stages of becoming) a packaging tool for Python GUI programs.
Fundamentally,
its *raison d'être* is producing macOS and Windows native packages
for distributing the `Mu Editor `_
to Python beginners around the world.
As a by-product of that,
it may very likely be effective at packaging
generic Python written GUI programs.
If that ever is the case,
then great.
Otherwise,
that's fine too.
The purpose,
again,
is to package `Mu Editor `_
for macOS and Windows distribution.
%package -n python3-pup
Summary: Pluggable Micro Packager
Provides: python-pup
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pup
``pup`` is (in the early stages of becoming) a packaging tool for Python GUI programs.
Fundamentally,
its *raison d'être* is producing macOS and Windows native packages
for distributing the `Mu Editor `_
to Python beginners around the world.
As a by-product of that,
it may very likely be effective at packaging
generic Python written GUI programs.
If that ever is the case,
then great.
Otherwise,
that's fine too.
The purpose,
again,
is to package `Mu Editor `_
for macOS and Windows distribution.
%package help
Summary: Development documents and examples for pup
Provides: python3-pup-doc
%description help
``pup`` is (in the early stages of becoming) a packaging tool for Python GUI programs.
Fundamentally,
its *raison d'être* is producing macOS and Windows native packages
for distributing the `Mu Editor `_
to Python beginners around the world.
As a by-product of that,
it may very likely be effective at packaging
generic Python written GUI programs.
If that ever is the case,
then great.
Otherwise,
that's fine too.
The purpose,
again,
is to package `Mu Editor `_
for macOS and Windows distribution.
%prep
%autosetup -n pup-1.0.0a17
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pup -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.0.0a17-1
- Package Spec generated