%global _empty_manifest_terminate_build 0
Name:		python-longling
Version:	1.3.36
Release:	1
Summary:	This project aims to provide some handy toolkit functions to help construct the architecture.
License:	LICENSE.txt
URL:		https://gitlab.com/tswsxk/longling.git
Source0:	https://mirrors.aliyun.com/pypi/web/packages/92/27/bea012fc73bf83711d3a9b0d3ab74a2364f2dbc5ce41ed99f25c5cac81ab/longling-1.3.36.tar.gz
BuildArch:	noarch

Requires:	python3-nbsphinx
Requires:	python3-m2r2
Requires:	python3-Image
Requires:	python3-recommonmark
Requires:	python3-ipython
Requires:	python3-sphinx-toggleprompt
Requires:	python3-pandas
Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-scikit-learn
Requires:	python3-gluonnlp
Requires:	python3-mxnet
Requires:	python3-torch
Requires:	python3-nni
Requires:	python3-matplotlib
Requires:	python3-tensorboardx
Requires:	python3-tensorboard
Requires:	python3-requests
Requires:	python3-rarfile
Requires:	python3-bs4
Requires:	python3-lxml
Requires:	python3-urllib3
Requires:	python3-pandas
Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-scikit-learn
Requires:	python3-pandas
Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-scikit-learn
Requires:	python3-gluonnlp
Requires:	python3-mxnet
Requires:	python3-torch
Requires:	python3-nni
Requires:	python3-matplotlib
Requires:	python3-tensorboardx
Requires:	python3-tensorboard
Requires:	python3-pandas
Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-tensorboardx
Requires:	python3-scikit-learn
Requires:	python3-matplotlib
Requires:	python3-tensorboardx
Requires:	python3-tensorboard
Requires:	python3-gluonnlp
Requires:	python3-mxnet
Requires:	python3-requests
Requires:	python3-rarfile
Requires:	python3-bs4
Requires:	python3-lxml
Requires:	python3-urllib3
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-pytest-flake8
Requires:	python3-pandas
Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-scikit-learn
Requires:	python3-gluonnlp
Requires:	python3-mxnet
Requires:	python3-torch
Requires:	python3-nni
Requires:	python3-matplotlib
Requires:	python3-tensorboardx
Requires:	python3-tensorboard
Requires:	python3-requests
Requires:	python3-rarfile
Requires:	python3-bs4
Requires:	python3-lxml
Requires:	python3-urllib3
Requires:	python3-torch
Requires:	python3-matplotlib
Requires:	python3-pip
Requires:	python3-tqdm
Requires:	python3-fire
Requires:	python3-PyYAML
Requires:	python3-toml
Requires:	python3-multiprocess
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-pytest-flake8
Requires:	python3-sphinx
Requires:	python3-sphinx-rtd-theme
Requires:	python3-nbsphinx
Requires:	python3-m2r2
Requires:	python3-Image
Requires:	python3-recommonmark
Requires:	python3-ipython
Requires:	python3-sphinx-toggleprompt
Requires:	python3-setuptools
Requires:	python3-wheel
Requires:	python3-twine
Requires:	python3-gluonnlp
Requires:	python3-mxnet
Requires:	python3-torch
Requires:	python3-pandas
Requires:	python3-numpy
Requires:	python3-matplotlib
Requires:	python3-sphinx
Requires:	python3-sphinx-rtd-theme
Requires:	python3-tensorboard

%description
This project aims to provide some handy toolkit functions to help construct the architecture.
Tutorial and full documentation can be found in https://longling.readthedocs.io/zh/latest/index.html.



%package -n python3-longling
Summary:	This project aims to provide some handy toolkit functions to help construct the architecture.
Provides:	python-longling
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-longling
This project aims to provide some handy toolkit functions to help construct the architecture.
Tutorial and full documentation can be found in https://longling.readthedocs.io/zh/latest/index.html.



%package help
Summary:	Development documents and examples for longling
Provides:	python3-longling-doc
%description help
This project aims to provide some handy toolkit functions to help construct the architecture.
Tutorial and full documentation can be found in https://longling.readthedocs.io/zh/latest/index.html.



%prep
%autosetup -n longling-1.3.36

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-longling -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.36-1
- Package Spec generated