%global _empty_manifest_terminate_build 0
Name: python-scam
Version: 0.3.12
Release: 1
Summary: Source Code Analyzing Maching is an application for the analysis of similarities between source code files. Currently with Python, Java, C, and C++ file checking capabilities.
License: MIT License
URL: https://github.com/SourceCodeAnalyzingMachine/SCAM_Public
Source0: https://mirrors.aliyun.com/pypi/web/packages/11/67/f8c423c0d909ae120fa4759248732cad7362a96cdf616a2c881fb851a12b/scam-0.3.12.tar.gz
BuildArch: noarch
Requires: python3-javalang
Requires: python3-PySide2
Requires: python3-matplotlib
Requires: python3-networkx
Requires: python3-clang
Requires: python3-pycparser
Requires: python3-grave
%description
# Source Code Analyzing Machine
[GitHub Repo Link](https://github.com/SourceCodeAnalyzingMachine/SCAM_Public)
- A locally run application that demonstrates different matching algorithms
- Current release compares files as a one to one connection
- Outputs given percentage of similarity and highlighted visualization of the matching sections of input documents
- Supports C, C++, Java, and Python files
## Getting Started
Install PySide2: `pip install scam`
Run from directly outside `source` directory: `python3 ./source/scam.py`
## Getting Started
#### STEP 1
it is recommended to create and navigate to virtual environemnt using python to run script
python3.8 -m venv
source /bin/activate
#### STEP 2
install source_analyzer python package from Python Package Index.
**Note:** must be running python version 3.8 or greater
pip install scam
###### OR
Download the latest built compressed file release from [source_analyzer-X.X.X.tar.gz](https://github.com/SourceCodeAnalyzingMachine/SCAM_Public/tree/master/dist)
then install downloaded file
pip3 install //scam-0.0.2.tar.gz
#### STEP 3
(make sure xlaunch is running)
run script
scam
## Known Errors/Issues
Issues-
Python files featuring a heavy amount of print statements may cause skewed data.
## Project Group: Codalyzers
- Djoni Austin | @dcaust1n
- Jared Dawson | @lukinator1
- Shane Eising | @seising99
- Julian Marott | @jmmoratta
## References:
https://theory.stanford.edu/~aiken/publications/papers/sigmod03.pdf
%package -n python3-scam
Summary: Source Code Analyzing Maching is an application for the analysis of similarities between source code files. Currently with Python, Java, C, and C++ file checking capabilities.
Provides: python-scam
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-scam
# Source Code Analyzing Machine
[GitHub Repo Link](https://github.com/SourceCodeAnalyzingMachine/SCAM_Public)
- A locally run application that demonstrates different matching algorithms
- Current release compares files as a one to one connection
- Outputs given percentage of similarity and highlighted visualization of the matching sections of input documents
- Supports C, C++, Java, and Python files
## Getting Started
Install PySide2: `pip install scam`
Run from directly outside `source` directory: `python3 ./source/scam.py`
## Getting Started
#### STEP 1
it is recommended to create and navigate to virtual environemnt using python to run script
python3.8 -m venv
source /bin/activate
#### STEP 2
install source_analyzer python package from Python Package Index.
**Note:** must be running python version 3.8 or greater
pip install scam
###### OR
Download the latest built compressed file release from [source_analyzer-X.X.X.tar.gz](https://github.com/SourceCodeAnalyzingMachine/SCAM_Public/tree/master/dist)
then install downloaded file
pip3 install //scam-0.0.2.tar.gz
#### STEP 3
(make sure xlaunch is running)
run script
scam
## Known Errors/Issues
Issues-
Python files featuring a heavy amount of print statements may cause skewed data.
## Project Group: Codalyzers
- Djoni Austin | @dcaust1n
- Jared Dawson | @lukinator1
- Shane Eising | @seising99
- Julian Marott | @jmmoratta
## References:
https://theory.stanford.edu/~aiken/publications/papers/sigmod03.pdf
%package help
Summary: Development documents and examples for scam
Provides: python3-scam-doc
%description help
# Source Code Analyzing Machine
[GitHub Repo Link](https://github.com/SourceCodeAnalyzingMachine/SCAM_Public)
- A locally run application that demonstrates different matching algorithms
- Current release compares files as a one to one connection
- Outputs given percentage of similarity and highlighted visualization of the matching sections of input documents
- Supports C, C++, Java, and Python files
## Getting Started
Install PySide2: `pip install scam`
Run from directly outside `source` directory: `python3 ./source/scam.py`
## Getting Started
#### STEP 1
it is recommended to create and navigate to virtual environemnt using python to run script
python3.8 -m venv
source /bin/activate
#### STEP 2
install source_analyzer python package from Python Package Index.
**Note:** must be running python version 3.8 or greater
pip install scam
###### OR
Download the latest built compressed file release from [source_analyzer-X.X.X.tar.gz](https://github.com/SourceCodeAnalyzingMachine/SCAM_Public/tree/master/dist)
then install downloaded file
pip3 install //scam-0.0.2.tar.gz
#### STEP 3
(make sure xlaunch is running)
run script
scam
## Known Errors/Issues
Issues-
Python files featuring a heavy amount of print statements may cause skewed data.
## Project Group: Codalyzers
- Djoni Austin | @dcaust1n
- Jared Dawson | @lukinator1
- Shane Eising | @seising99
- Julian Marott | @jmmoratta
## References:
https://theory.stanford.edu/~aiken/publications/papers/sigmod03.pdf
%prep
%autosetup -n scam-0.3.12
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-scam -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.3.12-1
- Package Spec generated