%global _empty_manifest_terminate_build 0
Name: python-robotframework-notifications
Version: 1.2.0
Release: 1
Summary: Send notifications to Slack or Mattermost using Robot Framework.
License: MIT
URL: https://github.com/tlolkema/RobotNotifications
Source0: https://mirrors.aliyun.com/pypi/web/packages/86/b8/92110915a598b412f8502aaae10cb083b37f488c536d4bd7af9a540aaf9d/robotframework-notifications-1.2.0.tar.gz
BuildArch: noarch
Requires: python3-requests
%description
# RobotNotifications
Send notifications to Slack or Mattermost using Robot Framework.
Can be used both as library or listener.
## Installation
The recommended installation method is pip:
pip install robotframework-notifications
Running this command installs also the latest version of Requests
## Use as listener
```robot --listener "RobotNotifications;https://webhook_url;end_test;summary" test.robot```
Listeners are taken into use from the command line with the --listener option.
- The first argument is the name of the library.
- The second argument is the webhook url.
- Based on your preferences pick the next argument(s) from the table
Seperate the arguments with a semicolon ;
## Optional Arguments
| Argument | Description | Example |
|-------------- |-------------------- |------------------------------------------------------------------------------------------------------------------- |
| end_suite | Post suite results | |
| summary | Post a report summary |
| end_test | Post failing tests | |
| end_test_all | Post all tests | |
## Use as library
Besides the listener functionality this library allows you to post a custom message with the use of the keyword "Post Message To Channel"
To use RobotNotifications in Robot Framework, the library needs to be imported using the ``Library`` setting as any other library. The library needs the webhook url from Slack or Mattermost as an argument.
Example:
```robotframework
*** Settings ***
Library RobotNotifications https://hooks.slack.com/services/--your-webhook--
```
You can retrieve this webhook url in Slack or Mattermost.
Example 2:
```robotframework
*** Settings ***
Library RobotNotifications https://hooks.slack.com/services/--your-webhook--
... end_suite end_test
```
## Write a custom message
After importing the library you have access to the keyword ``Post Message To Channel``
This keyword has one mandatory argument which is the message to post to the channel, and several optional arguments.
| Argument | Description | Required |
| ---------- | :----------------------------------------------------------- | -------- |
| text | Markdown-formatted message to display in the post. | YES |
| channel | Overrides the channel the message posts in. Use the channel’s name and not the display name. Defaults to the channel set during webhook creation. | NO |
| username | Overrides the username the message posts as. Defaults to the username set during webhook creation or the webhook creator’s username if the former was not set. | NO |
| icon_url | Overrides the profile picture the message posts with. Defaults to the URL set during webhook creation or the webhook creator’s profile picture if the former was not set. | NO |
| icon_emoji | Overrides the profile picture and `icon_url` parameter. Defaults to none and is not set during webhook creation. | NO |
| props | Sets the post `props`, a JSON property bag for storing extra or meta data on the post. | NO |
Example:
```robotframework
*** Settings ***
Library RobotNotifications https://hooks.slack.com/services/--your-webhook--
*** Test Cases ***
Example Test
Post Message To Channel This is a custom message! icon_emoji=robot_face username=Robot
... channel=robot-notifications
```
The above example shows how the ``Post Message To Channel`` can be used in Robot Framework.
## Retrieve webhook
Slack
> https://slack.com/intl/en-lv/help/articles/115005265063-incoming-webhooks-for-slack
Mattermost
> https://docs.mattermost.com/developer/webhooks-incoming.html#simple-incoming-webhook
%package -n python3-robotframework-notifications
Summary: Send notifications to Slack or Mattermost using Robot Framework.
Provides: python-robotframework-notifications
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-robotframework-notifications
# RobotNotifications
Send notifications to Slack or Mattermost using Robot Framework.
Can be used both as library or listener.
## Installation
The recommended installation method is pip:
pip install robotframework-notifications
Running this command installs also the latest version of Requests
## Use as listener
```robot --listener "RobotNotifications;https://webhook_url;end_test;summary" test.robot```
Listeners are taken into use from the command line with the --listener option.
- The first argument is the name of the library.
- The second argument is the webhook url.
- Based on your preferences pick the next argument(s) from the table
Seperate the arguments with a semicolon ;
## Optional Arguments
| Argument | Description | Example |
|-------------- |-------------------- |------------------------------------------------------------------------------------------------------------------- |
| end_suite | Post suite results | |
| summary | Post a report summary |
| end_test | Post failing tests | |
| end_test_all | Post all tests | |
## Use as library
Besides the listener functionality this library allows you to post a custom message with the use of the keyword "Post Message To Channel"
To use RobotNotifications in Robot Framework, the library needs to be imported using the ``Library`` setting as any other library. The library needs the webhook url from Slack or Mattermost as an argument.
Example:
```robotframework
*** Settings ***
Library RobotNotifications https://hooks.slack.com/services/--your-webhook--
```
You can retrieve this webhook url in Slack or Mattermost.
Example 2:
```robotframework
*** Settings ***
Library RobotNotifications https://hooks.slack.com/services/--your-webhook--
... end_suite end_test
```
## Write a custom message
After importing the library you have access to the keyword ``Post Message To Channel``
This keyword has one mandatory argument which is the message to post to the channel, and several optional arguments.
| Argument | Description | Required |
| ---------- | :----------------------------------------------------------- | -------- |
| text | Markdown-formatted message to display in the post. | YES |
| channel | Overrides the channel the message posts in. Use the channel’s name and not the display name. Defaults to the channel set during webhook creation. | NO |
| username | Overrides the username the message posts as. Defaults to the username set during webhook creation or the webhook creator’s username if the former was not set. | NO |
| icon_url | Overrides the profile picture the message posts with. Defaults to the URL set during webhook creation or the webhook creator’s profile picture if the former was not set. | NO |
| icon_emoji | Overrides the profile picture and `icon_url` parameter. Defaults to none and is not set during webhook creation. | NO |
| props | Sets the post `props`, a JSON property bag for storing extra or meta data on the post. | NO |
Example:
```robotframework
*** Settings ***
Library RobotNotifications https://hooks.slack.com/services/--your-webhook--
*** Test Cases ***
Example Test
Post Message To Channel This is a custom message! icon_emoji=robot_face username=Robot
... channel=robot-notifications
```
The above example shows how the ``Post Message To Channel`` can be used in Robot Framework.
## Retrieve webhook
Slack
> https://slack.com/intl/en-lv/help/articles/115005265063-incoming-webhooks-for-slack
Mattermost
> https://docs.mattermost.com/developer/webhooks-incoming.html#simple-incoming-webhook
%package help
Summary: Development documents and examples for robotframework-notifications
Provides: python3-robotframework-notifications-doc
%description help
# RobotNotifications
Send notifications to Slack or Mattermost using Robot Framework.
Can be used both as library or listener.
## Installation
The recommended installation method is pip:
pip install robotframework-notifications
Running this command installs also the latest version of Requests
## Use as listener
```robot --listener "RobotNotifications;https://webhook_url;end_test;summary" test.robot```
Listeners are taken into use from the command line with the --listener option.
- The first argument is the name of the library.
- The second argument is the webhook url.
- Based on your preferences pick the next argument(s) from the table
Seperate the arguments with a semicolon ;
## Optional Arguments
| Argument | Description | Example |
|-------------- |-------------------- |------------------------------------------------------------------------------------------------------------------- |
| end_suite | Post suite results | |
| summary | Post a report summary |
| end_test | Post failing tests | |
| end_test_all | Post all tests | |
## Use as library
Besides the listener functionality this library allows you to post a custom message with the use of the keyword "Post Message To Channel"
To use RobotNotifications in Robot Framework, the library needs to be imported using the ``Library`` setting as any other library. The library needs the webhook url from Slack or Mattermost as an argument.
Example:
```robotframework
*** Settings ***
Library RobotNotifications https://hooks.slack.com/services/--your-webhook--
```
You can retrieve this webhook url in Slack or Mattermost.
Example 2:
```robotframework
*** Settings ***
Library RobotNotifications https://hooks.slack.com/services/--your-webhook--
... end_suite end_test
```
## Write a custom message
After importing the library you have access to the keyword ``Post Message To Channel``
This keyword has one mandatory argument which is the message to post to the channel, and several optional arguments.
| Argument | Description | Required |
| ---------- | :----------------------------------------------------------- | -------- |
| text | Markdown-formatted message to display in the post. | YES |
| channel | Overrides the channel the message posts in. Use the channel’s name and not the display name. Defaults to the channel set during webhook creation. | NO |
| username | Overrides the username the message posts as. Defaults to the username set during webhook creation or the webhook creator’s username if the former was not set. | NO |
| icon_url | Overrides the profile picture the message posts with. Defaults to the URL set during webhook creation or the webhook creator’s profile picture if the former was not set. | NO |
| icon_emoji | Overrides the profile picture and `icon_url` parameter. Defaults to none and is not set during webhook creation. | NO |
| props | Sets the post `props`, a JSON property bag for storing extra or meta data on the post. | NO |
Example:
```robotframework
*** Settings ***
Library RobotNotifications https://hooks.slack.com/services/--your-webhook--
*** Test Cases ***
Example Test
Post Message To Channel This is a custom message! icon_emoji=robot_face username=Robot
... channel=robot-notifications
```
The above example shows how the ``Post Message To Channel`` can be used in Robot Framework.
## Retrieve webhook
Slack
> https://slack.com/intl/en-lv/help/articles/115005265063-incoming-webhooks-for-slack
Mattermost
> https://docs.mattermost.com/developer/webhooks-incoming.html#simple-incoming-webhook
%prep
%autosetup -n robotframework-notifications-1.2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-robotframework-notifications -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 1.2.0-1
- Package Spec generated