%global _empty_manifest_terminate_build 0
Name: python-admindojo
Version: 0.1.28
Release: 1
Summary: The admindojo client for VMs
License: MIT license
URL: https://github.com/admindojo/admindojo-client
Source0: https://mirrors.aliyun.com/pypi/web/packages/f8/10/7a5261aaddc95a7d6bdbd2afad28e377ac0269afd936048cf75ef3f1d341/admindojo-0.1.28.tar.gz
BuildArch: noarch
Requires: python3-Click
Requires: python3-termcolor
Requires: python3-click-default-group
%description
admindojo.org
# Introduction
admindojo is a free, interactive Linux tutorial for (junior) sysadmins.
Using local virtual machines, admindojo provides real-world scenarios in real environments.
This repository contains the client that is used inside each training VM.
Visit [admindojo.org](https://admindojo.org/getting-started) for more information.
# Basic Usage
``admindojo start`` : Start training
``admindojo check`` : Run check and calculate score
``admindojo --help``: help
# License
Free software: MIT license
# Credits
- Package templating tool [https://github.com/audreyr/cookiecutter](ookiecutter)
- Package template [https://github.com/audreyr/cookiecutter-pypackage](audreyr/cookiecutter-pypackage)
%package -n python3-admindojo
Summary: The admindojo client for VMs
Provides: python-admindojo
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-admindojo
admindojo.org
# Introduction
admindojo is a free, interactive Linux tutorial for (junior) sysadmins.
Using local virtual machines, admindojo provides real-world scenarios in real environments.
This repository contains the client that is used inside each training VM.
Visit [admindojo.org](https://admindojo.org/getting-started) for more information.
# Basic Usage
``admindojo start`` : Start training
``admindojo check`` : Run check and calculate score
``admindojo --help``: help
# License
Free software: MIT license
# Credits
- Package templating tool [https://github.com/audreyr/cookiecutter](ookiecutter)
- Package template [https://github.com/audreyr/cookiecutter-pypackage](audreyr/cookiecutter-pypackage)
%package help
Summary: Development documents and examples for admindojo
Provides: python3-admindojo-doc
%description help
admindojo.org
# Introduction
admindojo is a free, interactive Linux tutorial for (junior) sysadmins.
Using local virtual machines, admindojo provides real-world scenarios in real environments.
This repository contains the client that is used inside each training VM.
Visit [admindojo.org](https://admindojo.org/getting-started) for more information.
# Basic Usage
``admindojo start`` : Start training
``admindojo check`` : Run check and calculate score
``admindojo --help``: help
# License
Free software: MIT license
# Credits
- Package templating tool [https://github.com/audreyr/cookiecutter](ookiecutter)
- Package template [https://github.com/audreyr/cookiecutter-pypackage](audreyr/cookiecutter-pypackage)
%prep
%autosetup -n admindojo-0.1.28
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-admindojo -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.1.28-1
- Package Spec generated