%global _empty_manifest_terminate_build 0
Name:		python-pip-outdated
Version:	0.6.0
Release:	1
Summary:	Find outdated dependencies in your requirements.txt or setup.cfg
License:	MIT
URL:		https://github.com/eight04/pip-outdated
Source0:	https://mirrors.aliyun.com/pypi/web/packages/cf/ee/a2a616acc1d69bc16b4de245c21054f5671b4eb8206750355fa72e6a4d9d/pip-outdated-0.6.0.tar.gz
BuildArch:	noarch

Requires:	python3-aiodns
Requires:	python3-aiohttp
Requires:	python3-colorama
Requires:	python3-packaging
Requires:	python3-setuptools
Requires:	python3-termcolor
Requires:	python3-terminaltables

%description
Find outdated dependencies in your requirements.txt or setup.cfg file. Report missing/outdated/incompatible packages with table and colors.
This tool compares the version number with the version specifier in ``requirements.txt`` or ``setup.cfg``. If you just want to list all updatable package, simply use ``pip list --outdated`` command.

%package -n python3-pip-outdated
Summary:	Find outdated dependencies in your requirements.txt or setup.cfg
Provides:	python-pip-outdated
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pip-outdated
Find outdated dependencies in your requirements.txt or setup.cfg file. Report missing/outdated/incompatible packages with table and colors.
This tool compares the version number with the version specifier in ``requirements.txt`` or ``setup.cfg``. If you just want to list all updatable package, simply use ``pip list --outdated`` command.

%package help
Summary:	Development documents and examples for pip-outdated
Provides:	python3-pip-outdated-doc
%description help
Find outdated dependencies in your requirements.txt or setup.cfg file. Report missing/outdated/incompatible packages with table and colors.
This tool compares the version number with the version specifier in ``requirements.txt`` or ``setup.cfg``. If you just want to list all updatable package, simply use ``pip list --outdated`` command.

%prep
%autosetup -n pip-outdated-0.6.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pip-outdated -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.0-1
- Package Spec generated