%global _empty_manifest_terminate_build 0
Name: python-ai2thor-colab
Version: 0.1.2
Release: 1
Summary: Utility functions for using AI2-THOR with Google Colab.
License: Apache 2.0
URL: https://github.com/allenai/ai2thor-colab
Source0: https://mirrors.aliyun.com/pypi/web/packages/f9/6c/60da4dfb2ee22380a3cae50cd0e07f63f54c6cd857e020fae8a8a14014d8/ai2thor_colab-0.1.2.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-moviepy
Requires: python3-pandas
Requires: python3-ai2thor
Requires: python3-Pillow
%description
Run AI2-THOR on the Cloud using Google Colab
## 💡 Templates
#### 💪 Full Starter Template
To get started, we recommend saving a copy of the AI2-THOR Colab Full Starter Template to your drive. It goes over many helper functions that are often useful.
https://user-images.githubusercontent.com/28768645/119420726-06d8bc80-bcb2-11eb-9acf-e9b151121506.mp4
#### 👑 Minimal Starter Template
We also provide a Minimal Starter Template that does not showcase any helper functions. This is often useful as a starting point to minimally reproduce issues, highlight, or test functionality.
![image](https://user-images.githubusercontent.com/28768645/119420252-e5c39c00-bcb0-11eb-84d8-98ed862a687b.png)
## 🐱💻 Setup Overview
#### 💻 Installation
Using Python's packaging manager, `ai2thor_colab` can be installed with
```python
pip install ai2thor_colab
```
#### 🔥 Start X Server
AI2-THOR requires an X Server to run on a Linux machine. It allows us to open a Unity window where we can render scenes and observe images. Colab runs Linux, but it does not start an X Server by default. Using `ai2thor_colab.start_xserver()`, we can install all required X Server dependencies and start it up:
```python
import ai2thor_colab
ai2thor_colab.start_xserver()
```
## 💬 Support
**Questions.** If you have any questions on AI2-THOR, please ask them on [AI2-THOR's GitHub Discussions Page](https://github.com/allenai/ai2thor/discussions).
**Issues.** If you encounter any issues while using AI2-THOR, please open an [Issue on AI2-THOR's GitHub](https://github.com/allenai/ai2thor/issues). If you encounter an issue with AI2-THOR Colab, please open an [Issue on our GitHub](https://github.com/allenai/ai2thor-colab/issues)
## 🏫 Learn more
| Section | Description |
| :-- | :-- |
| [AI2-THOR Website](https://ai2thor.allenai.org/) | The AI2-THOR website, which contains extensive documentation on using the API. |
| [AI2-THOR GitHub](https://github.com/allenai/ai2thor) | Contains the source code and development of AI2-THOR. |
| [AI2-THOR Demo](https://ai2thor.allenai.org/demo/) | Interact and play with AI2-THOR live in the browser. |
## 👋 Our Team
AI2-THOR and AI2-THOR Colab are open-source projects built by the [PRIOR team](//prior.allenai.org) at the [Allen Institute for AI](//allenai.org) (AI2).
AI2 is a non-profit institute with the mission to contribute to humanity through high-impact AI research and engineering.
%package -n python3-ai2thor-colab
Summary: Utility functions for using AI2-THOR with Google Colab.
Provides: python-ai2thor-colab
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ai2thor-colab
Run AI2-THOR on the Cloud using Google Colab
## 💡 Templates
#### 💪 Full Starter Template
To get started, we recommend saving a copy of the AI2-THOR Colab Full Starter Template to your drive. It goes over many helper functions that are often useful.
https://user-images.githubusercontent.com/28768645/119420726-06d8bc80-bcb2-11eb-9acf-e9b151121506.mp4
#### 👑 Minimal Starter Template
We also provide a Minimal Starter Template that does not showcase any helper functions. This is often useful as a starting point to minimally reproduce issues, highlight, or test functionality.
![image](https://user-images.githubusercontent.com/28768645/119420252-e5c39c00-bcb0-11eb-84d8-98ed862a687b.png)
## 🐱💻 Setup Overview
#### 💻 Installation
Using Python's packaging manager, `ai2thor_colab` can be installed with
```python
pip install ai2thor_colab
```
#### 🔥 Start X Server
AI2-THOR requires an X Server to run on a Linux machine. It allows us to open a Unity window where we can render scenes and observe images. Colab runs Linux, but it does not start an X Server by default. Using `ai2thor_colab.start_xserver()`, we can install all required X Server dependencies and start it up:
```python
import ai2thor_colab
ai2thor_colab.start_xserver()
```
## 💬 Support
**Questions.** If you have any questions on AI2-THOR, please ask them on [AI2-THOR's GitHub Discussions Page](https://github.com/allenai/ai2thor/discussions).
**Issues.** If you encounter any issues while using AI2-THOR, please open an [Issue on AI2-THOR's GitHub](https://github.com/allenai/ai2thor/issues). If you encounter an issue with AI2-THOR Colab, please open an [Issue on our GitHub](https://github.com/allenai/ai2thor-colab/issues)
## 🏫 Learn more
| Section | Description |
| :-- | :-- |
| [AI2-THOR Website](https://ai2thor.allenai.org/) | The AI2-THOR website, which contains extensive documentation on using the API. |
| [AI2-THOR GitHub](https://github.com/allenai/ai2thor) | Contains the source code and development of AI2-THOR. |
| [AI2-THOR Demo](https://ai2thor.allenai.org/demo/) | Interact and play with AI2-THOR live in the browser. |
## 👋 Our Team
AI2-THOR and AI2-THOR Colab are open-source projects built by the [PRIOR team](//prior.allenai.org) at the [Allen Institute for AI](//allenai.org) (AI2).
AI2 is a non-profit institute with the mission to contribute to humanity through high-impact AI research and engineering.
%package help
Summary: Development documents and examples for ai2thor-colab
Provides: python3-ai2thor-colab-doc
%description help
Run AI2-THOR on the Cloud using Google Colab
## 💡 Templates
#### 💪 Full Starter Template
To get started, we recommend saving a copy of the AI2-THOR Colab Full Starter Template to your drive. It goes over many helper functions that are often useful.
https://user-images.githubusercontent.com/28768645/119420726-06d8bc80-bcb2-11eb-9acf-e9b151121506.mp4
#### 👑 Minimal Starter Template
We also provide a Minimal Starter Template that does not showcase any helper functions. This is often useful as a starting point to minimally reproduce issues, highlight, or test functionality.
![image](https://user-images.githubusercontent.com/28768645/119420252-e5c39c00-bcb0-11eb-84d8-98ed862a687b.png)
## 🐱💻 Setup Overview
#### 💻 Installation
Using Python's packaging manager, `ai2thor_colab` can be installed with
```python
pip install ai2thor_colab
```
#### 🔥 Start X Server
AI2-THOR requires an X Server to run on a Linux machine. It allows us to open a Unity window where we can render scenes and observe images. Colab runs Linux, but it does not start an X Server by default. Using `ai2thor_colab.start_xserver()`, we can install all required X Server dependencies and start it up:
```python
import ai2thor_colab
ai2thor_colab.start_xserver()
```
## 💬 Support
**Questions.** If you have any questions on AI2-THOR, please ask them on [AI2-THOR's GitHub Discussions Page](https://github.com/allenai/ai2thor/discussions).
**Issues.** If you encounter any issues while using AI2-THOR, please open an [Issue on AI2-THOR's GitHub](https://github.com/allenai/ai2thor/issues). If you encounter an issue with AI2-THOR Colab, please open an [Issue on our GitHub](https://github.com/allenai/ai2thor-colab/issues)
## 🏫 Learn more
| Section | Description |
| :-- | :-- |
| [AI2-THOR Website](https://ai2thor.allenai.org/) | The AI2-THOR website, which contains extensive documentation on using the API. |
| [AI2-THOR GitHub](https://github.com/allenai/ai2thor) | Contains the source code and development of AI2-THOR. |
| [AI2-THOR Demo](https://ai2thor.allenai.org/demo/) | Interact and play with AI2-THOR live in the browser. |
## 👋 Our Team
AI2-THOR and AI2-THOR Colab are open-source projects built by the [PRIOR team](//prior.allenai.org) at the [Allen Institute for AI](//allenai.org) (AI2).
AI2 is a non-profit institute with the mission to contribute to humanity through high-impact AI research and engineering.
%prep
%autosetup -n ai2thor_colab-0.1.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ai2thor-colab -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.1.2-1
- Package Spec generated