%global _empty_manifest_terminate_build 0
Name: python-cfbfastR-py
Version: 0.0.28
Release: 1
Summary: Retrieve American football data in Python
License: MIT
URL: https://github.com/saiemgilani/cfbfastR-py
Source0: https://mirrors.aliyun.com/pypi/web/packages/20/37/57f590922cfea2d9f8d43fb6b18face0dd7163c476e522af0679290d0b03/cfbfastR-py-0.0.28.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-beautifulsoup4
Requires: python3-requests
Requires: python3-lxml
Requires: python3-pyarrow
Requires: python3-pygithub
Requires: python3-scipy
Requires: python3-matplotlib
Requires: python3-tqdm
Requires: python3-attrs
Requires: python3-xgboost
Requires: python3-pytest
Requires: python3-mypy
Requires: python3-pytest-cov
Requires: python3-pytest-xdist
%description
# cfbfastR-py
![Lifecycle:experimental](https://img.shields.io/badge/lifecycle-experimental-orange.svg?style=for-the-badge&logo=github)
[![PyPI](https://img.shields.io/pypi/v/cfbfastR-py?label=cfbfastR-py&logo=python&style=for-the-badge)](https://pypi.org/project/cfbfastR-py/)
![Contributors](https://img.shields.io/github/contributors/saiemgilani/cfbfastR-py?style=for-the-badge)
[![Twitter
Follow](https://img.shields.io/twitter/follow/cfbfastR?color=blue&label=%40cfbfastR&logo=twitter&style=for-the-badge)](https://twitter.com/cfbfastR)
See [CHANGELOG.md](https://cfbfastR-py.sportsdataverse.org/CHANGELOG) for details.
The goal of [cfbfastR-py](https://cfbfastR-py.sportsdataverse.org) is to provide the community with a python package for working with American Football data as a companion to the [cfbfastR](https://saiemgilani.github.io/cfbfastR) R package. Beyond data aggregation and tidying ease, one of the multitude of services that [cfbfastR-py](https://cfbfastR-py.sportsdataverse.org) provides is for benchmarking open-source expected points and win probability metrics.
## Installation
cfbfastR-py can be installed via pip:
```bash
pip install cfbfastR-py
```
or from the repo (which may at times be more up to date):
```bash
git clone https://github.com/saiemgilani/cfbfastR-py
cd cfbfastR-py
pip install -e .
```
# **Our Authors**
- [Saiem Gilani](https://twitter.com/saiemgilani)
## **Citations**
To cite the [**`cfbfastR-py`**](https://cfbfastR-py.sportsdataverse.org) Python package in publications, use:
BibTex Citation
```bibtex
@misc{saiemgilani2021cfbfastRpy,
author = {Gilani, Saiem},
title = {cfbfastR-py: The SportsDataverse's Python Package for American Football Data.},
url = {https://cfbfastR-py.sportsdataverse.org},
season = {2021}
}
```
%package -n python3-cfbfastR-py
Summary: Retrieve American football data in Python
Provides: python-cfbfastR-py
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cfbfastR-py
# cfbfastR-py
![Lifecycle:experimental](https://img.shields.io/badge/lifecycle-experimental-orange.svg?style=for-the-badge&logo=github)
[![PyPI](https://img.shields.io/pypi/v/cfbfastR-py?label=cfbfastR-py&logo=python&style=for-the-badge)](https://pypi.org/project/cfbfastR-py/)
![Contributors](https://img.shields.io/github/contributors/saiemgilani/cfbfastR-py?style=for-the-badge)
[![Twitter
Follow](https://img.shields.io/twitter/follow/cfbfastR?color=blue&label=%40cfbfastR&logo=twitter&style=for-the-badge)](https://twitter.com/cfbfastR)
See [CHANGELOG.md](https://cfbfastR-py.sportsdataverse.org/CHANGELOG) for details.
The goal of [cfbfastR-py](https://cfbfastR-py.sportsdataverse.org) is to provide the community with a python package for working with American Football data as a companion to the [cfbfastR](https://saiemgilani.github.io/cfbfastR) R package. Beyond data aggregation and tidying ease, one of the multitude of services that [cfbfastR-py](https://cfbfastR-py.sportsdataverse.org) provides is for benchmarking open-source expected points and win probability metrics.
## Installation
cfbfastR-py can be installed via pip:
```bash
pip install cfbfastR-py
```
or from the repo (which may at times be more up to date):
```bash
git clone https://github.com/saiemgilani/cfbfastR-py
cd cfbfastR-py
pip install -e .
```
# **Our Authors**
- [Saiem Gilani](https://twitter.com/saiemgilani)
## **Citations**
To cite the [**`cfbfastR-py`**](https://cfbfastR-py.sportsdataverse.org) Python package in publications, use:
BibTex Citation
```bibtex
@misc{saiemgilani2021cfbfastRpy,
author = {Gilani, Saiem},
title = {cfbfastR-py: The SportsDataverse's Python Package for American Football Data.},
url = {https://cfbfastR-py.sportsdataverse.org},
season = {2021}
}
```
%package help
Summary: Development documents and examples for cfbfastR-py
Provides: python3-cfbfastR-py-doc
%description help
# cfbfastR-py
![Lifecycle:experimental](https://img.shields.io/badge/lifecycle-experimental-orange.svg?style=for-the-badge&logo=github)
[![PyPI](https://img.shields.io/pypi/v/cfbfastR-py?label=cfbfastR-py&logo=python&style=for-the-badge)](https://pypi.org/project/cfbfastR-py/)
![Contributors](https://img.shields.io/github/contributors/saiemgilani/cfbfastR-py?style=for-the-badge)
[![Twitter
Follow](https://img.shields.io/twitter/follow/cfbfastR?color=blue&label=%40cfbfastR&logo=twitter&style=for-the-badge)](https://twitter.com/cfbfastR)
See [CHANGELOG.md](https://cfbfastR-py.sportsdataverse.org/CHANGELOG) for details.
The goal of [cfbfastR-py](https://cfbfastR-py.sportsdataverse.org) is to provide the community with a python package for working with American Football data as a companion to the [cfbfastR](https://saiemgilani.github.io/cfbfastR) R package. Beyond data aggregation and tidying ease, one of the multitude of services that [cfbfastR-py](https://cfbfastR-py.sportsdataverse.org) provides is for benchmarking open-source expected points and win probability metrics.
## Installation
cfbfastR-py can be installed via pip:
```bash
pip install cfbfastR-py
```
or from the repo (which may at times be more up to date):
```bash
git clone https://github.com/saiemgilani/cfbfastR-py
cd cfbfastR-py
pip install -e .
```
# **Our Authors**
- [Saiem Gilani](https://twitter.com/saiemgilani)
## **Citations**
To cite the [**`cfbfastR-py`**](https://cfbfastR-py.sportsdataverse.org) Python package in publications, use:
BibTex Citation
```bibtex
@misc{saiemgilani2021cfbfastRpy,
author = {Gilani, Saiem},
title = {cfbfastR-py: The SportsDataverse's Python Package for American Football Data.},
url = {https://cfbfastR-py.sportsdataverse.org},
season = {2021}
}
```
%prep
%autosetup -n cfbfastR-py-0.0.28
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cfbfastR-py -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.0.28-1
- Package Spec generated