%global _empty_manifest_terminate_build 0
Name:		python-mediacloud
Version:	4.0.1
Release:	1
Summary:	Media Cloud API Client Library
License:	MIT
URL:		http://mediacloud.org
Source0:	https://mirrors.aliyun.com/pypi/web/packages/73/a9/5553d3aa64dc21f23c4ab4437390cb27c42c461eac38ef036d4cbc664e95/mediacloud-4.0.1.tar.gz
BuildArch:	noarch


%description
🚧 Under construction 🚧  
This is a python client for accessing the MediaCloud API v4. This allows you to perform cross-platform searches and 
also browse our collection/source/feed directory.
![pylint](https://github.com/mediacloud/api-client/actions/workflows/pylint.yml/badge.svg) ![pytest](https://github.com/mediacloud/api-client/actions/workflows/pytest.yml/badge.svg) [![GitHub license](https://img.shields.io/badge/license-MIT-blue.svg)](https://github.com/mitmedialab/MediaCloud-API-Client/blob/master/LICENSE)

%package -n python3-mediacloud
Summary:	Media Cloud API Client Library
Provides:	python-mediacloud
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-mediacloud
🚧 Under construction 🚧  
This is a python client for accessing the MediaCloud API v4. This allows you to perform cross-platform searches and 
also browse our collection/source/feed directory.
![pylint](https://github.com/mediacloud/api-client/actions/workflows/pylint.yml/badge.svg) ![pytest](https://github.com/mediacloud/api-client/actions/workflows/pytest.yml/badge.svg) [![GitHub license](https://img.shields.io/badge/license-MIT-blue.svg)](https://github.com/mitmedialab/MediaCloud-API-Client/blob/master/LICENSE)

%package help
Summary:	Development documents and examples for mediacloud
Provides:	python3-mediacloud-doc
%description help
🚧 Under construction 🚧  
This is a python client for accessing the MediaCloud API v4. This allows you to perform cross-platform searches and 
also browse our collection/source/feed directory.
![pylint](https://github.com/mediacloud/api-client/actions/workflows/pylint.yml/badge.svg) ![pytest](https://github.com/mediacloud/api-client/actions/workflows/pytest.yml/badge.svg) [![GitHub license](https://img.shields.io/badge/license-MIT-blue.svg)](https://github.com/mitmedialab/MediaCloud-API-Client/blob/master/LICENSE)

%prep
%autosetup -n mediacloud-4.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-mediacloud -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 4.0.1-1
- Package Spec generated