%global _empty_manifest_terminate_build 0
Name: python-feffery-antd-components
Version: 0.2.9
Release: 1
Summary: Best implementation of Antd components in Plotly Dash.
License: MIT
URL: https://github.com/CNFeffery/feffery-antd-components
Source0: https://mirrors.aliyun.com/pypi/web/packages/94/81/17fc6b7cca34abb81e767c58edbacfc6dbc509dc49bf7acfbfdcda1007ca/feffery_antd_components-0.2.9.tar.gz
BuildArch: noarch
Requires: python3-dash
%description
feffery-antd-components
[](https://github.com/CNFeffery/feffery-antd-components/blob/master/LICENSE)
[](https://pypi.org/project/feffery-antd-components/)
[](https://pepy.tech/project/feffery-antd-components)
[](https://pepy.tech/project/feffery-antd-components)
[](http://isitmaintained.com/project/CNFeffery/feffery-antd-components "Average time to resolve an issue")
[](http://isitmaintained.com/project/CNFeffery/feffery-antd-components "Percentage of issues still open")
简体中文 | [English](./README-en_US.md)
`feffery-components`计划子项目,`Plotly Dash`第三方组件库,基于`Antd`,将超多具有丰富功能的通用网页常用交互组件引入`Dash`的生态中 🥳,最新稳定版本:`0.2.8`
## 1 最新版本安装方式
```bash
pip install feffery-antd-components -U
```
## 2 最新预发布版本安装方式
```bash
pip install feffery-antd-components --pre -U
```
## 3 静态资源 CDN 加速方法
```Python
# 非debug模式下对Dash()传入参数serve_locally=False会强制浏览器端从unpkg cdn加载各个依赖的
# xxx.min.js等静态资源,从而避免占用服务器带宽,适合中小型站点加速访问
app = dash.Dash(serve_locally=False)
```
## 4 在线文档
文档地址
## 5 国际化
`fac`中的部分组件具有自带的文案信息,通过参数`locale`可以进行国际化设置,默认为`'zh-cn'`即简体中文,你可以设置为`'en-us'`来使用英文文案,譬如:
```Python
fac.AntdDatePicker(locale='en-us')
```
%package -n python3-feffery-antd-components
Summary: Best implementation of Antd components in Plotly Dash.
Provides: python-feffery-antd-components
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-feffery-antd-components
feffery-antd-components
[](https://github.com/CNFeffery/feffery-antd-components/blob/master/LICENSE)
[](https://pypi.org/project/feffery-antd-components/)
[](https://pepy.tech/project/feffery-antd-components)
[](https://pepy.tech/project/feffery-antd-components)
[](http://isitmaintained.com/project/CNFeffery/feffery-antd-components "Average time to resolve an issue")
[](http://isitmaintained.com/project/CNFeffery/feffery-antd-components "Percentage of issues still open")
简体中文 | [English](./README-en_US.md)
`feffery-components`计划子项目,`Plotly Dash`第三方组件库,基于`Antd`,将超多具有丰富功能的通用网页常用交互组件引入`Dash`的生态中 🥳,最新稳定版本:`0.2.8`
## 1 最新版本安装方式
```bash
pip install feffery-antd-components -U
```
## 2 最新预发布版本安装方式
```bash
pip install feffery-antd-components --pre -U
```
## 3 静态资源 CDN 加速方法
```Python
# 非debug模式下对Dash()传入参数serve_locally=False会强制浏览器端从unpkg cdn加载各个依赖的
# xxx.min.js等静态资源,从而避免占用服务器带宽,适合中小型站点加速访问
app = dash.Dash(serve_locally=False)
```
## 4 在线文档
文档地址
## 5 国际化
`fac`中的部分组件具有自带的文案信息,通过参数`locale`可以进行国际化设置,默认为`'zh-cn'`即简体中文,你可以设置为`'en-us'`来使用英文文案,譬如:
```Python
fac.AntdDatePicker(locale='en-us')
```
%package help
Summary: Development documents and examples for feffery-antd-components
Provides: python3-feffery-antd-components-doc
%description help
feffery-antd-components
[](https://github.com/CNFeffery/feffery-antd-components/blob/master/LICENSE)
[](https://pypi.org/project/feffery-antd-components/)
[](https://pepy.tech/project/feffery-antd-components)
[](https://pepy.tech/project/feffery-antd-components)
[](http://isitmaintained.com/project/CNFeffery/feffery-antd-components "Average time to resolve an issue")
[](http://isitmaintained.com/project/CNFeffery/feffery-antd-components "Percentage of issues still open")
简体中文 | [English](./README-en_US.md)
`feffery-components`计划子项目,`Plotly Dash`第三方组件库,基于`Antd`,将超多具有丰富功能的通用网页常用交互组件引入`Dash`的生态中 🥳,最新稳定版本:`0.2.8`
## 1 最新版本安装方式
```bash
pip install feffery-antd-components -U
```
## 2 最新预发布版本安装方式
```bash
pip install feffery-antd-components --pre -U
```
## 3 静态资源 CDN 加速方法
```Python
# 非debug模式下对Dash()传入参数serve_locally=False会强制浏览器端从unpkg cdn加载各个依赖的
# xxx.min.js等静态资源,从而避免占用服务器带宽,适合中小型站点加速访问
app = dash.Dash(serve_locally=False)
```
## 4 在线文档
文档地址
## 5 国际化
`fac`中的部分组件具有自带的文案信息,通过参数`locale`可以进行国际化设置,默认为`'zh-cn'`即简体中文,你可以设置为`'en-us'`来使用英文文案,譬如:
```Python
fac.AntdDatePicker(locale='en-us')
```
%prep
%autosetup -n feffery_antd_components-0.2.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-feffery-antd-components -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.2.9-1
- Package Spec generated