%global _empty_manifest_terminate_build 0
Name:		python-crop-utils
Version:	4.3.2
Release:	1
Summary:	鞋类ai识别
License:	MIT License
URL:		http://git.chaomy.com/libo/ecpro-utils.git
Source0:	https://mirrors.aliyun.com/pypi/web/packages/d4/60/5d0480651dca6cf63665789d36dcbb5875d128dc52a25febbeea89b2e50d/crop_utils-4.3.2.tar.gz
BuildArch:	noarch


%description
为了区分3.0与4.0版本,同时资源图与详情页也共用的一套裁剪逻辑代码。

为了降低裁剪部分维护与开发难度,封装为裁剪工具包





# 包制作流程

环境:win

python版本: 3.9



# 自定义包

https://packaging.python.org/tutorials/packaging-projects/#



项目目录结构

~~~markdown
 ecpro-util/

 	|-- src/

 	|   |-- ecpro/

 	|   |  |-- init.py

 	|   |  |-- html_slot_config.py

 	|   |  |-- image.py

 	|   |  |-- img_crop.py

 	|--tests/

 	|   |--test.py

 	|--setup.py

 	|--LICENSE

 	|--MANIFEST.IN

 	|--pyproject.toml

 	|--READNE.md
~~~

# 打包
> python setup.py sdist bdist_wheel



# 发布到pypi

首先需要在pypi上注册并绑定邮箱才有权限上传

> twine upload dist/*



# 安装



pip install crop-utils==4.3.1 -i  https://pypi.python.org/simple/



%package -n python3-crop-utils
Summary:	鞋类ai识别
Provides:	python-crop-utils
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-crop-utils
为了区分3.0与4.0版本,同时资源图与详情页也共用的一套裁剪逻辑代码。

为了降低裁剪部分维护与开发难度,封装为裁剪工具包





# 包制作流程

环境:win

python版本: 3.9



# 自定义包

https://packaging.python.org/tutorials/packaging-projects/#



项目目录结构

~~~markdown
 ecpro-util/

 	|-- src/

 	|   |-- ecpro/

 	|   |  |-- init.py

 	|   |  |-- html_slot_config.py

 	|   |  |-- image.py

 	|   |  |-- img_crop.py

 	|--tests/

 	|   |--test.py

 	|--setup.py

 	|--LICENSE

 	|--MANIFEST.IN

 	|--pyproject.toml

 	|--READNE.md
~~~

# 打包
> python setup.py sdist bdist_wheel



# 发布到pypi

首先需要在pypi上注册并绑定邮箱才有权限上传

> twine upload dist/*



# 安装



pip install crop-utils==4.3.1 -i  https://pypi.python.org/simple/



%package help
Summary:	Development documents and examples for crop-utils
Provides:	python3-crop-utils-doc
%description help
为了区分3.0与4.0版本,同时资源图与详情页也共用的一套裁剪逻辑代码。

为了降低裁剪部分维护与开发难度,封装为裁剪工具包





# 包制作流程

环境:win

python版本: 3.9



# 自定义包

https://packaging.python.org/tutorials/packaging-projects/#



项目目录结构

~~~markdown
 ecpro-util/

 	|-- src/

 	|   |-- ecpro/

 	|   |  |-- init.py

 	|   |  |-- html_slot_config.py

 	|   |  |-- image.py

 	|   |  |-- img_crop.py

 	|--tests/

 	|   |--test.py

 	|--setup.py

 	|--LICENSE

 	|--MANIFEST.IN

 	|--pyproject.toml

 	|--READNE.md
~~~

# 打包
> python setup.py sdist bdist_wheel



# 发布到pypi

首先需要在pypi上注册并绑定邮箱才有权限上传

> twine upload dist/*



# 安装



pip install crop-utils==4.3.1 -i  https://pypi.python.org/simple/



%prep
%autosetup -n crop_utils-4.3.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-crop-utils -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 4.3.2-1
- Package Spec generated