%global _empty_manifest_terminate_build 0
Name: python-luma.led-matrix
Version: 1.7.0
Release: 1
Summary: A library to drive a MAX7219 LED serializer (using SPI) and WS2812 NeoPixels (using DMA)
License: MIT
URL: https://github.com/rm-hull/luma.led_matrix
Source0: https://mirrors.aliyun.com/pypi/web/packages/cc/41/8cf7078e77da1ededef2bcc958114afc52725e948b01f16fa3542c914bbd/luma.led_matrix-1.7.0.tar.gz
BuildArch: noarch
%description
**Display drivers for MAX7219, WS2812, APA102**
Python 3 library interfacing LED matrix displays with the MAX7219 driver (using
SPI), WS2812 (NeoPixels, inc Pimoroni Unicorn pHat/Hat and Unicorn Hat HD) and
APA102 (DotStar) on the Raspberry Pi and other Linux-based single board computers
- it provides a `Pillow `_-compatible drawing
canvas, and other functionality to support:
* multiple cascaded devices
* LED matrix, seven-segment and NeoPixel variants
* scrolling/panning capability,
* terminal-style printing,
* state management,
* dithering to monochrome,
* pygame emulator,
* Python 3.6 and newer are supported
%package -n python3-luma.led-matrix
Summary: A library to drive a MAX7219 LED serializer (using SPI) and WS2812 NeoPixels (using DMA)
Provides: python-luma.led-matrix
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-luma.led-matrix
**Display drivers for MAX7219, WS2812, APA102**
Python 3 library interfacing LED matrix displays with the MAX7219 driver (using
SPI), WS2812 (NeoPixels, inc Pimoroni Unicorn pHat/Hat and Unicorn Hat HD) and
APA102 (DotStar) on the Raspberry Pi and other Linux-based single board computers
- it provides a `Pillow `_-compatible drawing
canvas, and other functionality to support:
* multiple cascaded devices
* LED matrix, seven-segment and NeoPixel variants
* scrolling/panning capability,
* terminal-style printing,
* state management,
* dithering to monochrome,
* pygame emulator,
* Python 3.6 and newer are supported
%package help
Summary: Development documents and examples for luma.led-matrix
Provides: python3-luma.led-matrix-doc
%description help
**Display drivers for MAX7219, WS2812, APA102**
Python 3 library interfacing LED matrix displays with the MAX7219 driver (using
SPI), WS2812 (NeoPixels, inc Pimoroni Unicorn pHat/Hat and Unicorn Hat HD) and
APA102 (DotStar) on the Raspberry Pi and other Linux-based single board computers
- it provides a `Pillow `_-compatible drawing
canvas, and other functionality to support:
* multiple cascaded devices
* LED matrix, seven-segment and NeoPixel variants
* scrolling/panning capability,
* terminal-style printing,
* state management,
* dithering to monochrome,
* pygame emulator,
* Python 3.6 and newer are supported
%prep
%autosetup -n luma.led_matrix-1.7.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-luma.led-matrix -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 1.7.0-1
- Package Spec generated