%global _empty_manifest_terminate_build 0
Name: python-Django-Site-Utils
Version: 0.3.7
Release: 1
Summary: Django site-wide management commands and utilities.
License: BSD
URL: https://github.com/ninemoreminutes/django-site-utils/
Source0: https://mirrors.aliyun.com/pypi/web/packages/cc/ae/eb8d7b1361b2d08eeb830758333873934d0739577d6d86d447fc96d06ff8/Django-Site-Utils-0.3.7.tar.gz
BuildArch: noarch
Requires: python3-django
Requires: python3-six
%description
The Django-Site-Utils library provides a reusable Django application with management commands for site-wide
administrative actions, along with functions for common tasks often needed by any Django site.
Management commands include:
* ``site_cleanup`` : Cleanup stale data and tables.
* ``site_config`` : Update the Site name and domain.
* ``site_error_pages`` : Generate static error pages based on your site's theme.
* ``site_notify`` : Send notifications to administrators and staff.
* ``site_update`` : Run groups of management commands at once.
Other features include:
* Error views and handlers.
* Template context processors.
* Admin mixin classes.
* Functions to patch Django internals.
Documentation can be found at `Read The Docs `_.
It is tested against:
* Django 1.11 (Python 3.5 and 3.6)
* Django 2.0 (Python 3.5, 3.6 and 3.7)
* Django 2.1 (Python 3.5, 3.6 and 3.7)
* Django 2.2 (Python 3.5, 3.6, 3.7, 3.8 and 3.9)
* Django 3.0 (Python 3.6, 3.7, 3.8 and 3.9)
* Django 3.1 (Python 3.6, 3.7, 3.8 and 3.9)
* Django 3.2 pre-release (Python 3.6, 3.7, 3.8 and 3.9)
* Django main/4.0 (Python 3.8 and 3.9)
%package -n python3-Django-Site-Utils
Summary: Django site-wide management commands and utilities.
Provides: python-Django-Site-Utils
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Django-Site-Utils
The Django-Site-Utils library provides a reusable Django application with management commands for site-wide
administrative actions, along with functions for common tasks often needed by any Django site.
Management commands include:
* ``site_cleanup`` : Cleanup stale data and tables.
* ``site_config`` : Update the Site name and domain.
* ``site_error_pages`` : Generate static error pages based on your site's theme.
* ``site_notify`` : Send notifications to administrators and staff.
* ``site_update`` : Run groups of management commands at once.
Other features include:
* Error views and handlers.
* Template context processors.
* Admin mixin classes.
* Functions to patch Django internals.
Documentation can be found at `Read The Docs `_.
It is tested against:
* Django 1.11 (Python 3.5 and 3.6)
* Django 2.0 (Python 3.5, 3.6 and 3.7)
* Django 2.1 (Python 3.5, 3.6 and 3.7)
* Django 2.2 (Python 3.5, 3.6, 3.7, 3.8 and 3.9)
* Django 3.0 (Python 3.6, 3.7, 3.8 and 3.9)
* Django 3.1 (Python 3.6, 3.7, 3.8 and 3.9)
* Django 3.2 pre-release (Python 3.6, 3.7, 3.8 and 3.9)
* Django main/4.0 (Python 3.8 and 3.9)
%package help
Summary: Development documents and examples for Django-Site-Utils
Provides: python3-Django-Site-Utils-doc
%description help
The Django-Site-Utils library provides a reusable Django application with management commands for site-wide
administrative actions, along with functions for common tasks often needed by any Django site.
Management commands include:
* ``site_cleanup`` : Cleanup stale data and tables.
* ``site_config`` : Update the Site name and domain.
* ``site_error_pages`` : Generate static error pages based on your site's theme.
* ``site_notify`` : Send notifications to administrators and staff.
* ``site_update`` : Run groups of management commands at once.
Other features include:
* Error views and handlers.
* Template context processors.
* Admin mixin classes.
* Functions to patch Django internals.
Documentation can be found at `Read The Docs `_.
It is tested against:
* Django 1.11 (Python 3.5 and 3.6)
* Django 2.0 (Python 3.5, 3.6 and 3.7)
* Django 2.1 (Python 3.5, 3.6 and 3.7)
* Django 2.2 (Python 3.5, 3.6, 3.7, 3.8 and 3.9)
* Django 3.0 (Python 3.6, 3.7, 3.8 and 3.9)
* Django 3.1 (Python 3.6, 3.7, 3.8 and 3.9)
* Django 3.2 pre-release (Python 3.6, 3.7, 3.8 and 3.9)
* Django main/4.0 (Python 3.8 and 3.9)
%prep
%autosetup -n Django-Site-Utils-0.3.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Django-Site-Utils -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.3.7-1
- Package Spec generated