%global _empty_manifest_terminate_build 0
Name:		python-Flask-DJ
Version:	1.0.7
Release:	1
Summary:	Django (mvc) structure for your Flask project.
License:	MIT License
URL:		https://github.com/AlexandrovRoman/Flask-DJ
Source0:	https://mirrors.aliyun.com/pypi/web/packages/db/ca/c0979b06048ec22d190ad775499e2f2b28405b733b3bbc1e6a4c77dd226f/Flask-DJ-1.0.7.tar.gz
BuildArch:	noarch

Requires:	python3-waitress
Requires:	python3-flask
Requires:	python3-Flask-Migrate
Requires:	python3-Flask-Script
Requires:	python3-Flask-SQLAlchemy
Requires:	python3-WTForms
Requires:	python3-SQLAlchemy
Requires:	python3-Flask-WTF
Requires:	python3-Flask-Login

%description
![image](https://habrastorage.org/webt/fm/uv/j0/fmuvj0qq8vym2hnf01n0wpeupn0.png)


# Flask-DJ

 Since the flask has no strict architecture, <br>
it's easy to get confused when creating a project.<br>
This library was created to help everyone who wants to <br>
create a project with mvc structure.<br>

 ## Quick start
 ### Start project:

 ```shell script
$ flask-dj startproject app
```

or

 ```python
from flask_dj import startproject
from os import getcwd

your_project_name = 'app'
startproject(your_project_name, getcwd())
```
 ### New app:

   ```shell script
 python manage.py startapp {app_name}
```

### Start server:

```shell script
 python manage.py runserver
```




%package -n python3-Flask-DJ
Summary:	Django (mvc) structure for your Flask project.
Provides:	python-Flask-DJ
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Flask-DJ
![image](https://habrastorage.org/webt/fm/uv/j0/fmuvj0qq8vym2hnf01n0wpeupn0.png)


# Flask-DJ

 Since the flask has no strict architecture, <br>
it's easy to get confused when creating a project.<br>
This library was created to help everyone who wants to <br>
create a project with mvc structure.<br>

 ## Quick start
 ### Start project:

 ```shell script
$ flask-dj startproject app
```

or

 ```python
from flask_dj import startproject
from os import getcwd

your_project_name = 'app'
startproject(your_project_name, getcwd())
```
 ### New app:

   ```shell script
 python manage.py startapp {app_name}
```

### Start server:

```shell script
 python manage.py runserver
```




%package help
Summary:	Development documents and examples for Flask-DJ
Provides:	python3-Flask-DJ-doc
%description help
![image](https://habrastorage.org/webt/fm/uv/j0/fmuvj0qq8vym2hnf01n0wpeupn0.png)


# Flask-DJ

 Since the flask has no strict architecture, <br>
it's easy to get confused when creating a project.<br>
This library was created to help everyone who wants to <br>
create a project with mvc structure.<br>

 ## Quick start
 ### Start project:

 ```shell script
$ flask-dj startproject app
```

or

 ```python
from flask_dj import startproject
from os import getcwd

your_project_name = 'app'
startproject(your_project_name, getcwd())
```
 ### New app:

   ```shell script
 python manage.py startapp {app_name}
```

### Start server:

```shell script
 python manage.py runserver
```




%prep
%autosetup -n Flask-DJ-1.0.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Flask-DJ -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.7-1
- Package Spec generated