%global _empty_manifest_terminate_build 0
Name: python-jasmin
Version: 0.10.13
Release: 1
Summary: Jasmin is a very complete open source SMS Gateway with many enterprise-class features.
License: Apache v2.0
URL: https://www.jasminsms.com
Source0: https://mirrors.aliyun.com/pypi/web/packages/56/55/c3dd6168fd49fb8ec9138b625611bc5189b9b0d7f0dd02fb61b657cdd592/jasmin-0.10.13.tar.gz
BuildArch: noarch
%description
.. image:: https://raw.githubusercontent.com/jookies/jasmin/master/misc/doc/sources/_static/jasmin-logo-small.png
Jasmin - Open source SMS gateway
################################
|contribs| |ubuntu-package| |redhat-package| |ci| |docker| |docs| |support|
Introduction
************
Jasmin is a very complete open source SMS Gateway with many enterprise-class features such as:
* SMPP Client / Server
* HTTP Client / Server
* Console-based configuration, no service restart required
* Based on AMQP broker for store&forward mechanisms and other queuing systems
* Using Redis for in-memory DLR tracking and billing
* Advanced message routing/filtering (Simple, Roundrobin, Failover, HLR lookup, Leastcost ...)
* Supports Unicode (UTF-8) for sending out multilingual SMS
* Supports easy creation and sending of specialized/binary SMS like mono Ringtones, WAP Push, Vcards
* Supports concatenated SMS strings (long SMS)
Jasmin relies heavily on message queuing through message brokers (Using AMQP), it is designed for performance,
high traffic loads and full in-memory execution.
.. figure:: https://opensource.nyc3.cdn.digitaloceanspaces.com/attribution/assets/PoweredByDO/DO_Powered_by_Badge_blue.svg
:alt: Powered by DigitalOcean
:align: Center
:figwidth: 210px
:target: https://www.digitalocean.com/
Architecture
************
.. figure:: https://github.com/jookies/jasmin/raw/master/misc/doc/sources/resources/architecture/hld.png
:alt: HLD Architecture
:align: Center
:figwidth: 100%
:target: https://docs.jasminsms.com/en/latest/architecture/index.html
Jasmin core and its external connectors (used for AMQP, Redis, SMPP, HTTP, Telnet ...) are written in Python
and are mainly based on `Twisted matrix `_, an event-driven networking engine.
Getting started
***************
Refer to `Installation steps `_ to get Jasmin gateway up and running quickly with a simple SMS sending scenario.
Documentation
*************
The documentation is at: http://docs.jasminsms.com
If you still need to build it locally::
$ cd misc/doc
$ make html
...
...
Build finished. The HTML pages are in build/html.
Links
*****
* `Project home page `_
* `Documentation `_
* `Support `_
* `Continuous Integration `_
* `Source code `_
* `Kubernetes deployment `_ or `/Experimental/ Deploy to Heroku `_
Contributors
************
.. figure:: https://opencollective.com/jookies/contributors.svg?width=840&button=false
:alt: Contributors
:align: Center
:figwidth: 100%
:target: https://github.com/jookies/jasmin/graphs/contributors
License
*******
Jasmin is released under the terms of the [Apache License Version 2]. See **`LICENSE`** file for details.
Credits
*******
* Supported by `DigitalOcean `_
* Dominic Amato for the extraordinary effort porting Jasmin to Python3: https://github.com/DomAmato
* SMPP PDU parsing based on smpp.pdu: https://github.com/mozes/smpp.pdu
* SMPP 3.4 Client based on smpp.twisted: https://github.com/mozes/smpp.twisted
* GSMP 3.38 based on Python messaging: https://github.com/pmarti/python-messaging
.. |contribs| image:: https://img.shields.io/badge/contributions-welcome-brightgreen?logo=github
:alt: Contributions welcome
:scale: 100%
:target: https://github.com/jookies/jasmin/blob/master/CODE_OF_CONDUCT.md
.. |ci| image:: https://github.com/jookies/jasmin/actions/workflows/ci.yml/badge.svg
:alt: Build status
:scale: 100%
:target: https://github.com/jookies/jasmin/actions
.. |ubuntu-package| image:: https://img.shields.io/badge/package-ubuntu-brightgreen.svg?style=flat-square
:alt: Ubuntu package
:scale: 100%
:target: https://packagecloud.io/jookies/jasmin-sms-gateway
.. |redhat-package| image:: https://img.shields.io/badge/package-redhat-brightgreen.svg?style=flat-square
:alt: Redhat package
:scale: 100%
:target: https://packagecloud.io/jookies/jasmin-sms-gateway
.. |docker| image:: https://github.com/jookies/jasmin/actions/workflows/docker.yml/badge.svg
:alt: Docker image build status
:scale: 100%
:target: https://github.com/jookies/jasmin/actions
.. |docs| image:: https://readthedocs.org/projects/jasmin/badge/?version=latest
:alt: Documentation status
:scale: 100%
:target: http://docs.jasminsms.com
.. |support| image:: https://img.shields.io/badge/discussions-GitHub-333333?logo=github
:alt: Github discussions
:scale: 100%
:target: https://github.com/jookies/jasmin/discussions
%package -n python3-jasmin
Summary: Jasmin is a very complete open source SMS Gateway with many enterprise-class features.
Provides: python-jasmin
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-jasmin
.. image:: https://raw.githubusercontent.com/jookies/jasmin/master/misc/doc/sources/_static/jasmin-logo-small.png
Jasmin - Open source SMS gateway
################################
|contribs| |ubuntu-package| |redhat-package| |ci| |docker| |docs| |support|
Introduction
************
Jasmin is a very complete open source SMS Gateway with many enterprise-class features such as:
* SMPP Client / Server
* HTTP Client / Server
* Console-based configuration, no service restart required
* Based on AMQP broker for store&forward mechanisms and other queuing systems
* Using Redis for in-memory DLR tracking and billing
* Advanced message routing/filtering (Simple, Roundrobin, Failover, HLR lookup, Leastcost ...)
* Supports Unicode (UTF-8) for sending out multilingual SMS
* Supports easy creation and sending of specialized/binary SMS like mono Ringtones, WAP Push, Vcards
* Supports concatenated SMS strings (long SMS)
Jasmin relies heavily on message queuing through message brokers (Using AMQP), it is designed for performance,
high traffic loads and full in-memory execution.
.. figure:: https://opensource.nyc3.cdn.digitaloceanspaces.com/attribution/assets/PoweredByDO/DO_Powered_by_Badge_blue.svg
:alt: Powered by DigitalOcean
:align: Center
:figwidth: 210px
:target: https://www.digitalocean.com/
Architecture
************
.. figure:: https://github.com/jookies/jasmin/raw/master/misc/doc/sources/resources/architecture/hld.png
:alt: HLD Architecture
:align: Center
:figwidth: 100%
:target: https://docs.jasminsms.com/en/latest/architecture/index.html
Jasmin core and its external connectors (used for AMQP, Redis, SMPP, HTTP, Telnet ...) are written in Python
and are mainly based on `Twisted matrix `_, an event-driven networking engine.
Getting started
***************
Refer to `Installation steps `_ to get Jasmin gateway up and running quickly with a simple SMS sending scenario.
Documentation
*************
The documentation is at: http://docs.jasminsms.com
If you still need to build it locally::
$ cd misc/doc
$ make html
...
...
Build finished. The HTML pages are in build/html.
Links
*****
* `Project home page `_
* `Documentation `_
* `Support `_
* `Continuous Integration `_
* `Source code `_
* `Kubernetes deployment `_ or `/Experimental/ Deploy to Heroku `_
Contributors
************
.. figure:: https://opencollective.com/jookies/contributors.svg?width=840&button=false
:alt: Contributors
:align: Center
:figwidth: 100%
:target: https://github.com/jookies/jasmin/graphs/contributors
License
*******
Jasmin is released under the terms of the [Apache License Version 2]. See **`LICENSE`** file for details.
Credits
*******
* Supported by `DigitalOcean `_
* Dominic Amato for the extraordinary effort porting Jasmin to Python3: https://github.com/DomAmato
* SMPP PDU parsing based on smpp.pdu: https://github.com/mozes/smpp.pdu
* SMPP 3.4 Client based on smpp.twisted: https://github.com/mozes/smpp.twisted
* GSMP 3.38 based on Python messaging: https://github.com/pmarti/python-messaging
.. |contribs| image:: https://img.shields.io/badge/contributions-welcome-brightgreen?logo=github
:alt: Contributions welcome
:scale: 100%
:target: https://github.com/jookies/jasmin/blob/master/CODE_OF_CONDUCT.md
.. |ci| image:: https://github.com/jookies/jasmin/actions/workflows/ci.yml/badge.svg
:alt: Build status
:scale: 100%
:target: https://github.com/jookies/jasmin/actions
.. |ubuntu-package| image:: https://img.shields.io/badge/package-ubuntu-brightgreen.svg?style=flat-square
:alt: Ubuntu package
:scale: 100%
:target: https://packagecloud.io/jookies/jasmin-sms-gateway
.. |redhat-package| image:: https://img.shields.io/badge/package-redhat-brightgreen.svg?style=flat-square
:alt: Redhat package
:scale: 100%
:target: https://packagecloud.io/jookies/jasmin-sms-gateway
.. |docker| image:: https://github.com/jookies/jasmin/actions/workflows/docker.yml/badge.svg
:alt: Docker image build status
:scale: 100%
:target: https://github.com/jookies/jasmin/actions
.. |docs| image:: https://readthedocs.org/projects/jasmin/badge/?version=latest
:alt: Documentation status
:scale: 100%
:target: http://docs.jasminsms.com
.. |support| image:: https://img.shields.io/badge/discussions-GitHub-333333?logo=github
:alt: Github discussions
:scale: 100%
:target: https://github.com/jookies/jasmin/discussions
%package help
Summary: Development documents and examples for jasmin
Provides: python3-jasmin-doc
%description help
.. image:: https://raw.githubusercontent.com/jookies/jasmin/master/misc/doc/sources/_static/jasmin-logo-small.png
Jasmin - Open source SMS gateway
################################
|contribs| |ubuntu-package| |redhat-package| |ci| |docker| |docs| |support|
Introduction
************
Jasmin is a very complete open source SMS Gateway with many enterprise-class features such as:
* SMPP Client / Server
* HTTP Client / Server
* Console-based configuration, no service restart required
* Based on AMQP broker for store&forward mechanisms and other queuing systems
* Using Redis for in-memory DLR tracking and billing
* Advanced message routing/filtering (Simple, Roundrobin, Failover, HLR lookup, Leastcost ...)
* Supports Unicode (UTF-8) for sending out multilingual SMS
* Supports easy creation and sending of specialized/binary SMS like mono Ringtones, WAP Push, Vcards
* Supports concatenated SMS strings (long SMS)
Jasmin relies heavily on message queuing through message brokers (Using AMQP), it is designed for performance,
high traffic loads and full in-memory execution.
.. figure:: https://opensource.nyc3.cdn.digitaloceanspaces.com/attribution/assets/PoweredByDO/DO_Powered_by_Badge_blue.svg
:alt: Powered by DigitalOcean
:align: Center
:figwidth: 210px
:target: https://www.digitalocean.com/
Architecture
************
.. figure:: https://github.com/jookies/jasmin/raw/master/misc/doc/sources/resources/architecture/hld.png
:alt: HLD Architecture
:align: Center
:figwidth: 100%
:target: https://docs.jasminsms.com/en/latest/architecture/index.html
Jasmin core and its external connectors (used for AMQP, Redis, SMPP, HTTP, Telnet ...) are written in Python
and are mainly based on `Twisted matrix `_, an event-driven networking engine.
Getting started
***************
Refer to `Installation steps `_ to get Jasmin gateway up and running quickly with a simple SMS sending scenario.
Documentation
*************
The documentation is at: http://docs.jasminsms.com
If you still need to build it locally::
$ cd misc/doc
$ make html
...
...
Build finished. The HTML pages are in build/html.
Links
*****
* `Project home page `_
* `Documentation `_
* `Support `_
* `Continuous Integration `_
* `Source code `_
* `Kubernetes deployment `_ or `/Experimental/ Deploy to Heroku `_
Contributors
************
.. figure:: https://opencollective.com/jookies/contributors.svg?width=840&button=false
:alt: Contributors
:align: Center
:figwidth: 100%
:target: https://github.com/jookies/jasmin/graphs/contributors
License
*******
Jasmin is released under the terms of the [Apache License Version 2]. See **`LICENSE`** file for details.
Credits
*******
* Supported by `DigitalOcean `_
* Dominic Amato for the extraordinary effort porting Jasmin to Python3: https://github.com/DomAmato
* SMPP PDU parsing based on smpp.pdu: https://github.com/mozes/smpp.pdu
* SMPP 3.4 Client based on smpp.twisted: https://github.com/mozes/smpp.twisted
* GSMP 3.38 based on Python messaging: https://github.com/pmarti/python-messaging
.. |contribs| image:: https://img.shields.io/badge/contributions-welcome-brightgreen?logo=github
:alt: Contributions welcome
:scale: 100%
:target: https://github.com/jookies/jasmin/blob/master/CODE_OF_CONDUCT.md
.. |ci| image:: https://github.com/jookies/jasmin/actions/workflows/ci.yml/badge.svg
:alt: Build status
:scale: 100%
:target: https://github.com/jookies/jasmin/actions
.. |ubuntu-package| image:: https://img.shields.io/badge/package-ubuntu-brightgreen.svg?style=flat-square
:alt: Ubuntu package
:scale: 100%
:target: https://packagecloud.io/jookies/jasmin-sms-gateway
.. |redhat-package| image:: https://img.shields.io/badge/package-redhat-brightgreen.svg?style=flat-square
:alt: Redhat package
:scale: 100%
:target: https://packagecloud.io/jookies/jasmin-sms-gateway
.. |docker| image:: https://github.com/jookies/jasmin/actions/workflows/docker.yml/badge.svg
:alt: Docker image build status
:scale: 100%
:target: https://github.com/jookies/jasmin/actions
.. |docs| image:: https://readthedocs.org/projects/jasmin/badge/?version=latest
:alt: Documentation status
:scale: 100%
:target: http://docs.jasminsms.com
.. |support| image:: https://img.shields.io/badge/discussions-GitHub-333333?logo=github
:alt: Github discussions
:scale: 100%
:target: https://github.com/jookies/jasmin/discussions
%prep
%autosetup -n jasmin-0.10.13
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-jasmin -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.10.13-1
- Package Spec generated