%global _empty_manifest_terminate_build 0
Name:		python-graphene-elastic
Version:	0.8
Release:	1
Summary:	Graphene Elasticsearch/OpenSearch (DSL) integration
License:	GPL 2.0/LGPL 2.1
URL:		https://github.com/barseghyanartur/graphene-elastic
Source0:	https://mirrors.aliyun.com/pypi/web/packages/0f/ca/65a00dce113724667db31a972feea784ad9e0fef2428637d5c151ede5c80/graphene-elastic-0.8.tar.gz
BuildArch:	noarch

Requires:	python3-graphene
Requires:	python3-singledispatch
Requires:	python3-iso8601
Requires:	python3-stringcase
Requires:	python3-anysearch
Requires:	python3-typing
Requires:	python3-elasticsearch
Requires:	python3-elasticsearch-dsl
Requires:	python3-opensearch-py
Requires:	python3-opensearch-dsl

%description


%package -n python3-graphene-elastic
Summary:	Graphene Elasticsearch/OpenSearch (DSL) integration
Provides:	python-graphene-elastic
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-graphene-elastic


%package help
Summary:	Development documents and examples for graphene-elastic
Provides:	python3-graphene-elastic-doc
%description help


%prep
%autosetup -n graphene-elastic-0.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-graphene-elastic -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8-1
- Package Spec generated