%global _empty_manifest_terminate_build 0
Name: python-Mopidy-TuneIn
Version: 1.1.0
Release: 1
Summary: Mopidy extension for playing music from TuneIn
License: Apache License, Version 2.0
URL: https://github.com/kingosticks/mopidy-tunein
Source0: https://mirrors.aliyun.com/pypi/web/packages/22/c4/7efb36a75643a249528f191d1a9a130d9d62e4907aa35f4f9853e1fe1dd2/Mopidy-TuneIn-1.1.0.tar.gz
BuildArch: noarch
Requires: python3-Mopidy
Requires: python3-Pykka
Requires: python3-requests
Requires: python3-setuptools
Requires: python3-black
Requires: python3-check-manifest
Requires: python3-flake8
Requires: python3-flake8-black
Requires: python3-flake8-bugbear
Requires: python3-flake8-isort
Requires: python3-isort
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-tox
Requires: python3-black
Requires: python3-check-manifest
Requires: python3-flake8
Requires: python3-flake8-black
Requires: python3-flake8-bugbear
Requires: python3-flake8-isort
Requires: python3-isort
Requires: python3-pytest
Requires: python3-pytest-cov
%description
Install by running::
python3 -m pip install Mopidy-TuneIn
Or, if available, install the Debian/Ubuntu package from
`apt.mopidy.com `_.
Some radio streams may require additional audio plugins. These can be found in the gstreamer plugin packages for your system. For Mopidy v3.0.0 and later, these might include:
* `gstreamer1.0-plugins-ugly`
* `gstreamer1.0-plugins-bad`
* `gstreamer1.0-libav`
%package -n python3-Mopidy-TuneIn
Summary: Mopidy extension for playing music from TuneIn
Provides: python-Mopidy-TuneIn
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Mopidy-TuneIn
Install by running::
python3 -m pip install Mopidy-TuneIn
Or, if available, install the Debian/Ubuntu package from
`apt.mopidy.com `_.
Some radio streams may require additional audio plugins. These can be found in the gstreamer plugin packages for your system. For Mopidy v3.0.0 and later, these might include:
* `gstreamer1.0-plugins-ugly`
* `gstreamer1.0-plugins-bad`
* `gstreamer1.0-libav`
%package help
Summary: Development documents and examples for Mopidy-TuneIn
Provides: python3-Mopidy-TuneIn-doc
%description help
Install by running::
python3 -m pip install Mopidy-TuneIn
Or, if available, install the Debian/Ubuntu package from
`apt.mopidy.com `_.
Some radio streams may require additional audio plugins. These can be found in the gstreamer plugin packages for your system. For Mopidy v3.0.0 and later, these might include:
* `gstreamer1.0-plugins-ugly`
* `gstreamer1.0-plugins-bad`
* `gstreamer1.0-libav`
%prep
%autosetup -n Mopidy-TuneIn-1.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Mopidy-TuneIn -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 1.1.0-1
- Package Spec generated