%global _empty_manifest_terminate_build 0
Name: python-frccontrol
Version: 2023.29
Release: 1
Summary: Wrappers around Python Control for making development of state-space models for the FIRST Robotics Competition easier
License: BSD License
URL: https://github.com/calcmogul/frccontrol
Source0: https://mirrors.aliyun.com/pypi/web/packages/df/4d/18b37660649f58820907d4e76dd274ba3f01ec5625795663466ced1ebf59/frccontrol-2023.29.tar.gz
BuildArch: noarch
Requires: python3-matplotlib
Requires: python3-numpy
Requires: python3-scipy
%description
frccontrol
##########
Provides SciPy wrappers for easing development of state-space models for
the FIRST Robotics Competition.
Dependencies
************
- `Python 3.5 or newer `_
- Matplotlib
- NumPy
- SciPy
Installation
************
On Windows, execute::
py -m pip install frccontrol
On Linux/OSX, execute::
pip install frccontrol
%package -n python3-frccontrol
Summary: Wrappers around Python Control for making development of state-space models for the FIRST Robotics Competition easier
Provides: python-frccontrol
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-frccontrol
frccontrol
##########
Provides SciPy wrappers for easing development of state-space models for
the FIRST Robotics Competition.
Dependencies
************
- `Python 3.5 or newer `_
- Matplotlib
- NumPy
- SciPy
Installation
************
On Windows, execute::
py -m pip install frccontrol
On Linux/OSX, execute::
pip install frccontrol
%package help
Summary: Development documents and examples for frccontrol
Provides: python3-frccontrol-doc
%description help
frccontrol
##########
Provides SciPy wrappers for easing development of state-space models for
the FIRST Robotics Competition.
Dependencies
************
- `Python 3.5 or newer `_
- Matplotlib
- NumPy
- SciPy
Installation
************
On Windows, execute::
py -m pip install frccontrol
On Linux/OSX, execute::
pip install frccontrol
%prep
%autosetup -n frccontrol-2023.29
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-frccontrol -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 2023.29-1
- Package Spec generated