%global _empty_manifest_terminate_build 0
Name:		python-rosreestr2coord
Version:	4.2.7
Release:	1
Summary:	Get geometry from rosreestr
License:	MIT
URL:		https://github.com/rendrom/rosreestr2coord
Source0:	https://mirrors.aliyun.com/pypi/web/packages/fd/d5/47318aec82b46b55f1d0771f6a48be25c6698e7e1cb675925467f3ad66ce/rosreestr2coord-4.2.7.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-Pillow
Requires:	python3-opencv-contrib-python

%description
Get area coordinates by its cadastral number




%package -n python3-rosreestr2coord
Summary:	Get geometry from rosreestr
Provides:	python-rosreestr2coord
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-rosreestr2coord
Get area coordinates by its cadastral number




%package help
Summary:	Development documents and examples for rosreestr2coord
Provides:	python3-rosreestr2coord-doc
%description help
Get area coordinates by its cadastral number




%prep
%autosetup -n rosreestr2coord-4.2.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-rosreestr2coord -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 4.2.7-1
- Package Spec generated