%global _empty_manifest_terminate_build 0
Name:		python-flexiblecc
Version:	1.0.0
Release:	1
Summary:	Flexible Camera Calibration
License:	MIT
URL:		https://github.com/SimonLBSoerensen/Flexible-Camera-Calibration
Source0:	https://mirrors.aliyun.com/pypi/web/packages/20/2b/9cd6006fd510a26b64782c88a17f69dd8bb00166acdc06431782d27cdeee/flexiblecc-1.0.0.tar.gz
BuildArch:	noarch

Requires:	python3-Pillow
Requires:	python3-numpy
Requires:	python3-opencv-contrib-python
Requires:	python3-tqdm
Requires:	python3-matplotlib
Requires:	python3-scipy
Requires:	python3-seaborn
Requires:	python3-pandas

%description
# Flexible-Camera-Calibration
Flexible Camera Calibration

Demo there show use of this module:
- [![Open In Colab](https://colab.research.google.com/assets/colab-badge.svg)](https://colab.research.google.com/github/SimonLBSoerensen/Flexible-Camera-Calibration/blob/master/Demos/FlexibleCameraCalibration.ipynb)

Python implementation of:
- Schöps, T., Larsson, V., Pollefeys, M., & Sattler, T. (2019). Why Having 10,000 Parameters in Your Camera Model is Better Than Twelve. http://arxiv.org/abs/1912.02908
- Ramalingam, S., & Sturm, P. (2017). A Unifying Model for Camera Calibration. IEEE Transactions on Pattern Analysis and Machine Intelligence, 39(7), 1309–1319. https://doi.org/10.1109/TPAMI.2016.2592904

# Installation
- Recommended: Install flexiblecc from PyPI: 
```sh
pip install flexiblecc
```
- Alternatively: install flexiblecc from the GitHub source:

First, clone flexiblecc using `git`:

```sh
git clone https://github.com/SimonLBSoerensen/Flexible-Camera-Calibration
```

Then, `cd` to the folder and run the install command:
```sh
cd Flexible-Camera-Calibration
python setup.py install
```




%package -n python3-flexiblecc
Summary:	Flexible Camera Calibration
Provides:	python-flexiblecc
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-flexiblecc
# Flexible-Camera-Calibration
Flexible Camera Calibration

Demo there show use of this module:
- [![Open In Colab](https://colab.research.google.com/assets/colab-badge.svg)](https://colab.research.google.com/github/SimonLBSoerensen/Flexible-Camera-Calibration/blob/master/Demos/FlexibleCameraCalibration.ipynb)

Python implementation of:
- Schöps, T., Larsson, V., Pollefeys, M., & Sattler, T. (2019). Why Having 10,000 Parameters in Your Camera Model is Better Than Twelve. http://arxiv.org/abs/1912.02908
- Ramalingam, S., & Sturm, P. (2017). A Unifying Model for Camera Calibration. IEEE Transactions on Pattern Analysis and Machine Intelligence, 39(7), 1309–1319. https://doi.org/10.1109/TPAMI.2016.2592904

# Installation
- Recommended: Install flexiblecc from PyPI: 
```sh
pip install flexiblecc
```
- Alternatively: install flexiblecc from the GitHub source:

First, clone flexiblecc using `git`:

```sh
git clone https://github.com/SimonLBSoerensen/Flexible-Camera-Calibration
```

Then, `cd` to the folder and run the install command:
```sh
cd Flexible-Camera-Calibration
python setup.py install
```




%package help
Summary:	Development documents and examples for flexiblecc
Provides:	python3-flexiblecc-doc
%description help
# Flexible-Camera-Calibration
Flexible Camera Calibration

Demo there show use of this module:
- [![Open In Colab](https://colab.research.google.com/assets/colab-badge.svg)](https://colab.research.google.com/github/SimonLBSoerensen/Flexible-Camera-Calibration/blob/master/Demos/FlexibleCameraCalibration.ipynb)

Python implementation of:
- Schöps, T., Larsson, V., Pollefeys, M., & Sattler, T. (2019). Why Having 10,000 Parameters in Your Camera Model is Better Than Twelve. http://arxiv.org/abs/1912.02908
- Ramalingam, S., & Sturm, P. (2017). A Unifying Model for Camera Calibration. IEEE Transactions on Pattern Analysis and Machine Intelligence, 39(7), 1309–1319. https://doi.org/10.1109/TPAMI.2016.2592904

# Installation
- Recommended: Install flexiblecc from PyPI: 
```sh
pip install flexiblecc
```
- Alternatively: install flexiblecc from the GitHub source:

First, clone flexiblecc using `git`:

```sh
git clone https://github.com/SimonLBSoerensen/Flexible-Camera-Calibration
```

Then, `cd` to the folder and run the install command:
```sh
cd Flexible-Camera-Calibration
python setup.py install
```




%prep
%autosetup -n flexiblecc-1.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-flexiblecc -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
- Package Spec generated