%global _empty_manifest_terminate_build 0
Name: python-jss
Version: 0.1.0
Release: 1
Summary: JSON processing command line tool based on JSONSelect
License: UNKNOWN
URL: https://github.com/danvk/jss/
Source0: https://mirrors.aliyun.com/pypi/web/packages/a0/a6/6835f2dd02de41ed123661382ba70110d876afd960368e34d4689eb34cc5/jss-0.1.0.tar.gz
BuildArch: noarch
%description
jss is a JSON processing command line tool (like jq).
Unlike `jq `__, its selection language is
`JSONSelect `__, which is based on CSS
selectors. No need to learn an ad-hoc language for processing your JSON
files. Just use one you already know! Your time with jss won't be
wasted—it will make you better at writing CSS selectors.
%package -n python3-jss
Summary: JSON processing command line tool based on JSONSelect
Provides: python-jss
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-jss
jss is a JSON processing command line tool (like jq).
Unlike `jq `__, its selection language is
`JSONSelect `__, which is based on CSS
selectors. No need to learn an ad-hoc language for processing your JSON
files. Just use one you already know! Your time with jss won't be
wasted—it will make you better at writing CSS selectors.
%package help
Summary: Development documents and examples for jss
Provides: python3-jss-doc
%description help
jss is a JSON processing command line tool (like jq).
Unlike `jq `__, its selection language is
`JSONSelect `__, which is based on CSS
selectors. No need to learn an ad-hoc language for processing your JSON
files. Just use one you already know! Your time with jss won't be
wasted—it will make you better at writing CSS selectors.
%prep
%autosetup -n jss-0.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-jss -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.1.0-1
- Package Spec generated