%global _empty_manifest_terminate_build 0 Name: python-django-salesman Version: 1.2.0 Release: 1 Summary: Headless e-commerce framework for Django and Wagtail. License: BSD-3-Clause URL: https://pypi.org/project/django-salesman/ Source0: https://mirrors.aliyun.com/pypi/web/packages/38/16/55f65015e2c4971908b51efee034a17615b1c8a91012a23955f9fb227c6d/django_salesman-1.2.0.tar.gz BuildArch: noarch Requires: python3-django Requires: python3-djangorestframework Requires: python3-Pygments Requires: python3-wagtail Requires: python3-pytest Requires: python3-pytest-django Requires: python3-pytest-cov Requires: python3-sphinx Requires: python3-sphinx-rtd-theme Requires: python3-sphinx-autobuild Requires: python3-sphinxcontrib-httpdomain %description

Salesman logo

Headless e-commerce framework for Django and Wagtail.

PyPI GitHub - Test status Codecov branch PyPI - Python Version PyPI - Django Version Code style: black

**Salesman** provides a configurable system for building an online store. It includes a **RESTful** API with endpoints for manipulating the basket, processing the checkout and payment operations as well as managing customer orders. ## Features - API endpoints for **Basket**, **Checkout** and **Order** - Support for as many **Product** types needed using generic relations - Pluggable **Modifier** system for basket processing - **Payment** methods interface to support any gateway necessary - Customizable **Order** implementation - Fully swappable **Order** and **Basket** models - [Wagtail](https://wagtail.io/) and **Django** admin implementation ## Documentation Documentation is available on [Read the Docs](https://django-salesman.readthedocs.org). %package -n python3-django-salesman Summary: Headless e-commerce framework for Django and Wagtail. Provides: python-django-salesman BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-django-salesman

Salesman logo

Headless e-commerce framework for Django and Wagtail.

PyPI GitHub - Test status Codecov branch PyPI - Python Version PyPI - Django Version Code style: black

**Salesman** provides a configurable system for building an online store. It includes a **RESTful** API with endpoints for manipulating the basket, processing the checkout and payment operations as well as managing customer orders. ## Features - API endpoints for **Basket**, **Checkout** and **Order** - Support for as many **Product** types needed using generic relations - Pluggable **Modifier** system for basket processing - **Payment** methods interface to support any gateway necessary - Customizable **Order** implementation - Fully swappable **Order** and **Basket** models - [Wagtail](https://wagtail.io/) and **Django** admin implementation ## Documentation Documentation is available on [Read the Docs](https://django-salesman.readthedocs.org). %package help Summary: Development documents and examples for django-salesman Provides: python3-django-salesman-doc %description help

Salesman logo

Headless e-commerce framework for Django and Wagtail.

PyPI GitHub - Test status Codecov branch PyPI - Python Version PyPI - Django Version Code style: black

**Salesman** provides a configurable system for building an online store. It includes a **RESTful** API with endpoints for manipulating the basket, processing the checkout and payment operations as well as managing customer orders. ## Features - API endpoints for **Basket**, **Checkout** and **Order** - Support for as many **Product** types needed using generic relations - Pluggable **Modifier** system for basket processing - **Payment** methods interface to support any gateway necessary - Customizable **Order** implementation - Fully swappable **Order** and **Basket** models - [Wagtail](https://wagtail.io/) and **Django** admin implementation ## Documentation Documentation is available on [Read the Docs](https://django-salesman.readthedocs.org). %prep %autosetup -n django_salesman-1.2.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-django-salesman -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue Jun 20 2023 Python_Bot - 1.2.0-1 - Package Spec generated