%global _empty_manifest_terminate_build 0
Name: python-WaveGliDA
Version: 0.2.1
Release: 1
Summary: Import and quick plot ocean surface CO2 data from a wave glider
License: MIT License
URL: http://luke-gregor.github.io
Source0: https://mirrors.aliyun.com/pypi/web/packages/87/49/a9df2ea209189ff3b2568822a4d4377720e6de057ab06f994224d81e4851/WaveGliDA-0.2.1.tar.gz
BuildArch: noarch
Requires: python3-Flask
Requires: python3-Jinja2
Requires: python3-MarkupSafe
Requires: python3-PyExcelerate
Requires: python3-Pygments
Requires: python3-Werkzeug
Requires: python3-click
Requires: python3-itsdangerous
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-dateutil
Requires: python3-pytz
Requires: python3-seawater
Requires: python3-six
%description
# Wave Glider Data Analysis (WaveGliDA)
This software is created to read in files generated by a Wave Glider fitted with a CSIR CO2 sensor.
The script processes the text files that are sent via irridium.
## Usage
There should be a command line function available after installation:
WaveGliDA
if this fails run:
pyhton -m WaveGliDA
%package -n python3-WaveGliDA
Summary: Import and quick plot ocean surface CO2 data from a wave glider
Provides: python-WaveGliDA
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-WaveGliDA
# Wave Glider Data Analysis (WaveGliDA)
This software is created to read in files generated by a Wave Glider fitted with a CSIR CO2 sensor.
The script processes the text files that are sent via irridium.
## Usage
There should be a command line function available after installation:
WaveGliDA
if this fails run:
pyhton -m WaveGliDA
%package help
Summary: Development documents and examples for WaveGliDA
Provides: python3-WaveGliDA-doc
%description help
# Wave Glider Data Analysis (WaveGliDA)
This software is created to read in files generated by a Wave Glider fitted with a CSIR CO2 sensor.
The script processes the text files that are sent via irridium.
## Usage
There should be a command line function available after installation:
WaveGliDA
if this fails run:
pyhton -m WaveGliDA
%prep
%autosetup -n WaveGliDA-0.2.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-WaveGliDA -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.2.1-1
- Package Spec generated