%global _empty_manifest_terminate_build 0
Name: python-oddsjam-api
Version: 0.2.9
Release: 1
Summary: A lightweight OddsJam API wrapper
License: MIT License
URL: https://github.com/oddsjam/api-python
Source0: https://mirrors.aliyun.com/pypi/web/packages/ca/f5/842df7faae3828b0caf548a09049bf328580107ccb7617e6810e5c86df7f/oddsjam-api-0.2.9.tar.gz
BuildArch: noarch
%description
# oddsjam-api
: A lightweight OddsJam API wrapper
## V2 Update
V2 support is now available for the new endpoints/models listed at the [OddsJam Developer Page](https://developer.oddsjam.com/). The client exposed by this package is backwards compatible, and runs in v1 by default. Versions can be switched as follows:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
v1Results = Client.GetLeagues(); #Default v1 endpoints
Client.UseV2();
v2Results = Client.GetLeagues(); #v2 endpoints
```
This update comes with the following changes:
(*args: Any, **kwargs:Any) -> Any
. Please refer to the developer documentation for valid arguments.InvalidGetOddsV2Error
, and the endpoint will not be hit.oddsjam-api
?
oddsjam-api
is a fast, lightweight wrapper for the [OddsJam API](https://developer.oddsjam.com/). It strives to be as intuitive to use as possible, providing strongly typed requests and responses to ensure predictability and consistency.
## How do I use it?
Start by installing the oddsjam-api
package (currently only on TestPyPI):
```
pip install oddsjam-api
```
Create an instance of the OddsJamClient
:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
```
Then simply call whichever function you'd like to:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
GamesResponse = Client.GetGames();
```
Parameters are not required for any function call, but can be provided as desired:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
GamesResponse = Client.GetGames(league='ncaa', sport='football');
```
Parameters will raise specific errors:
``` python
GamesResponse = Client.GetGames(sport='curling');
#Raises SportError, with a list of valid values
OddsResponse = Client.GetOdds(sportsbook='212 Bet');
#Raises SportsBookError, with a list of valid values
```
Note: Sport and SportsBook parameters are *case insensitive*
Accessing the object of a response requires accessing the response's object:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
GamesResponse = Client.GetGames();
Games = GamesResponse.Games;
```
List comprehension can also be used to access objects:
``` python
AwayTeams = [g.away_team for g in GamesResponse.Games];
```
Nested objects can be accessed similarly:
``` python
OddsResponse = Client.GetOdds();
print(OddsResponse.Odds[0].game.sport)
```
The raw response from the API is also accessible via the *RawResponse* property of any *Response* object:
``` python
Raw = GamesResponse.RawResponse;
Jobj = json.loads(raw);
```
## Built-in functions
Convert entire Odds collection to decimal, then back to American:
``` python
OddsResponse = Client.GetOdds();
OddsResponse.AsDecimal();
OddsResponse.AsAmerican();
```
Convert individual Odds object to decimal, then back to American:
``` python
OddsResponse = Client.GetOdds();
FirstOdd = OddsResponse.Odds[0];
FirstOdd.AsDecimal();
FirstOdd.AsAmerican();
```
## Example usage
Flatten and output data using pandas:
``` python
import pandas as pd;
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
Odds = Client.GetOdds().Odds;
df = pd.DataFrame(Odds);
#Lambda over rows to extract just the ID from the 'game' object in each row
df['game'] = df.apply(lambda row: row['game']['id'], axis=1)
#Get odds for Moneyline markets only
df = df.loc[df['market_name'] == 'Moneyline']
```
# PyPi
* Prod: https://pypi.org/project/oddsjam-api
* Test: https://test.pypi.org/project/oddsjam-api-test
ORIGINAL CREDIT GOES TO https://github.com/cooperbrandon1
%package -n python3-oddsjam-api
Summary: A lightweight OddsJam API wrapper
Provides: python-oddsjam-api
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-oddsjam-api
# oddsjam-api
: A lightweight OddsJam API wrapper
## V2 Update
V2 support is now available for the new endpoints/models listed at the [OddsJam Developer Page](https://developer.oddsjam.com/). The client exposed by this package is backwards compatible, and runs in v1 by default. Versions can be switched as follows:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
v1Results = Client.GetLeagues(); #Default v1 endpoints
Client.UseV2();
v2Results = Client.GetLeagues(); #v2 endpoints
```
This update comes with the following changes:
(*args: Any, **kwargs:Any) -> Any
. Please refer to the developer documentation for valid arguments.InvalidGetOddsV2Error
, and the endpoint will not be hit.oddsjam-api
?
oddsjam-api
is a fast, lightweight wrapper for the [OddsJam API](https://developer.oddsjam.com/). It strives to be as intuitive to use as possible, providing strongly typed requests and responses to ensure predictability and consistency.
## How do I use it?
Start by installing the oddsjam-api
package (currently only on TestPyPI):
```
pip install oddsjam-api
```
Create an instance of the OddsJamClient
:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
```
Then simply call whichever function you'd like to:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
GamesResponse = Client.GetGames();
```
Parameters are not required for any function call, but can be provided as desired:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
GamesResponse = Client.GetGames(league='ncaa', sport='football');
```
Parameters will raise specific errors:
``` python
GamesResponse = Client.GetGames(sport='curling');
#Raises SportError, with a list of valid values
OddsResponse = Client.GetOdds(sportsbook='212 Bet');
#Raises SportsBookError, with a list of valid values
```
Note: Sport and SportsBook parameters are *case insensitive*
Accessing the object of a response requires accessing the response's object:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
GamesResponse = Client.GetGames();
Games = GamesResponse.Games;
```
List comprehension can also be used to access objects:
``` python
AwayTeams = [g.away_team for g in GamesResponse.Games];
```
Nested objects can be accessed similarly:
``` python
OddsResponse = Client.GetOdds();
print(OddsResponse.Odds[0].game.sport)
```
The raw response from the API is also accessible via the *RawResponse* property of any *Response* object:
``` python
Raw = GamesResponse.RawResponse;
Jobj = json.loads(raw);
```
## Built-in functions
Convert entire Odds collection to decimal, then back to American:
``` python
OddsResponse = Client.GetOdds();
OddsResponse.AsDecimal();
OddsResponse.AsAmerican();
```
Convert individual Odds object to decimal, then back to American:
``` python
OddsResponse = Client.GetOdds();
FirstOdd = OddsResponse.Odds[0];
FirstOdd.AsDecimal();
FirstOdd.AsAmerican();
```
## Example usage
Flatten and output data using pandas:
``` python
import pandas as pd;
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
Odds = Client.GetOdds().Odds;
df = pd.DataFrame(Odds);
#Lambda over rows to extract just the ID from the 'game' object in each row
df['game'] = df.apply(lambda row: row['game']['id'], axis=1)
#Get odds for Moneyline markets only
df = df.loc[df['market_name'] == 'Moneyline']
```
# PyPi
* Prod: https://pypi.org/project/oddsjam-api
* Test: https://test.pypi.org/project/oddsjam-api-test
ORIGINAL CREDIT GOES TO https://github.com/cooperbrandon1
%package help
Summary: Development documents and examples for oddsjam-api
Provides: python3-oddsjam-api-doc
%description help
# oddsjam-api
: A lightweight OddsJam API wrapper
## V2 Update
V2 support is now available for the new endpoints/models listed at the [OddsJam Developer Page](https://developer.oddsjam.com/). The client exposed by this package is backwards compatible, and runs in v1 by default. Versions can be switched as follows:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
v1Results = Client.GetLeagues(); #Default v1 endpoints
Client.UseV2();
v2Results = Client.GetLeagues(); #v2 endpoints
```
This update comes with the following changes:
(*args: Any, **kwargs:Any) -> Any
. Please refer to the developer documentation for valid arguments.InvalidGetOddsV2Error
, and the endpoint will not be hit.oddsjam-api
?
oddsjam-api
is a fast, lightweight wrapper for the [OddsJam API](https://developer.oddsjam.com/). It strives to be as intuitive to use as possible, providing strongly typed requests and responses to ensure predictability and consistency.
## How do I use it?
Start by installing the oddsjam-api
package (currently only on TestPyPI):
```
pip install oddsjam-api
```
Create an instance of the OddsJamClient
:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
```
Then simply call whichever function you'd like to:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
GamesResponse = Client.GetGames();
```
Parameters are not required for any function call, but can be provided as desired:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
GamesResponse = Client.GetGames(league='ncaa', sport='football');
```
Parameters will raise specific errors:
``` python
GamesResponse = Client.GetGames(sport='curling');
#Raises SportError, with a list of valid values
OddsResponse = Client.GetOdds(sportsbook='212 Bet');
#Raises SportsBookError, with a list of valid values
```
Note: Sport and SportsBook parameters are *case insensitive*
Accessing the object of a response requires accessing the response's object:
``` python
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
GamesResponse = Client.GetGames();
Games = GamesResponse.Games;
```
List comprehension can also be used to access objects:
``` python
AwayTeams = [g.away_team for g in GamesResponse.Games];
```
Nested objects can be accessed similarly:
``` python
OddsResponse = Client.GetOdds();
print(OddsResponse.Odds[0].game.sport)
```
The raw response from the API is also accessible via the *RawResponse* property of any *Response* object:
``` python
Raw = GamesResponse.RawResponse;
Jobj = json.loads(raw);
```
## Built-in functions
Convert entire Odds collection to decimal, then back to American:
``` python
OddsResponse = Client.GetOdds();
OddsResponse.AsDecimal();
OddsResponse.AsAmerican();
```
Convert individual Odds object to decimal, then back to American:
``` python
OddsResponse = Client.GetOdds();
FirstOdd = OddsResponse.Odds[0];
FirstOdd.AsDecimal();
FirstOdd.AsAmerican();
```
## Example usage
Flatten and output data using pandas:
``` python
import pandas as pd;
from OddsJamClient import OddsJamClient;
Client = OddsJamClient(YOUR_API_KEY);
Odds = Client.GetOdds().Odds;
df = pd.DataFrame(Odds);
#Lambda over rows to extract just the ID from the 'game' object in each row
df['game'] = df.apply(lambda row: row['game']['id'], axis=1)
#Get odds for Moneyline markets only
df = df.loc[df['market_name'] == 'Moneyline']
```
# PyPi
* Prod: https://pypi.org/project/oddsjam-api
* Test: https://test.pypi.org/project/oddsjam-api-test
ORIGINAL CREDIT GOES TO https://github.com/cooperbrandon1
%prep
%autosetup -n oddsjam-api-0.2.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-oddsjam-api -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot