%global _empty_manifest_terminate_build 0
Name: python-aiomixcloud
Version: 1.0.6
Release: 1
Summary: Mixcloud API wrapper for Python and Async IO
License: MIT
URL: https://github.com/amikrop/aiomixcloud
Source0: https://mirrors.aliyun.com/pypi/web/packages/f8/b6/414f478d0b8e2d0705e9b187869837f3d6835a8dd76223048afb17266b01/aiomixcloud-1.0.6.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-dateutil
%description
*aiomixcloud* is a wrapper library for the `HTTP API
`_ of `Mixcloud
`_. It supports asynchronous operation via
`asyncio `_ and specifically
the `aiohttp `_ framework.
*aiomixcloud* tries to be abstract and independent of the API's transient
structure, meaning it is not tied to specific JSON fields and resource types.
That is, when the API changes or expands, the library should be ready to
handle it.
%package -n python3-aiomixcloud
Summary: Mixcloud API wrapper for Python and Async IO
Provides: python-aiomixcloud
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-aiomixcloud
*aiomixcloud* is a wrapper library for the `HTTP API
`_ of `Mixcloud
`_. It supports asynchronous operation via
`asyncio `_ and specifically
the `aiohttp `_ framework.
*aiomixcloud* tries to be abstract and independent of the API's transient
structure, meaning it is not tied to specific JSON fields and resource types.
That is, when the API changes or expands, the library should be ready to
handle it.
%package help
Summary: Development documents and examples for aiomixcloud
Provides: python3-aiomixcloud-doc
%description help
*aiomixcloud* is a wrapper library for the `HTTP API
`_ of `Mixcloud
`_. It supports asynchronous operation via
`asyncio `_ and specifically
the `aiohttp `_ framework.
*aiomixcloud* tries to be abstract and independent of the API's transient
structure, meaning it is not tied to specific JSON fields and resource types.
That is, when the API changes or expands, the library should be ready to
handle it.
%prep
%autosetup -n aiomixcloud-1.0.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-aiomixcloud -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.0.6-1
- Package Spec generated