%global _empty_manifest_terminate_build 0
Name:		python-super-simple-test-sequencer
Version:	0.14.8
Release:	1
Summary:	Super simple test sequencer for production testing
License:	MIT License
URL:		https://www.jotautomation.com
Source0:	https://mirrors.aliyun.com/pypi/web/packages/70/da/1af111e36e6a75ed0264bbf2944791bc74cf29c5fb096db41f24c2f7a815/super_simple_test_sequencer-0.14.8.tar.gz
BuildArch:	noarch

Requires:	python3-PyYAML
Requires:	python3-colorama
Requires:	python3-coloredlogs
Requires:	python3-gaiaclient
Requires:	python3-json2html
Requires:	python3-tornado
Requires:	python3-wheel

%description
# Super Simple Test Sequencer

## Install

```
pip install super-simple-test-sequencer
```

## Create new test sequence

This command creates new empty/template test sequence to test_definitions/ directory.

```
super_simple_test_runner.py 
```

Modify the template at test_definitions/ to create your own sequence.

## Run sequence

```
super_simple_test_runner.py 
```


# More information

See video of the concept (in finnish):
https://youtu.be/x7MCSb7BLW4




%package -n python3-super-simple-test-sequencer
Summary:	Super simple test sequencer for production testing
Provides:	python-super-simple-test-sequencer
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-super-simple-test-sequencer
# Super Simple Test Sequencer

## Install

```
pip install super-simple-test-sequencer
```

## Create new test sequence

This command creates new empty/template test sequence to test_definitions/ directory.

```
super_simple_test_runner.py 
```

Modify the template at test_definitions/ to create your own sequence.

## Run sequence

```
super_simple_test_runner.py 
```


# More information

See video of the concept (in finnish):
https://youtu.be/x7MCSb7BLW4




%package help
Summary:	Development documents and examples for super-simple-test-sequencer
Provides:	python3-super-simple-test-sequencer-doc
%description help
# Super Simple Test Sequencer

## Install

```
pip install super-simple-test-sequencer
```

## Create new test sequence

This command creates new empty/template test sequence to test_definitions/ directory.

```
super_simple_test_runner.py 
```

Modify the template at test_definitions/ to create your own sequence.

## Run sequence

```
super_simple_test_runner.py 
```


# More information

See video of the concept (in finnish):
https://youtu.be/x7MCSb7BLW4




%prep
%autosetup -n super_simple_test_sequencer-0.14.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-super-simple-test-sequencer -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.14.8-1
- Package Spec generated