%global _empty_manifest_terminate_build 0
Name: python-jira-agile-toolbox
Version: 0.0.13
Release: 1
Summary: Extends standard jira package with agile specific tooling for metrics and administration
License: MIT
URL: https://github.com/studioj/jira-agile-toolbox
Source0: https://mirrors.aliyun.com/pypi/web/packages/7c/88/475a1d51e138f63033818a5afcf2c000a06cc0fbb7f59deacc3d95fe886e/jira_agile_toolbox-0.0.13.tar.gz
BuildArch: noarch
Requires: python3-jira
Requires: python3-pytest
%description
# jira_agile_toolbox
![python package workflow](https://github.com/studioj/jira-agile-toolbox/actions/workflows/python-publish.yml/badge.svg)
![python package workflow](https://github.com/studioj/jira-agile-toolbox/actions/workflows/python-package.yml/badge.svg)
[![Quality Gate Status](https://sonarcloud.io/api/project_badges/measure?project=studioj_jira-agile-toolbox&metric=alert_status)](https://sonarcloud.io/dashboard?id=studioj_jira-agile-toolbox)
[![PyPI downloads](https://img.shields.io/pypi/dm/jira-agile-toolbox.svg)](https://pypistats.org/packages/jira-agile-toolbox)
A python package which extends the jira package with agile related functionality
For more info about the jira package
- PyPi: https://pypi.org/project/jira/
- rtd: https://jira.readthedocs.io/en/latest/
## Installation
```bash
pip install jira-agile-toolbox
```
## Documentation
https://jira-agile-toolbox.readthedocs.io/
## Features
- ### Getting story points from an epic
Example:
```python
>>> from jira_agile_toolbox import JiraAgileToolBox
>>> from jira import JIRA
>>> my_jira_client = JIRA("https://my-jira-server.com", basic_auth=("MYUSERNAME","MYPASSWORD"))
>>> tb = JiraAgileToolBox(my_jira_client)
>>> tb.get_storypoints_from_epic("JAT-001")
{'total': 100, "Reported": 50, "Closed": 50}
```
- ### Ranking a list of epics on top of another one
Example:
```python
>>> from jira_agile_toolbox import JiraAgileToolBox
>>> from jira import JIRA
>>> my_jira_client = JIRA("https://my-jira-server.com", basic_auth=("MYUSERNAME","MYPASSWORD"))
>>> tb = JiraAgileToolBox(my_jira_client)
>>> tb.rank_issues_by_list([my_jira_client.issue("JAT-001"), my_jira_client.issue("JAT-003")], my_jira_client.issue("JAT-005"))
```
will rank issues like:
| original | result |
| -------- | ------ |
| JAT-010 | JAT-010
| JAT-005 | JAT-001
| JAT-003 | JAT-003
| JAT-002 | JAT-005
| JAT-001 | JAT-002
- ### more explanation and examples can be found here
https://jira-agile-toolbox.readthedocs.io/en/stable/#api-documentation
%package -n python3-jira-agile-toolbox
Summary: Extends standard jira package with agile specific tooling for metrics and administration
Provides: python-jira-agile-toolbox
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-jira-agile-toolbox
# jira_agile_toolbox
![python package workflow](https://github.com/studioj/jira-agile-toolbox/actions/workflows/python-publish.yml/badge.svg)
![python package workflow](https://github.com/studioj/jira-agile-toolbox/actions/workflows/python-package.yml/badge.svg)
[![Quality Gate Status](https://sonarcloud.io/api/project_badges/measure?project=studioj_jira-agile-toolbox&metric=alert_status)](https://sonarcloud.io/dashboard?id=studioj_jira-agile-toolbox)
[![PyPI downloads](https://img.shields.io/pypi/dm/jira-agile-toolbox.svg)](https://pypistats.org/packages/jira-agile-toolbox)
A python package which extends the jira package with agile related functionality
For more info about the jira package
- PyPi: https://pypi.org/project/jira/
- rtd: https://jira.readthedocs.io/en/latest/
## Installation
```bash
pip install jira-agile-toolbox
```
## Documentation
https://jira-agile-toolbox.readthedocs.io/
## Features
- ### Getting story points from an epic
Example:
```python
>>> from jira_agile_toolbox import JiraAgileToolBox
>>> from jira import JIRA
>>> my_jira_client = JIRA("https://my-jira-server.com", basic_auth=("MYUSERNAME","MYPASSWORD"))
>>> tb = JiraAgileToolBox(my_jira_client)
>>> tb.get_storypoints_from_epic("JAT-001")
{'total': 100, "Reported": 50, "Closed": 50}
```
- ### Ranking a list of epics on top of another one
Example:
```python
>>> from jira_agile_toolbox import JiraAgileToolBox
>>> from jira import JIRA
>>> my_jira_client = JIRA("https://my-jira-server.com", basic_auth=("MYUSERNAME","MYPASSWORD"))
>>> tb = JiraAgileToolBox(my_jira_client)
>>> tb.rank_issues_by_list([my_jira_client.issue("JAT-001"), my_jira_client.issue("JAT-003")], my_jira_client.issue("JAT-005"))
```
will rank issues like:
| original | result |
| -------- | ------ |
| JAT-010 | JAT-010
| JAT-005 | JAT-001
| JAT-003 | JAT-003
| JAT-002 | JAT-005
| JAT-001 | JAT-002
- ### more explanation and examples can be found here
https://jira-agile-toolbox.readthedocs.io/en/stable/#api-documentation
%package help
Summary: Development documents and examples for jira-agile-toolbox
Provides: python3-jira-agile-toolbox-doc
%description help
# jira_agile_toolbox
![python package workflow](https://github.com/studioj/jira-agile-toolbox/actions/workflows/python-publish.yml/badge.svg)
![python package workflow](https://github.com/studioj/jira-agile-toolbox/actions/workflows/python-package.yml/badge.svg)
[![Quality Gate Status](https://sonarcloud.io/api/project_badges/measure?project=studioj_jira-agile-toolbox&metric=alert_status)](https://sonarcloud.io/dashboard?id=studioj_jira-agile-toolbox)
[![PyPI downloads](https://img.shields.io/pypi/dm/jira-agile-toolbox.svg)](https://pypistats.org/packages/jira-agile-toolbox)
A python package which extends the jira package with agile related functionality
For more info about the jira package
- PyPi: https://pypi.org/project/jira/
- rtd: https://jira.readthedocs.io/en/latest/
## Installation
```bash
pip install jira-agile-toolbox
```
## Documentation
https://jira-agile-toolbox.readthedocs.io/
## Features
- ### Getting story points from an epic
Example:
```python
>>> from jira_agile_toolbox import JiraAgileToolBox
>>> from jira import JIRA
>>> my_jira_client = JIRA("https://my-jira-server.com", basic_auth=("MYUSERNAME","MYPASSWORD"))
>>> tb = JiraAgileToolBox(my_jira_client)
>>> tb.get_storypoints_from_epic("JAT-001")
{'total': 100, "Reported": 50, "Closed": 50}
```
- ### Ranking a list of epics on top of another one
Example:
```python
>>> from jira_agile_toolbox import JiraAgileToolBox
>>> from jira import JIRA
>>> my_jira_client = JIRA("https://my-jira-server.com", basic_auth=("MYUSERNAME","MYPASSWORD"))
>>> tb = JiraAgileToolBox(my_jira_client)
>>> tb.rank_issues_by_list([my_jira_client.issue("JAT-001"), my_jira_client.issue("JAT-003")], my_jira_client.issue("JAT-005"))
```
will rank issues like:
| original | result |
| -------- | ------ |
| JAT-010 | JAT-010
| JAT-005 | JAT-001
| JAT-003 | JAT-003
| JAT-002 | JAT-005
| JAT-001 | JAT-002
- ### more explanation and examples can be found here
https://jira-agile-toolbox.readthedocs.io/en/stable/#api-documentation
%prep
%autosetup -n jira_agile_toolbox-0.0.13
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-jira-agile-toolbox -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.0.13-1
- Package Spec generated