%global _empty_manifest_terminate_build 0
Name: python-openbox
Version: 0.8.1
Release: 1
Summary: Efficient and generalized blackbox optimization (BBO) system
License: MIT License Copyright (c) 2023 DAIR Lab @ Peking University Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. The OpenBox license applies to all parts of OpenBox that are not externally maintained codes. The externally maintained codes used by OpenBox are parts of: - base surrogates, located at openbox/surrogate/base/, - acquisition functions, located at openbox/acquisition_function/acquisition.py, - acquisition optimizers, located at openbox/acq_optimizer/, are licensed as follows: ''' SMAC License ============ ============ BSD 3-Clause License Copyright (c) 2016-2018, Ml4AAD Group (http://www.ml4aad.org/) All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: * Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. * Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. * Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. License of other files ====================== ====================== RoBO ==== Gaussian process files are built on code from RoBO and/or are copied from RoBO: https://github.com/automl/RoBO smac/epm/gaussian_process.py smac/epm/gaussian_process_mcmc.py smac/epm/gp_base_prior.py smac/epm/gp_default_priors.py License: Copyright (c) 2015, automl All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: * Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. * Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. * Neither the name of RoBO nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. '''
URL: https://pypi.org/project/openbox/
Source0: https://mirrors.aliyun.com/pypi/web/packages/95/24/d94e6bd4174cfe891b4357ea69dde7391123639f73a9503ae45ae90b89b7/openbox-0.8.1.tar.gz
BuildArch: noarch
Requires: python3-cython
Requires: python3-psutil
Requires: python3-setuptools
Requires: python3-requests
Requires: python3-tqdm
Requires: python3-prettytable
Requires: python3-colorama
Requires: python3-matplotlib
Requires: python3-pandas
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-scikit-learn
Requires: python3-scikit-optimize
Requires: python3-ConfigSpace
Requires: python3-emcee
Requires: python3-statsmodels
Requires: python3-platypus-opt
Requires: python3-setuptools
Requires: python3-build
Requires: python3-wheel
Requires: python3-twine
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-docutils
Requires: python3-sphinx
Requires: python3-myst-parser
Requires: python3-linkify-it-py
Requires: python3-furo
Requires: python3-sphinx-copybutton
Requires: python3-sphinx-notfound-page
Requires: python3-sphinx-hoverxref
Requires: python3-setuptools
Requires: python3-build
Requires: python3-wheel
Requires: python3-twine
Requires: python3-docutils
Requires: python3-sphinx
Requires: python3-myst-parser
Requires: python3-linkify-it-py
Requires: python3-furo
Requires: python3-sphinx-copybutton
Requires: python3-sphinx-notfound-page
Requires: python3-sphinx-hoverxref
Requires: python3-pyrfr
Requires: python3-shap
Requires: python3-lightgbm
Requires: python3-hiplot
Requires: python3-cma
Requires: python3-django
Requires: python3-pymongo
Requires: python3-bson
Requires: python3-pyjwt
Requires: python3-pyrfr
Requires: python3-shap
Requires: python3-lightgbm
Requires: python3-hiplot
Requires: python3-cma
Requires: python3-pytest
Requires: python3-pytest-cov
%description
[](
https://github.com/PKU-DAIR/open-box/blob/master/LICENSE)
[](
https://github.com/PKU-DAIR/open-box/issues?q=is%3Aissue+is%3Aopen)
[](
https://github.com/PKU-DAIR/open-box/pulls?q=is%3Apr+is%3Aopen)
[](
https://github.com/PKU-DAIR/open-box/releases)
[](https://github.com/PKU-DAIR/open-box/actions/workflows/test.yml)
[](
https://open-box.readthedocs.io/)
[OpenBox Documentation](https://open-box.readthedocs.io)
| [OpenBox中文文档](https://open-box.readthedocs.io/zh_CN/latest/)
| [中文README](https://github.com/PKU-DAIR/open-box/blob/master/README_zh_CN.md)
## OpenBox: Generalized and Efficient Blackbox Optimization System
**OpenBox** is an efficient and generalized blackbox optimization (BBO) system, which supports the following
characteristics: 1) **BBO with multiple objectives and constraints**, 2) **BBO with transfer learning**, 3)
**BBO with distributed parallelization**, 4) **BBO with multi-fidelity acceleration** and 5) **BBO with early stops**.
OpenBox is designed and developed by the AutoML team from the [DAIR Lab](http://net.pku.edu.cn/~cuibin/) at Peking
University, and its goal is to make blackbox optimization easier to apply both in industry and academia, and help
facilitate data science.
## Software Artifacts
#### Standalone Python package.
Users can install the released package and use it with Python.
#### Distributed BBO service.
We adopt the "BBO as a service" paradigm and implement OpenBox as a managed general service for black-box optimization.
Users can access this service via REST API conveniently, and do not need to worry about other issues such as environment
setup, software maintenance, programming, and optimization of the execution. Moreover, we also provide a Web UI,
through which users can easily track and manage the tasks.
## Design Goal
The design of OpenBox follows the following principles:
+ **Ease of use**: Minimal user effort, and user-friendly visualization for tracking and managing BBO tasks.
+ **Consistent performance**: Host state-of-the-art optimization algorithms; Choose the proper algorithm automatically.
+ **Resource-aware management**: Give cost-model-based advice to users, e.g., minimal workers or time-budget.
+ **Scalability**: Scale to dimensions on the number of input variables, objectives, tasks, trials, and parallel
evaluations.
+ **High efficiency**: Effective use of parallel resources, system optimization with transfer-learning and
multi-fidelities, etc.
+ **Fault tolerance**, **extensibility**, and **data privacy protection**.
## Links
+ [Documentations](https://open-box.readthedocs.io/en/latest/) |
[中文文档](https://open-box.readthedocs.io/zh_CN/latest/)
+ [Examples](https://github.com/PKU-DAIR/open-box/tree/master/examples)
+ [Pypi package](https://pypi.org/project/openbox/)
+ Conda package: [to appear soon]()
+ Blog post: [to appear soon]()
## News
+ **OpenBox** based solutions achieved the **First Place** of
[ACM CIKM 2021 AnalyticCup](https://www.cikm2021.org/analyticup)
(Track - Automated Hyperparameter Optimization of Recommendation System).
+ **OpenBox** team won the **Top Prize (special prize)** in the open-source innovation competition at
[2021 CCF ChinaSoft](http://chinasoft.ccf.org.cn/papers/chinasoft.html) conference.
+ [**Pasca**](https://github.com/PKU-DAIR/SGL), which adopts Openbox to support neural architecture search
functionality, won the **Best Student Paper Award at WWW'22**.
## OpenBox Capabilities in a Glance
Build-in Optimization Components
|
Optimization Algorithms
|
Optimization Services
|
- Surrogate Model
- Gaussian Process
- TPE
- Probabilistic Random Forest
- LightGBM
- Acquisition Optimizer
- Random Search
- Local Search
- Interleaved RS and LS
- Differential Evolution
- L-BFGS-B
|
- Bayesian Optimization
- GP-based BO
- SMAC
- TPE
- LineBO
- SafeOpt
- Multi-fidelity Optimization
- Evolutionary Algorithms
- Surrogate-assisted EA
- Regularized EA
- Adaptive EA
- Differential EA
- NSGA-II
|
|
## Installation
### System Requirements
Installation Requirements:
+ Python >= 3.7 (Python 3.7 is recommended!)
Supported Systems:
+ Linux (Ubuntu, ...)
+ macOS
+ Windows
We **strongly** suggest you to create a Python environment via
[Anaconda](https://www.anaconda.com/products/individual#Downloads):
```bash
conda create -n openbox python=3.7
conda activate openbox
```
Then we recommend you to update your `pip`, `setuptools` and `wheel` as follows:
```bash
pip install --upgrade pip setuptools wheel
```
### Installation from PyPI
To install OpenBox from PyPI:
```bash
pip install openbox
```
For advanced features, [install SWIG](https://open-box.readthedocs.io/en/latest/installation/install_swig.html)
first and then run `pip install "openbox[extra]"`.
### Manual Installation from Source
To install the newest OpenBox from the source code, please run the following commands:
```bash
git clone https://github.com/PKU-DAIR/open-box.git && cd open-box
pip install .
```
Also, for advanced features, [install SWIG](https://open-box.readthedocs.io/en/latest/installation/install_swig.html)
first and then run `pip install ".[extra]"`.
For more details about installation instructions, please refer to the
[Installation Guide](https://open-box.readthedocs.io/en/latest/installation/installation_guide.html).
## Quick Start
A quick start example is given by:
```python
import numpy as np
from openbox import Optimizer, space as sp
# Define Search Space
space = sp.Space()
x1 = sp.Real("x1", -5, 10, default_value=0)
x2 = sp.Real("x2", 0, 15, default_value=0)
space.add_variables([x1, x2])
# Define Objective Function
def branin(config):
x1, x2 = config['x1'], config['x2']
y = (x2-5.1/(4*np.pi**2)*x1**2+5/np.pi*x1-6)**2+10*(1-1/(8*np.pi))*np.cos(x1)+10
return {'objectives': [y]}
# Run
if __name__ == '__main__':
opt = Optimizer(branin, space, max_runs=50, task_id='quick_start')
history = opt.run()
print(history)
```
The example with multi-objectives and constraints is as follows:
```python
import matplotlib.pyplot as plt
from openbox import Optimizer, space as sp
# Define Search Space
space = sp.Space()
x1 = sp.Real("x1", 0.1, 10.0)
x2 = sp.Real("x2", 0.0, 5.0)
space.add_variables([x1, x2])
# Define Objective Function
def CONSTR(config):
x1, x2 = config['x1'], config['x2']
y1, y2 = x1, (1.0 + x2) / x1
c1, c2 = 6.0 - 9.0 * x1 - x2, 1.0 - 9.0 * x1 + x2
return dict(objectives=[y1, y2], constraints=[c1, c2])
# Run
if __name__ == "__main__":
opt = Optimizer(CONSTR, space, num_objectives=2, num_constraints=2,
max_runs=50, ref_point=[10.0, 10.0], task_id='moc')
history = opt.run()
history.plot_pareto_front() # plot for 2 or 3 objectives
plt.show()
```
We also provide **HTML Visualization**. Enable it by setting additional options
`visualization`=`basic`/`advanced` and `auto_open_html=True`(optional) in `Optimizer`:
```python
opt = Optimizer(...,
visualization='advanced', # or 'basic'. For 'advanced', run 'pip install "openbox[extra]"' first
auto_open_html=True, # open the visualization page in your browser automatically
)
history = opt.run()
```
For more visualization details, please refer to
[HTML Visualization](https://open-box.readthedocs.io/en/latest/visualization/visualization.html).
**More Examples**:
+ [Single-Objective with Constraints](
https://github.com/PKU-DAIR/open-box/blob/master/examples/optimize_problem_with_constraint.py)
+ [Multi-Objective](https://github.com/PKU-DAIR/open-box/blob/master/examples/optimize_multi_objective.py)
+ [Multi-Objective with Constraints](
https://github.com/PKU-DAIR/open-box/blob/master/examples/optimize_multi_objective_with_constraint.py)
+ [Ask-and-tell Interface](https://github.com/PKU-DAIR/open-box/blob/master/examples/ask_and_tell_interface.py)
+ [Parallel Evaluation on Local](
https://github.com/PKU-DAIR/open-box/blob/master/examples/evaluate_async_parallel_optimization.py)
+ [Distributed Evaluation](https://github.com/PKU-DAIR/open-box/blob/master/examples/distributed_optimization.py)
+ [Tuning LightGBM](https://github.com/PKU-DAIR/open-box/blob/master/examples/tuning_lightgbm.py)
+ [Tuning XGBoost](https://github.com/PKU-DAIR/open-box/blob/master/examples/tuning_xgboost.py)
## **Enterprise Users**
* [Tencent Inc.](https://www.tencent.com/en-us/)
* [Alibaba Group](https://www.alibabagroup.com/en-US/)
* [Kuaishou Technology](https://www.kuaishou.com/en)
## **Contributing**
OpenBox has a frequent release cycle. Please let us know if you encounter a bug by
[filling an issue](https://github.com/PKU-DAIR/open-box/issues/new/choose).
We appreciate all contributions. If you are planning to contribute any bug-fixes,
please create a [pull request](https://github.com/PKU-DAIR/open-box/pulls).
If you plan to contribute new features, new modules, etc. please first open an issue or reuse an existing issue,
and discuss the feature with us.
To learn more about making a contribution to OpenBox, please refer to our
[How-to contribution page](https://github.com/PKU-DAIR/open-box/blob/master/CONTRIBUTING.md).
We appreciate all contributions and thank all the contributors!
## **Feedback**
* [File an issue](https://github.com/PKU-DAIR/open-box/issues) on GitHub
* Email us via [*Yang Li*](https://thomas-young-2013.github.io/),
*shenyu@pku.edu.cn* or *jianghuaijun@pku.edu.cn*
* [Q&A] Join the QQ group: 227229622
## **Related Projects**
Targeting at openness and advancing AutoML ecosystems, we had also released few other open-source projects.
* [MindWare](https://github.com/PKU-DAIR/mindware): an open source system that provides end-to-end ML model training
and inference capabilities.
* [SGL](https://github.com/PKU-DAIR/SGL): a scalable graph learning toolkit for extremely large graph datasets.
* [HyperTune](https://github.com/PKU-DAIR/HyperTune): a large-scale multi-fidelity hyper-parameter tuning system.
## **Related Publications**
**OpenBox: A Generalized Black-box Optimization Service.**
Yang Li, Yu Shen, Wentao Zhang, Yuanwei Chen, Huaijun Jiang, Mingchao Liu, Jiawei Jiang, Jinyang Gao, Wentao Wu,
Zhi Yang, Ce Zhang, Bin Cui; KDD 2021, CCF-A.
https://arxiv.org/abs/2106.00421
**MFES-HB: Efficient Hyperband with Multi-Fidelity Quality Measurements.**
Yang Li, Yu Shen, Jiawei Jiang, Jinyang Gao, Ce Zhang, Bin Cui; AAAI 2021, CCF-A.
https://arxiv.org/abs/2012.03011
**Transfer Learning based Search Space Design for Hyperparameter Tuning.**
Yang Li, Yu Shen, Huaijun Jiang, Tianyi Bai, Wentao Zhang, Ce Zhang, Bin Cui; KDD 2022, CCF-A.
https://arxiv.org/abs/2206.02511
**TransBO: Hyperparameter Optimization via Two-Phase Transfer Learning.**
Yang Li, Yu Shen, Huaijun Jiang, Wentao Zhang, Zhi Yang, Ce Zhang, Bin Cui; KDD 2022, CCF-A.
https://arxiv.org/abs/2206.02663
**PaSca: a Graph Neural Architecture Search System under the Scalable Paradigm.**
Wentao Zhang, Yu Shen, Zheyu Lin, Yang Li, Xiaosen Li, Wen Ouyang, Yangyu Tao, Zhi Yang, and Bin Cui;
WWW 2022, CCF-A, 🏆 Best Student Paper Award.
https://arxiv.org/abs/2203.00638
**Hyper-Tune: Towards Efficient Hyper-parameter Tuning at Scale.**
Yang Li, Yu Shen, Huaijun Jiang, Wentao Zhang, Jixiang Li, Ji Liu, Ce Zhang, Bin Cui; VLDB 2022, CCF-A.
https://arxiv.org/abs/2201.06834
## **License**
The entire codebase is under [MIT license](LICENSE).
%package -n python3-openbox
Summary: Efficient and generalized blackbox optimization (BBO) system
Provides: python-openbox
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-openbox
[](
https://github.com/PKU-DAIR/open-box/blob/master/LICENSE)
[](
https://github.com/PKU-DAIR/open-box/issues?q=is%3Aissue+is%3Aopen)
[](
https://github.com/PKU-DAIR/open-box/pulls?q=is%3Apr+is%3Aopen)
[](
https://github.com/PKU-DAIR/open-box/releases)
[](https://github.com/PKU-DAIR/open-box/actions/workflows/test.yml)
[](
https://open-box.readthedocs.io/)
[OpenBox Documentation](https://open-box.readthedocs.io)
| [OpenBox中文文档](https://open-box.readthedocs.io/zh_CN/latest/)
| [中文README](https://github.com/PKU-DAIR/open-box/blob/master/README_zh_CN.md)
## OpenBox: Generalized and Efficient Blackbox Optimization System
**OpenBox** is an efficient and generalized blackbox optimization (BBO) system, which supports the following
characteristics: 1) **BBO with multiple objectives and constraints**, 2) **BBO with transfer learning**, 3)
**BBO with distributed parallelization**, 4) **BBO with multi-fidelity acceleration** and 5) **BBO with early stops**.
OpenBox is designed and developed by the AutoML team from the [DAIR Lab](http://net.pku.edu.cn/~cuibin/) at Peking
University, and its goal is to make blackbox optimization easier to apply both in industry and academia, and help
facilitate data science.
## Software Artifacts
#### Standalone Python package.
Users can install the released package and use it with Python.
#### Distributed BBO service.
We adopt the "BBO as a service" paradigm and implement OpenBox as a managed general service for black-box optimization.
Users can access this service via REST API conveniently, and do not need to worry about other issues such as environment
setup, software maintenance, programming, and optimization of the execution. Moreover, we also provide a Web UI,
through which users can easily track and manage the tasks.
## Design Goal
The design of OpenBox follows the following principles:
+ **Ease of use**: Minimal user effort, and user-friendly visualization for tracking and managing BBO tasks.
+ **Consistent performance**: Host state-of-the-art optimization algorithms; Choose the proper algorithm automatically.
+ **Resource-aware management**: Give cost-model-based advice to users, e.g., minimal workers or time-budget.
+ **Scalability**: Scale to dimensions on the number of input variables, objectives, tasks, trials, and parallel
evaluations.
+ **High efficiency**: Effective use of parallel resources, system optimization with transfer-learning and
multi-fidelities, etc.
+ **Fault tolerance**, **extensibility**, and **data privacy protection**.
## Links
+ [Documentations](https://open-box.readthedocs.io/en/latest/) |
[中文文档](https://open-box.readthedocs.io/zh_CN/latest/)
+ [Examples](https://github.com/PKU-DAIR/open-box/tree/master/examples)
+ [Pypi package](https://pypi.org/project/openbox/)
+ Conda package: [to appear soon]()
+ Blog post: [to appear soon]()
## News
+ **OpenBox** based solutions achieved the **First Place** of
[ACM CIKM 2021 AnalyticCup](https://www.cikm2021.org/analyticup)
(Track - Automated Hyperparameter Optimization of Recommendation System).
+ **OpenBox** team won the **Top Prize (special prize)** in the open-source innovation competition at
[2021 CCF ChinaSoft](http://chinasoft.ccf.org.cn/papers/chinasoft.html) conference.
+ [**Pasca**](https://github.com/PKU-DAIR/SGL), which adopts Openbox to support neural architecture search
functionality, won the **Best Student Paper Award at WWW'22**.
## OpenBox Capabilities in a Glance
Build-in Optimization Components
|
Optimization Algorithms
|
Optimization Services
|
- Surrogate Model
- Gaussian Process
- TPE
- Probabilistic Random Forest
- LightGBM
- Acquisition Optimizer
- Random Search
- Local Search
- Interleaved RS and LS
- Differential Evolution
- L-BFGS-B
|
- Bayesian Optimization
- GP-based BO
- SMAC
- TPE
- LineBO
- SafeOpt
- Multi-fidelity Optimization
- Evolutionary Algorithms
- Surrogate-assisted EA
- Regularized EA
- Adaptive EA
- Differential EA
- NSGA-II
|
|
## Installation
### System Requirements
Installation Requirements:
+ Python >= 3.7 (Python 3.7 is recommended!)
Supported Systems:
+ Linux (Ubuntu, ...)
+ macOS
+ Windows
We **strongly** suggest you to create a Python environment via
[Anaconda](https://www.anaconda.com/products/individual#Downloads):
```bash
conda create -n openbox python=3.7
conda activate openbox
```
Then we recommend you to update your `pip`, `setuptools` and `wheel` as follows:
```bash
pip install --upgrade pip setuptools wheel
```
### Installation from PyPI
To install OpenBox from PyPI:
```bash
pip install openbox
```
For advanced features, [install SWIG](https://open-box.readthedocs.io/en/latest/installation/install_swig.html)
first and then run `pip install "openbox[extra]"`.
### Manual Installation from Source
To install the newest OpenBox from the source code, please run the following commands:
```bash
git clone https://github.com/PKU-DAIR/open-box.git && cd open-box
pip install .
```
Also, for advanced features, [install SWIG](https://open-box.readthedocs.io/en/latest/installation/install_swig.html)
first and then run `pip install ".[extra]"`.
For more details about installation instructions, please refer to the
[Installation Guide](https://open-box.readthedocs.io/en/latest/installation/installation_guide.html).
## Quick Start
A quick start example is given by:
```python
import numpy as np
from openbox import Optimizer, space as sp
# Define Search Space
space = sp.Space()
x1 = sp.Real("x1", -5, 10, default_value=0)
x2 = sp.Real("x2", 0, 15, default_value=0)
space.add_variables([x1, x2])
# Define Objective Function
def branin(config):
x1, x2 = config['x1'], config['x2']
y = (x2-5.1/(4*np.pi**2)*x1**2+5/np.pi*x1-6)**2+10*(1-1/(8*np.pi))*np.cos(x1)+10
return {'objectives': [y]}
# Run
if __name__ == '__main__':
opt = Optimizer(branin, space, max_runs=50, task_id='quick_start')
history = opt.run()
print(history)
```
The example with multi-objectives and constraints is as follows:
```python
import matplotlib.pyplot as plt
from openbox import Optimizer, space as sp
# Define Search Space
space = sp.Space()
x1 = sp.Real("x1", 0.1, 10.0)
x2 = sp.Real("x2", 0.0, 5.0)
space.add_variables([x1, x2])
# Define Objective Function
def CONSTR(config):
x1, x2 = config['x1'], config['x2']
y1, y2 = x1, (1.0 + x2) / x1
c1, c2 = 6.0 - 9.0 * x1 - x2, 1.0 - 9.0 * x1 + x2
return dict(objectives=[y1, y2], constraints=[c1, c2])
# Run
if __name__ == "__main__":
opt = Optimizer(CONSTR, space, num_objectives=2, num_constraints=2,
max_runs=50, ref_point=[10.0, 10.0], task_id='moc')
history = opt.run()
history.plot_pareto_front() # plot for 2 or 3 objectives
plt.show()
```
We also provide **HTML Visualization**. Enable it by setting additional options
`visualization`=`basic`/`advanced` and `auto_open_html=True`(optional) in `Optimizer`:
```python
opt = Optimizer(...,
visualization='advanced', # or 'basic'. For 'advanced', run 'pip install "openbox[extra]"' first
auto_open_html=True, # open the visualization page in your browser automatically
)
history = opt.run()
```
For more visualization details, please refer to
[HTML Visualization](https://open-box.readthedocs.io/en/latest/visualization/visualization.html).
**More Examples**:
+ [Single-Objective with Constraints](
https://github.com/PKU-DAIR/open-box/blob/master/examples/optimize_problem_with_constraint.py)
+ [Multi-Objective](https://github.com/PKU-DAIR/open-box/blob/master/examples/optimize_multi_objective.py)
+ [Multi-Objective with Constraints](
https://github.com/PKU-DAIR/open-box/blob/master/examples/optimize_multi_objective_with_constraint.py)
+ [Ask-and-tell Interface](https://github.com/PKU-DAIR/open-box/blob/master/examples/ask_and_tell_interface.py)
+ [Parallel Evaluation on Local](
https://github.com/PKU-DAIR/open-box/blob/master/examples/evaluate_async_parallel_optimization.py)
+ [Distributed Evaluation](https://github.com/PKU-DAIR/open-box/blob/master/examples/distributed_optimization.py)
+ [Tuning LightGBM](https://github.com/PKU-DAIR/open-box/blob/master/examples/tuning_lightgbm.py)
+ [Tuning XGBoost](https://github.com/PKU-DAIR/open-box/blob/master/examples/tuning_xgboost.py)
## **Enterprise Users**
* [Tencent Inc.](https://www.tencent.com/en-us/)
* [Alibaba Group](https://www.alibabagroup.com/en-US/)
* [Kuaishou Technology](https://www.kuaishou.com/en)
## **Contributing**
OpenBox has a frequent release cycle. Please let us know if you encounter a bug by
[filling an issue](https://github.com/PKU-DAIR/open-box/issues/new/choose).
We appreciate all contributions. If you are planning to contribute any bug-fixes,
please create a [pull request](https://github.com/PKU-DAIR/open-box/pulls).
If you plan to contribute new features, new modules, etc. please first open an issue or reuse an existing issue,
and discuss the feature with us.
To learn more about making a contribution to OpenBox, please refer to our
[How-to contribution page](https://github.com/PKU-DAIR/open-box/blob/master/CONTRIBUTING.md).
We appreciate all contributions and thank all the contributors!
## **Feedback**
* [File an issue](https://github.com/PKU-DAIR/open-box/issues) on GitHub
* Email us via [*Yang Li*](https://thomas-young-2013.github.io/),
*shenyu@pku.edu.cn* or *jianghuaijun@pku.edu.cn*
* [Q&A] Join the QQ group: 227229622
## **Related Projects**
Targeting at openness and advancing AutoML ecosystems, we had also released few other open-source projects.
* [MindWare](https://github.com/PKU-DAIR/mindware): an open source system that provides end-to-end ML model training
and inference capabilities.
* [SGL](https://github.com/PKU-DAIR/SGL): a scalable graph learning toolkit for extremely large graph datasets.
* [HyperTune](https://github.com/PKU-DAIR/HyperTune): a large-scale multi-fidelity hyper-parameter tuning system.
## **Related Publications**
**OpenBox: A Generalized Black-box Optimization Service.**
Yang Li, Yu Shen, Wentao Zhang, Yuanwei Chen, Huaijun Jiang, Mingchao Liu, Jiawei Jiang, Jinyang Gao, Wentao Wu,
Zhi Yang, Ce Zhang, Bin Cui; KDD 2021, CCF-A.
https://arxiv.org/abs/2106.00421
**MFES-HB: Efficient Hyperband with Multi-Fidelity Quality Measurements.**
Yang Li, Yu Shen, Jiawei Jiang, Jinyang Gao, Ce Zhang, Bin Cui; AAAI 2021, CCF-A.
https://arxiv.org/abs/2012.03011
**Transfer Learning based Search Space Design for Hyperparameter Tuning.**
Yang Li, Yu Shen, Huaijun Jiang, Tianyi Bai, Wentao Zhang, Ce Zhang, Bin Cui; KDD 2022, CCF-A.
https://arxiv.org/abs/2206.02511
**TransBO: Hyperparameter Optimization via Two-Phase Transfer Learning.**
Yang Li, Yu Shen, Huaijun Jiang, Wentao Zhang, Zhi Yang, Ce Zhang, Bin Cui; KDD 2022, CCF-A.
https://arxiv.org/abs/2206.02663
**PaSca: a Graph Neural Architecture Search System under the Scalable Paradigm.**
Wentao Zhang, Yu Shen, Zheyu Lin, Yang Li, Xiaosen Li, Wen Ouyang, Yangyu Tao, Zhi Yang, and Bin Cui;
WWW 2022, CCF-A, 🏆 Best Student Paper Award.
https://arxiv.org/abs/2203.00638
**Hyper-Tune: Towards Efficient Hyper-parameter Tuning at Scale.**
Yang Li, Yu Shen, Huaijun Jiang, Wentao Zhang, Jixiang Li, Ji Liu, Ce Zhang, Bin Cui; VLDB 2022, CCF-A.
https://arxiv.org/abs/2201.06834
## **License**
The entire codebase is under [MIT license](LICENSE).
%package help
Summary: Development documents and examples for openbox
Provides: python3-openbox-doc
%description help
[](
https://github.com/PKU-DAIR/open-box/blob/master/LICENSE)
[](
https://github.com/PKU-DAIR/open-box/issues?q=is%3Aissue+is%3Aopen)
[](
https://github.com/PKU-DAIR/open-box/pulls?q=is%3Apr+is%3Aopen)
[](
https://github.com/PKU-DAIR/open-box/releases)
[](https://github.com/PKU-DAIR/open-box/actions/workflows/test.yml)
[](
https://open-box.readthedocs.io/)
[OpenBox Documentation](https://open-box.readthedocs.io)
| [OpenBox中文文档](https://open-box.readthedocs.io/zh_CN/latest/)
| [中文README](https://github.com/PKU-DAIR/open-box/blob/master/README_zh_CN.md)
## OpenBox: Generalized and Efficient Blackbox Optimization System
**OpenBox** is an efficient and generalized blackbox optimization (BBO) system, which supports the following
characteristics: 1) **BBO with multiple objectives and constraints**, 2) **BBO with transfer learning**, 3)
**BBO with distributed parallelization**, 4) **BBO with multi-fidelity acceleration** and 5) **BBO with early stops**.
OpenBox is designed and developed by the AutoML team from the [DAIR Lab](http://net.pku.edu.cn/~cuibin/) at Peking
University, and its goal is to make blackbox optimization easier to apply both in industry and academia, and help
facilitate data science.
## Software Artifacts
#### Standalone Python package.
Users can install the released package and use it with Python.
#### Distributed BBO service.
We adopt the "BBO as a service" paradigm and implement OpenBox as a managed general service for black-box optimization.
Users can access this service via REST API conveniently, and do not need to worry about other issues such as environment
setup, software maintenance, programming, and optimization of the execution. Moreover, we also provide a Web UI,
through which users can easily track and manage the tasks.
## Design Goal
The design of OpenBox follows the following principles:
+ **Ease of use**: Minimal user effort, and user-friendly visualization for tracking and managing BBO tasks.
+ **Consistent performance**: Host state-of-the-art optimization algorithms; Choose the proper algorithm automatically.
+ **Resource-aware management**: Give cost-model-based advice to users, e.g., minimal workers or time-budget.
+ **Scalability**: Scale to dimensions on the number of input variables, objectives, tasks, trials, and parallel
evaluations.
+ **High efficiency**: Effective use of parallel resources, system optimization with transfer-learning and
multi-fidelities, etc.
+ **Fault tolerance**, **extensibility**, and **data privacy protection**.
## Links
+ [Documentations](https://open-box.readthedocs.io/en/latest/) |
[中文文档](https://open-box.readthedocs.io/zh_CN/latest/)
+ [Examples](https://github.com/PKU-DAIR/open-box/tree/master/examples)
+ [Pypi package](https://pypi.org/project/openbox/)
+ Conda package: [to appear soon]()
+ Blog post: [to appear soon]()
## News
+ **OpenBox** based solutions achieved the **First Place** of
[ACM CIKM 2021 AnalyticCup](https://www.cikm2021.org/analyticup)
(Track - Automated Hyperparameter Optimization of Recommendation System).
+ **OpenBox** team won the **Top Prize (special prize)** in the open-source innovation competition at
[2021 CCF ChinaSoft](http://chinasoft.ccf.org.cn/papers/chinasoft.html) conference.
+ [**Pasca**](https://github.com/PKU-DAIR/SGL), which adopts Openbox to support neural architecture search
functionality, won the **Best Student Paper Award at WWW'22**.
## OpenBox Capabilities in a Glance
Build-in Optimization Components
|
Optimization Algorithms
|
Optimization Services
|
- Surrogate Model
- Gaussian Process
- TPE
- Probabilistic Random Forest
- LightGBM
- Acquisition Optimizer
- Random Search
- Local Search
- Interleaved RS and LS
- Differential Evolution
- L-BFGS-B
|
- Bayesian Optimization
- GP-based BO
- SMAC
- TPE
- LineBO
- SafeOpt
- Multi-fidelity Optimization
- Evolutionary Algorithms
- Surrogate-assisted EA
- Regularized EA
- Adaptive EA
- Differential EA
- NSGA-II
|
|
## Installation
### System Requirements
Installation Requirements:
+ Python >= 3.7 (Python 3.7 is recommended!)
Supported Systems:
+ Linux (Ubuntu, ...)
+ macOS
+ Windows
We **strongly** suggest you to create a Python environment via
[Anaconda](https://www.anaconda.com/products/individual#Downloads):
```bash
conda create -n openbox python=3.7
conda activate openbox
```
Then we recommend you to update your `pip`, `setuptools` and `wheel` as follows:
```bash
pip install --upgrade pip setuptools wheel
```
### Installation from PyPI
To install OpenBox from PyPI:
```bash
pip install openbox
```
For advanced features, [install SWIG](https://open-box.readthedocs.io/en/latest/installation/install_swig.html)
first and then run `pip install "openbox[extra]"`.
### Manual Installation from Source
To install the newest OpenBox from the source code, please run the following commands:
```bash
git clone https://github.com/PKU-DAIR/open-box.git && cd open-box
pip install .
```
Also, for advanced features, [install SWIG](https://open-box.readthedocs.io/en/latest/installation/install_swig.html)
first and then run `pip install ".[extra]"`.
For more details about installation instructions, please refer to the
[Installation Guide](https://open-box.readthedocs.io/en/latest/installation/installation_guide.html).
## Quick Start
A quick start example is given by:
```python
import numpy as np
from openbox import Optimizer, space as sp
# Define Search Space
space = sp.Space()
x1 = sp.Real("x1", -5, 10, default_value=0)
x2 = sp.Real("x2", 0, 15, default_value=0)
space.add_variables([x1, x2])
# Define Objective Function
def branin(config):
x1, x2 = config['x1'], config['x2']
y = (x2-5.1/(4*np.pi**2)*x1**2+5/np.pi*x1-6)**2+10*(1-1/(8*np.pi))*np.cos(x1)+10
return {'objectives': [y]}
# Run
if __name__ == '__main__':
opt = Optimizer(branin, space, max_runs=50, task_id='quick_start')
history = opt.run()
print(history)
```
The example with multi-objectives and constraints is as follows:
```python
import matplotlib.pyplot as plt
from openbox import Optimizer, space as sp
# Define Search Space
space = sp.Space()
x1 = sp.Real("x1", 0.1, 10.0)
x2 = sp.Real("x2", 0.0, 5.0)
space.add_variables([x1, x2])
# Define Objective Function
def CONSTR(config):
x1, x2 = config['x1'], config['x2']
y1, y2 = x1, (1.0 + x2) / x1
c1, c2 = 6.0 - 9.0 * x1 - x2, 1.0 - 9.0 * x1 + x2
return dict(objectives=[y1, y2], constraints=[c1, c2])
# Run
if __name__ == "__main__":
opt = Optimizer(CONSTR, space, num_objectives=2, num_constraints=2,
max_runs=50, ref_point=[10.0, 10.0], task_id='moc')
history = opt.run()
history.plot_pareto_front() # plot for 2 or 3 objectives
plt.show()
```
We also provide **HTML Visualization**. Enable it by setting additional options
`visualization`=`basic`/`advanced` and `auto_open_html=True`(optional) in `Optimizer`:
```python
opt = Optimizer(...,
visualization='advanced', # or 'basic'. For 'advanced', run 'pip install "openbox[extra]"' first
auto_open_html=True, # open the visualization page in your browser automatically
)
history = opt.run()
```
For more visualization details, please refer to
[HTML Visualization](https://open-box.readthedocs.io/en/latest/visualization/visualization.html).
**More Examples**:
+ [Single-Objective with Constraints](
https://github.com/PKU-DAIR/open-box/blob/master/examples/optimize_problem_with_constraint.py)
+ [Multi-Objective](https://github.com/PKU-DAIR/open-box/blob/master/examples/optimize_multi_objective.py)
+ [Multi-Objective with Constraints](
https://github.com/PKU-DAIR/open-box/blob/master/examples/optimize_multi_objective_with_constraint.py)
+ [Ask-and-tell Interface](https://github.com/PKU-DAIR/open-box/blob/master/examples/ask_and_tell_interface.py)
+ [Parallel Evaluation on Local](
https://github.com/PKU-DAIR/open-box/blob/master/examples/evaluate_async_parallel_optimization.py)
+ [Distributed Evaluation](https://github.com/PKU-DAIR/open-box/blob/master/examples/distributed_optimization.py)
+ [Tuning LightGBM](https://github.com/PKU-DAIR/open-box/blob/master/examples/tuning_lightgbm.py)
+ [Tuning XGBoost](https://github.com/PKU-DAIR/open-box/blob/master/examples/tuning_xgboost.py)
## **Enterprise Users**
* [Tencent Inc.](https://www.tencent.com/en-us/)
* [Alibaba Group](https://www.alibabagroup.com/en-US/)
* [Kuaishou Technology](https://www.kuaishou.com/en)
## **Contributing**
OpenBox has a frequent release cycle. Please let us know if you encounter a bug by
[filling an issue](https://github.com/PKU-DAIR/open-box/issues/new/choose).
We appreciate all contributions. If you are planning to contribute any bug-fixes,
please create a [pull request](https://github.com/PKU-DAIR/open-box/pulls).
If you plan to contribute new features, new modules, etc. please first open an issue or reuse an existing issue,
and discuss the feature with us.
To learn more about making a contribution to OpenBox, please refer to our
[How-to contribution page](https://github.com/PKU-DAIR/open-box/blob/master/CONTRIBUTING.md).
We appreciate all contributions and thank all the contributors!
## **Feedback**
* [File an issue](https://github.com/PKU-DAIR/open-box/issues) on GitHub
* Email us via [*Yang Li*](https://thomas-young-2013.github.io/),
*shenyu@pku.edu.cn* or *jianghuaijun@pku.edu.cn*
* [Q&A] Join the QQ group: 227229622
## **Related Projects**
Targeting at openness and advancing AutoML ecosystems, we had also released few other open-source projects.
* [MindWare](https://github.com/PKU-DAIR/mindware): an open source system that provides end-to-end ML model training
and inference capabilities.
* [SGL](https://github.com/PKU-DAIR/SGL): a scalable graph learning toolkit for extremely large graph datasets.
* [HyperTune](https://github.com/PKU-DAIR/HyperTune): a large-scale multi-fidelity hyper-parameter tuning system.
## **Related Publications**
**OpenBox: A Generalized Black-box Optimization Service.**
Yang Li, Yu Shen, Wentao Zhang, Yuanwei Chen, Huaijun Jiang, Mingchao Liu, Jiawei Jiang, Jinyang Gao, Wentao Wu,
Zhi Yang, Ce Zhang, Bin Cui; KDD 2021, CCF-A.
https://arxiv.org/abs/2106.00421
**MFES-HB: Efficient Hyperband with Multi-Fidelity Quality Measurements.**
Yang Li, Yu Shen, Jiawei Jiang, Jinyang Gao, Ce Zhang, Bin Cui; AAAI 2021, CCF-A.
https://arxiv.org/abs/2012.03011
**Transfer Learning based Search Space Design for Hyperparameter Tuning.**
Yang Li, Yu Shen, Huaijun Jiang, Tianyi Bai, Wentao Zhang, Ce Zhang, Bin Cui; KDD 2022, CCF-A.
https://arxiv.org/abs/2206.02511
**TransBO: Hyperparameter Optimization via Two-Phase Transfer Learning.**
Yang Li, Yu Shen, Huaijun Jiang, Wentao Zhang, Zhi Yang, Ce Zhang, Bin Cui; KDD 2022, CCF-A.
https://arxiv.org/abs/2206.02663
**PaSca: a Graph Neural Architecture Search System under the Scalable Paradigm.**
Wentao Zhang, Yu Shen, Zheyu Lin, Yang Li, Xiaosen Li, Wen Ouyang, Yangyu Tao, Zhi Yang, and Bin Cui;
WWW 2022, CCF-A, 🏆 Best Student Paper Award.
https://arxiv.org/abs/2203.00638
**Hyper-Tune: Towards Efficient Hyper-parameter Tuning at Scale.**
Yang Li, Yu Shen, Huaijun Jiang, Wentao Zhang, Jixiang Li, Ji Liu, Ce Zhang, Bin Cui; VLDB 2022, CCF-A.
https://arxiv.org/abs/2201.06834
## **License**
The entire codebase is under [MIT license](LICENSE).
%prep
%autosetup -n openbox-0.8.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-openbox -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.8.1-1
- Package Spec generated