%global _empty_manifest_terminate_build 0
Name: python-spotipy2
Version: 0.6.1
Release: 1
Summary: The next generation Spotify Web API wrapper for Python
License: LGPLv3+
URL: https://spotipy2.org/
Source0: https://mirrors.aliyun.com/pypi/web/packages/99/19/676a8067ce50563b86b91f5f65d4c6fb60e1b13713353ff11613cc682363/spotipy2-0.6.1.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-pymongo
%description
The next generation Spotify Web API wrapper for Python
Documentation
•
Releases
•
Community
### Quick example
```python
import asyncio
from spotipy2 import Spotify
from spotipy2.auth import ClientCredentialsFlow
async def get_track_name(track_id):
client = Spotify(
ClientCredentialsFlow(
client_id="client_id",
client_secret="client_secret"
)
)
async with client as s:
track = await s.get_track(track_id)
print(f"The name of the track is {track.name}")
asyncio.run(get_track_name(input("Insert the track ID: ")))
```
### Key Features
- **Easy** - Makes the Spotify API easy to understand and intuitive, without giving less customization.
- **Fast** - Thanks to its async design and [`aiohttp`](https://github.com/aio-libs/aiohttp) speed, spotipy2 is incredibly fast
- **Type-hinted** - All the methods and types are type-hinted, enabling excellent IDE support
- **Documented** - API methods, types and interfaces are all well documented
### Installing
```bash
pip install spotipy2
```
## Resources
- Check out the docs at https://spotipy2.org to learn about Spotipy2.
- For any issue, open one [here](https://github.com/CyanBook/spotipy2/issues) or contact me privately via [Telegram](https://t.me/CyanBook).
- If you have anything else to ask, feel free to open a [discussion](https://github.com/CyanBook/spotipy2/discussions)
%package -n python3-spotipy2
Summary: The next generation Spotify Web API wrapper for Python
Provides: python-spotipy2
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-spotipy2
The next generation Spotify Web API wrapper for Python
Documentation
•
Releases
•
Community
### Quick example
```python
import asyncio
from spotipy2 import Spotify
from spotipy2.auth import ClientCredentialsFlow
async def get_track_name(track_id):
client = Spotify(
ClientCredentialsFlow(
client_id="client_id",
client_secret="client_secret"
)
)
async with client as s:
track = await s.get_track(track_id)
print(f"The name of the track is {track.name}")
asyncio.run(get_track_name(input("Insert the track ID: ")))
```
### Key Features
- **Easy** - Makes the Spotify API easy to understand and intuitive, without giving less customization.
- **Fast** - Thanks to its async design and [`aiohttp`](https://github.com/aio-libs/aiohttp) speed, spotipy2 is incredibly fast
- **Type-hinted** - All the methods and types are type-hinted, enabling excellent IDE support
- **Documented** - API methods, types and interfaces are all well documented
### Installing
```bash
pip install spotipy2
```
## Resources
- Check out the docs at https://spotipy2.org to learn about Spotipy2.
- For any issue, open one [here](https://github.com/CyanBook/spotipy2/issues) or contact me privately via [Telegram](https://t.me/CyanBook).
- If you have anything else to ask, feel free to open a [discussion](https://github.com/CyanBook/spotipy2/discussions)
%package help
Summary: Development documents and examples for spotipy2
Provides: python3-spotipy2-doc
%description help
The next generation Spotify Web API wrapper for Python
Documentation
•
Releases
•
Community
### Quick example
```python
import asyncio
from spotipy2 import Spotify
from spotipy2.auth import ClientCredentialsFlow
async def get_track_name(track_id):
client = Spotify(
ClientCredentialsFlow(
client_id="client_id",
client_secret="client_secret"
)
)
async with client as s:
track = await s.get_track(track_id)
print(f"The name of the track is {track.name}")
asyncio.run(get_track_name(input("Insert the track ID: ")))
```
### Key Features
- **Easy** - Makes the Spotify API easy to understand and intuitive, without giving less customization.
- **Fast** - Thanks to its async design and [`aiohttp`](https://github.com/aio-libs/aiohttp) speed, spotipy2 is incredibly fast
- **Type-hinted** - All the methods and types are type-hinted, enabling excellent IDE support
- **Documented** - API methods, types and interfaces are all well documented
### Installing
```bash
pip install spotipy2
```
## Resources
- Check out the docs at https://spotipy2.org to learn about Spotipy2.
- For any issue, open one [here](https://github.com/CyanBook/spotipy2/issues) or contact me privately via [Telegram](https://t.me/CyanBook).
- If you have anything else to ask, feel free to open a [discussion](https://github.com/CyanBook/spotipy2/discussions)
%prep
%autosetup -n spotipy2-0.6.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-spotipy2 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.6.1-1
- Package Spec generated