%global _empty_manifest_terminate_build 0
Name: python-pyjs-bridge
Version: 1.0
Release: 1
Summary: Vulcan's python-javascript api bridge
License: Apache Software License
URL: https://github.com/vulcan-coalition/pyjs.git
Source0: https://mirrors.aliyun.com/pypi/web/packages/5f/75/98f3f822260fe41213efbb606bd3b2fcee62be62e02760505bcc66f632c6/pyjs-bridge-1.0.tar.gz
BuildArch: noarch
Requires: python3-fastapi
Requires: python3-aiofiles
Requires: python3-jose[cryptography]
Requires: python3-multipart
Requires: python3-jsmin
Requires: python3-uvicorn
Requires: python3-websockets
%description
## Server functions
- **__main__.broadcast**(**message** : str, **p1** : int = 0, **p2** : any = undefined)
This is the broadcast function.
- **__main__.another**(**p0** : int, **p1** : str = "a", **p2** : any = undefined)
This is another function.
## Client callbacks
- **another**(**p0** : int, **p1** : str = "a", **p2** : any = undefined)
This is another function.
- **incoming_message**(**p0** : any = undefined)
This is the incoming_message function.
%package -n python3-pyjs-bridge
Summary: Vulcan's python-javascript api bridge
Provides: python-pyjs-bridge
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyjs-bridge
## Server functions
- **__main__.broadcast**(**message** : str, **p1** : int = 0, **p2** : any = undefined)
This is the broadcast function.
- **__main__.another**(**p0** : int, **p1** : str = "a", **p2** : any = undefined)
This is another function.
## Client callbacks
- **another**(**p0** : int, **p1** : str = "a", **p2** : any = undefined)
This is another function.
- **incoming_message**(**p0** : any = undefined)
This is the incoming_message function.
%package help
Summary: Development documents and examples for pyjs-bridge
Provides: python3-pyjs-bridge-doc
%description help
## Server functions
- **__main__.broadcast**(**message** : str, **p1** : int = 0, **p2** : any = undefined)
This is the broadcast function.
- **__main__.another**(**p0** : int, **p1** : str = "a", **p2** : any = undefined)
This is another function.
## Client callbacks
- **another**(**p0** : int, **p1** : str = "a", **p2** : any = undefined)
This is another function.
- **incoming_message**(**p0** : any = undefined)
This is the incoming_message function.
%prep
%autosetup -n pyjs-bridge-1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyjs-bridge -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.0-1
- Package Spec generated