%global _empty_manifest_terminate_build 0
Name: python-StdConfigParser
Version: 1.0.1
Release: 1
Summary: A standard INI style configuration parser.
License: MIT
URL: https://github.com/tds333/stdconfigparser
Source0: https://mirrors.aliyun.com/pypi/web/packages/d5/14/849f6f907beecd2c24acb35bee397483d96687f00ff429d2c7331a4027aa/StdConfigParser-1.0.1.tar.gz
BuildArch: noarch
%description
This is the Python configparser with an extra class StdConfigParser.
The StdConfigParser class uses specified parameters to initialize
the Python ConfigParser and adds some useful converters.
The result is a simple well defined syntax for the INI file.
See it as a preconfigured ConfigParser class for you.
It allows interoperability in configuration between different projects.
Also contains everything to be a full backport of the configparser module from
Python 3.5 to Python 2.7, 3.3, 3.4.
Everything in one module easy to vendor or install no extra dependencies.
`Documentation `_
`ChangeLog `_
`Source code on github `_
Example config file::
[section]
option = value
envlisting = env1,env2,env3
valuelist = multi line
values
# with comment
fetchable as list
[other_section]
# interpolation is a optional feature
name = ${section:option}-substitution
%package -n python3-StdConfigParser
Summary: A standard INI style configuration parser.
Provides: python-StdConfigParser
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-StdConfigParser
This is the Python configparser with an extra class StdConfigParser.
The StdConfigParser class uses specified parameters to initialize
the Python ConfigParser and adds some useful converters.
The result is a simple well defined syntax for the INI file.
See it as a preconfigured ConfigParser class for you.
It allows interoperability in configuration between different projects.
Also contains everything to be a full backport of the configparser module from
Python 3.5 to Python 2.7, 3.3, 3.4.
Everything in one module easy to vendor or install no extra dependencies.
`Documentation `_
`ChangeLog `_
`Source code on github `_
Example config file::
[section]
option = value
envlisting = env1,env2,env3
valuelist = multi line
values
# with comment
fetchable as list
[other_section]
# interpolation is a optional feature
name = ${section:option}-substitution
%package help
Summary: Development documents and examples for StdConfigParser
Provides: python3-StdConfigParser-doc
%description help
This is the Python configparser with an extra class StdConfigParser.
The StdConfigParser class uses specified parameters to initialize
the Python ConfigParser and adds some useful converters.
The result is a simple well defined syntax for the INI file.
See it as a preconfigured ConfigParser class for you.
It allows interoperability in configuration between different projects.
Also contains everything to be a full backport of the configparser module from
Python 3.5 to Python 2.7, 3.3, 3.4.
Everything in one module easy to vendor or install no extra dependencies.
`Documentation `_
`ChangeLog `_
`Source code on github `_
Example config file::
[section]
option = value
envlisting = env1,env2,env3
valuelist = multi line
values
# with comment
fetchable as list
[other_section]
# interpolation is a optional feature
name = ${section:option}-substitution
%prep
%autosetup -n StdConfigParser-1.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-StdConfigParser -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.0.1-1
- Package Spec generated