%global _empty_manifest_terminate_build 0
Name: python-caerus
Version: 0.1.9
Release: 1
Summary: Python package caerus
License: MIT License
URL: https://erdogant.github.io/caerus
Source0: https://mirrors.aliyun.com/pypi/web/packages/e9/03/f6d2dae24fec813fea5896913219c1910bc30431b3c52db193f55d28a642/caerus-0.1.9.tar.gz
BuildArch: noarch
Requires: python3-wget
Requires: python3-matplotlib
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-tqdm
%description
# caerus
[![Python](https://img.shields.io/pypi/pyversions/caerus)](https://img.shields.io/pypi/pyversions/caerus)
[![PyPI Version](https://img.shields.io/pypi/v/caerus)](https://pypi.org/project/caerus/)
[![License](https://img.shields.io/badge/license-MIT-green.svg)](https://github.com/erdogant/caerus/blob/master/LICENSE)
[![Downloads](https://pepy.tech/badge/caerus)](https://pepy.tech/project/caerus)
[![Downloads](https://pepy.tech/badge/caerus/month)](https://pepy.tech/project/caerus/month)
[![Sphinx](https://img.shields.io/badge/Sphinx-Docs-Green)](https://erdogant.github.io/caerus/)
``caerus`` is Python package to compute the local-minima with the corresponding local-maxima within the given time-frame. This approach is designed to for stock-market valley and peak detection.
Here are just a few of the things that caerus does well:
- Ouput contains detected start-stop regions of local minima and maxima.
- Figures are created.
- Parameter gridsearch.
- Designed for the detection of complex trend movements.
#
**⭐️ Star this repo if you like it ⭐️**
#
#### Install caerus from PyPI
```bash
pip install caerus
```
#### Import caerus package
```python
from caerus import caerus
```
#
### [Documentation pages](https://erdogant.github.io/caerus/)
On the [documentation pages](https://erdogant.github.io/caerus/) you can find detailed information about the working of the ``caerus`` with examples.
### Examples
#
* [Example: Detect peak and valleys in Bitcoin](https://erdogant.github.io/caerus/pages/html/Examples.html)
#
* [Example: Detect peak and valleys in Facebook](https://erdogant.github.io/caerus/pages/html/Examples.html)
* [Example: Gridsearch](https://erdogant.github.io/caerus/pages/html/Examples.html#gridsearch)
### Support
This project needs some love! ❤️
Contribute to this project by feature requests, idea discussions, reporting bugs, opening pull requests, or through Github Sponsors. Your help is highly appreciated.
* If you wish to buy me a Coffee for this work, it is very appreciated :)
[![Github Sponsors](https://img.shields.io/github/sponsors/erdogant?label=github%20sponsors&logo=github%20sponsors&style=for-the-badge)](https://github.com/sponsors/erdogant)
### Maintainers
* Erdogan Taskesen, github: [erdogant](https://github.com/erdogant)
%package -n python3-caerus
Summary: Python package caerus
Provides: python-caerus
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-caerus
# caerus
[![Python](https://img.shields.io/pypi/pyversions/caerus)](https://img.shields.io/pypi/pyversions/caerus)
[![PyPI Version](https://img.shields.io/pypi/v/caerus)](https://pypi.org/project/caerus/)
[![License](https://img.shields.io/badge/license-MIT-green.svg)](https://github.com/erdogant/caerus/blob/master/LICENSE)
[![Downloads](https://pepy.tech/badge/caerus)](https://pepy.tech/project/caerus)
[![Downloads](https://pepy.tech/badge/caerus/month)](https://pepy.tech/project/caerus/month)
[![Sphinx](https://img.shields.io/badge/Sphinx-Docs-Green)](https://erdogant.github.io/caerus/)
``caerus`` is Python package to compute the local-minima with the corresponding local-maxima within the given time-frame. This approach is designed to for stock-market valley and peak detection.
Here are just a few of the things that caerus does well:
- Ouput contains detected start-stop regions of local minima and maxima.
- Figures are created.
- Parameter gridsearch.
- Designed for the detection of complex trend movements.
#
**⭐️ Star this repo if you like it ⭐️**
#
#### Install caerus from PyPI
```bash
pip install caerus
```
#### Import caerus package
```python
from caerus import caerus
```
#
### [Documentation pages](https://erdogant.github.io/caerus/)
On the [documentation pages](https://erdogant.github.io/caerus/) you can find detailed information about the working of the ``caerus`` with examples.
### Examples
#
* [Example: Detect peak and valleys in Bitcoin](https://erdogant.github.io/caerus/pages/html/Examples.html)
#
* [Example: Detect peak and valleys in Facebook](https://erdogant.github.io/caerus/pages/html/Examples.html)
* [Example: Gridsearch](https://erdogant.github.io/caerus/pages/html/Examples.html#gridsearch)
### Support
This project needs some love! ❤️
Contribute to this project by feature requests, idea discussions, reporting bugs, opening pull requests, or through Github Sponsors. Your help is highly appreciated.
* If you wish to buy me a Coffee for this work, it is very appreciated :)
[![Github Sponsors](https://img.shields.io/github/sponsors/erdogant?label=github%20sponsors&logo=github%20sponsors&style=for-the-badge)](https://github.com/sponsors/erdogant)
### Maintainers
* Erdogan Taskesen, github: [erdogant](https://github.com/erdogant)
%package help
Summary: Development documents and examples for caerus
Provides: python3-caerus-doc
%description help
# caerus
[![Python](https://img.shields.io/pypi/pyversions/caerus)](https://img.shields.io/pypi/pyversions/caerus)
[![PyPI Version](https://img.shields.io/pypi/v/caerus)](https://pypi.org/project/caerus/)
[![License](https://img.shields.io/badge/license-MIT-green.svg)](https://github.com/erdogant/caerus/blob/master/LICENSE)
[![Downloads](https://pepy.tech/badge/caerus)](https://pepy.tech/project/caerus)
[![Downloads](https://pepy.tech/badge/caerus/month)](https://pepy.tech/project/caerus/month)
[![Sphinx](https://img.shields.io/badge/Sphinx-Docs-Green)](https://erdogant.github.io/caerus/)
``caerus`` is Python package to compute the local-minima with the corresponding local-maxima within the given time-frame. This approach is designed to for stock-market valley and peak detection.
Here are just a few of the things that caerus does well:
- Ouput contains detected start-stop regions of local minima and maxima.
- Figures are created.
- Parameter gridsearch.
- Designed for the detection of complex trend movements.
#
**⭐️ Star this repo if you like it ⭐️**
#
#### Install caerus from PyPI
```bash
pip install caerus
```
#### Import caerus package
```python
from caerus import caerus
```
#
### [Documentation pages](https://erdogant.github.io/caerus/)
On the [documentation pages](https://erdogant.github.io/caerus/) you can find detailed information about the working of the ``caerus`` with examples.
### Examples
#
* [Example: Detect peak and valleys in Bitcoin](https://erdogant.github.io/caerus/pages/html/Examples.html)
#
* [Example: Detect peak and valleys in Facebook](https://erdogant.github.io/caerus/pages/html/Examples.html)
* [Example: Gridsearch](https://erdogant.github.io/caerus/pages/html/Examples.html#gridsearch)
### Support
This project needs some love! ❤️
Contribute to this project by feature requests, idea discussions, reporting bugs, opening pull requests, or through Github Sponsors. Your help is highly appreciated.
* If you wish to buy me a Coffee for this work, it is very appreciated :)
[![Github Sponsors](https://img.shields.io/github/sponsors/erdogant?label=github%20sponsors&logo=github%20sponsors&style=for-the-badge)](https://github.com/sponsors/erdogant)
### Maintainers
* Erdogan Taskesen, github: [erdogant](https://github.com/erdogant)
%prep
%autosetup -n caerus-0.1.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-caerus -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.1.9-1
- Package Spec generated