%global _empty_manifest_terminate_build 0
Name:		python-stegoveritas-py010parser
Version:	0.1.10
Release:	1
Summary:	010 template parser in Python
License:	BSD
URL:		https://github.com/bannsec/py010parser/tree/stegoveritas
Source0:	https://mirrors.aliyun.com/pypi/web/packages/70/ae/08560b79218aa51c0d1e79a9042d7b5c476cbceb25a61562f1875052f416/stegoveritas-py010parser-0.1.10.tar.gz
BuildArch:	noarch


%description
py010parser is a modified fork of the pycparser project. It is
		pure Python using the PLY parsing library. It parses 010 templates
		into an AST.

%package -n python3-stegoveritas-py010parser
Summary:	010 template parser in Python
Provides:	python-stegoveritas-py010parser
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-stegoveritas-py010parser
py010parser is a modified fork of the pycparser project. It is
		pure Python using the PLY parsing library. It parses 010 templates
		into an AST.

%package help
Summary:	Development documents and examples for stegoveritas-py010parser
Provides:	python3-stegoveritas-py010parser-doc
%description help
py010parser is a modified fork of the pycparser project. It is
		pure Python using the PLY parsing library. It parses 010 templates
		into an AST.

%prep
%autosetup -n stegoveritas-py010parser-0.1.10

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-stegoveritas-py010parser -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.10-1
- Package Spec generated