%global _empty_manifest_terminate_build 0
Name:		python-wappdriver
Version:	0.6.6
Release:	1
Summary:	A package that automates sending messages through WhatsApp Web
License:	MIT
URL:		https://github.com/aahnik/wappdriver
Source0:	https://mirrors.aliyun.com/pypi/web/packages/0d/13/797df15b0e9b32553c34ece2ff5d42e1a8d3fb4d11c2da6e471c27796430/wappdriver-0.6.6.tar.gz
BuildArch:	noarch

Requires:	python3-selenium
Requires:	python3-pyyaml
Requires:	python3-requests
Requires:	python3-pyfiglet
Requires:	python3-verlat
Requires:	python3-emoji

%description
# wappdriver

API for WhatsApp Web Automation

Wondering how to send WhatsApp messages using Python using only three lines of code? **You have come to the right place!**

[![Tests](https://img.shields.io/badge/tests-passing-green)](https://aahnik.github.io/wappdriver/docs/Tests.html)
[![Maintenance](https://img.shields.io/maintenance/yes/2020)](https://github.com/aahnik/wappdriver/graphs/commit-activity)
[![GitHub Release](https://img.shields.io/github/v/release/aahnik/wappdriver)](https://github.com/aahnik/wappdriver/releases)
[![CodeFactor](https://www.codefactor.io/repository/github/aahnik/wappdriver/badge)](https://www.codefactor.io/repository/github/aahnik/wappdriver)
[![MIT LICENSE](https://img.shields.io/pypi/l/ansicolortags.svg)](/LICENSE)
[![made-with-python](https://img.shields.io/badge/Made%20with-Python-1f425f.svg)](https://www.python.org/)

## Usage 😎

wappdriver is a python package that helps you automate sending messages through WhatsApp Web.

_It enables you to send WhatsApp messages programmatically, using only three lines of code._

It is very simple to use

```python
from wappdriver import WhatsApp
with WhatsApp() as bot:
    bot.send('aahnik',  # name of recipient
             'hi send by a bot')  # message
# The name of the recipient should be in your contacts
```

Read **[full documentation 📖](https://aahnik.github.io/wappdriver/usage/02_sending_messages/)** to learn how to send emojis, media and files.

## Installation ⏬

You can easily install wappdriver from the [PyPI](https://pypi.org/project/wappdriver/).

```shell
pip install wappdriver
```

For Mac and Linux, you may need to use `pip3`.

## Requirements 🧑‍💻

You must have the following installed in your system for wappdriver to work.

- [Chrome Browser](https://www.google.com/chrome/)
- [Chrome Driver](https://chromedriver.chromium.org/)

Make sure to have matching versions of the Chrome Browser and Chrome Driver.
I recommend using the latest stable release for both to get the best performance.

WappDriver does not support other Browsers. Please use Chrome for a smooth experience.

## Setup ⚙️

After you have installed wappdriver and the requirements stated above, you can start using wappdriver straight away.

When you will run your code for the first time, you will be asked for Chrome Driver Path.
When the WhatsApp web screen loads for the first time, you have to scan the QR code from you smartphone's WhatsApp application, to log into your WhatsApp account. [Learn more](https://aahnik.github.io/wappdriver/usage/01_first_time_setup/).

<!-- Read more about [first time setup](https://aahnik.github.io/wappdriver/usage/01_first_time_setup/) on the official docs page. -->

## Getting Help 💁🏻

First of all, read the [Help Page](https://aahnik.github.io/wappdriver/help/).
You may try to search your question in the search bar on the page.

For further assistance you may [ask a question](https://github.com/aahnik/wappdriver/issues/new/choose) the issues section.

## Contributing 🤩

Please look at [Code of Conduct](https://github.com/aahnik/wappdriver/blob/master/.github/CODE_OF_CONDUCT.md#contributor-covenant-code-of-conduct) and [Contributing Guidelines](https://github.com/aahnik/wappdriver/blob/master/.github/CONTRIBUTING.md#how-to-contribute-to-wappdriver-).

Please read the explanation of the detailed working of `wappdriver` from the [Developer's Guide.](https://aahnik.github.io/wappdriver/dev/wappdriver/)

## Legal ⚖️

This project is distributed under [MIT License](https://github.com/aahnik/wappdriver/blob/main/LICENSE).

This code is in no way affiliated with, authorized, maintained, sponsored, or endorsed by WhatsApp or any of its affiliates or subsidiaries. This is an independent and unofficial software.




%package -n python3-wappdriver
Summary:	A package that automates sending messages through WhatsApp Web
Provides:	python-wappdriver
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-wappdriver
# wappdriver

API for WhatsApp Web Automation

Wondering how to send WhatsApp messages using Python using only three lines of code? **You have come to the right place!**

[![Tests](https://img.shields.io/badge/tests-passing-green)](https://aahnik.github.io/wappdriver/docs/Tests.html)
[![Maintenance](https://img.shields.io/maintenance/yes/2020)](https://github.com/aahnik/wappdriver/graphs/commit-activity)
[![GitHub Release](https://img.shields.io/github/v/release/aahnik/wappdriver)](https://github.com/aahnik/wappdriver/releases)
[![CodeFactor](https://www.codefactor.io/repository/github/aahnik/wappdriver/badge)](https://www.codefactor.io/repository/github/aahnik/wappdriver)
[![MIT LICENSE](https://img.shields.io/pypi/l/ansicolortags.svg)](/LICENSE)
[![made-with-python](https://img.shields.io/badge/Made%20with-Python-1f425f.svg)](https://www.python.org/)

## Usage 😎

wappdriver is a python package that helps you automate sending messages through WhatsApp Web.

_It enables you to send WhatsApp messages programmatically, using only three lines of code._

It is very simple to use

```python
from wappdriver import WhatsApp
with WhatsApp() as bot:
    bot.send('aahnik',  # name of recipient
             'hi send by a bot')  # message
# The name of the recipient should be in your contacts
```

Read **[full documentation 📖](https://aahnik.github.io/wappdriver/usage/02_sending_messages/)** to learn how to send emojis, media and files.

## Installation ⏬

You can easily install wappdriver from the [PyPI](https://pypi.org/project/wappdriver/).

```shell
pip install wappdriver
```

For Mac and Linux, you may need to use `pip3`.

## Requirements 🧑‍💻

You must have the following installed in your system for wappdriver to work.

- [Chrome Browser](https://www.google.com/chrome/)
- [Chrome Driver](https://chromedriver.chromium.org/)

Make sure to have matching versions of the Chrome Browser and Chrome Driver.
I recommend using the latest stable release for both to get the best performance.

WappDriver does not support other Browsers. Please use Chrome for a smooth experience.

## Setup ⚙️

After you have installed wappdriver and the requirements stated above, you can start using wappdriver straight away.

When you will run your code for the first time, you will be asked for Chrome Driver Path.
When the WhatsApp web screen loads for the first time, you have to scan the QR code from you smartphone's WhatsApp application, to log into your WhatsApp account. [Learn more](https://aahnik.github.io/wappdriver/usage/01_first_time_setup/).

<!-- Read more about [first time setup](https://aahnik.github.io/wappdriver/usage/01_first_time_setup/) on the official docs page. -->

## Getting Help 💁🏻

First of all, read the [Help Page](https://aahnik.github.io/wappdriver/help/).
You may try to search your question in the search bar on the page.

For further assistance you may [ask a question](https://github.com/aahnik/wappdriver/issues/new/choose) the issues section.

## Contributing 🤩

Please look at [Code of Conduct](https://github.com/aahnik/wappdriver/blob/master/.github/CODE_OF_CONDUCT.md#contributor-covenant-code-of-conduct) and [Contributing Guidelines](https://github.com/aahnik/wappdriver/blob/master/.github/CONTRIBUTING.md#how-to-contribute-to-wappdriver-).

Please read the explanation of the detailed working of `wappdriver` from the [Developer's Guide.](https://aahnik.github.io/wappdriver/dev/wappdriver/)

## Legal ⚖️

This project is distributed under [MIT License](https://github.com/aahnik/wappdriver/blob/main/LICENSE).

This code is in no way affiliated with, authorized, maintained, sponsored, or endorsed by WhatsApp or any of its affiliates or subsidiaries. This is an independent and unofficial software.




%package help
Summary:	Development documents and examples for wappdriver
Provides:	python3-wappdriver-doc
%description help
# wappdriver

API for WhatsApp Web Automation

Wondering how to send WhatsApp messages using Python using only three lines of code? **You have come to the right place!**

[![Tests](https://img.shields.io/badge/tests-passing-green)](https://aahnik.github.io/wappdriver/docs/Tests.html)
[![Maintenance](https://img.shields.io/maintenance/yes/2020)](https://github.com/aahnik/wappdriver/graphs/commit-activity)
[![GitHub Release](https://img.shields.io/github/v/release/aahnik/wappdriver)](https://github.com/aahnik/wappdriver/releases)
[![CodeFactor](https://www.codefactor.io/repository/github/aahnik/wappdriver/badge)](https://www.codefactor.io/repository/github/aahnik/wappdriver)
[![MIT LICENSE](https://img.shields.io/pypi/l/ansicolortags.svg)](/LICENSE)
[![made-with-python](https://img.shields.io/badge/Made%20with-Python-1f425f.svg)](https://www.python.org/)

## Usage 😎

wappdriver is a python package that helps you automate sending messages through WhatsApp Web.

_It enables you to send WhatsApp messages programmatically, using only three lines of code._

It is very simple to use

```python
from wappdriver import WhatsApp
with WhatsApp() as bot:
    bot.send('aahnik',  # name of recipient
             'hi send by a bot')  # message
# The name of the recipient should be in your contacts
```

Read **[full documentation 📖](https://aahnik.github.io/wappdriver/usage/02_sending_messages/)** to learn how to send emojis, media and files.

## Installation ⏬

You can easily install wappdriver from the [PyPI](https://pypi.org/project/wappdriver/).

```shell
pip install wappdriver
```

For Mac and Linux, you may need to use `pip3`.

## Requirements 🧑‍💻

You must have the following installed in your system for wappdriver to work.

- [Chrome Browser](https://www.google.com/chrome/)
- [Chrome Driver](https://chromedriver.chromium.org/)

Make sure to have matching versions of the Chrome Browser and Chrome Driver.
I recommend using the latest stable release for both to get the best performance.

WappDriver does not support other Browsers. Please use Chrome for a smooth experience.

## Setup ⚙️

After you have installed wappdriver and the requirements stated above, you can start using wappdriver straight away.

When you will run your code for the first time, you will be asked for Chrome Driver Path.
When the WhatsApp web screen loads for the first time, you have to scan the QR code from you smartphone's WhatsApp application, to log into your WhatsApp account. [Learn more](https://aahnik.github.io/wappdriver/usage/01_first_time_setup/).

<!-- Read more about [first time setup](https://aahnik.github.io/wappdriver/usage/01_first_time_setup/) on the official docs page. -->

## Getting Help 💁🏻

First of all, read the [Help Page](https://aahnik.github.io/wappdriver/help/).
You may try to search your question in the search bar on the page.

For further assistance you may [ask a question](https://github.com/aahnik/wappdriver/issues/new/choose) the issues section.

## Contributing 🤩

Please look at [Code of Conduct](https://github.com/aahnik/wappdriver/blob/master/.github/CODE_OF_CONDUCT.md#contributor-covenant-code-of-conduct) and [Contributing Guidelines](https://github.com/aahnik/wappdriver/blob/master/.github/CONTRIBUTING.md#how-to-contribute-to-wappdriver-).

Please read the explanation of the detailed working of `wappdriver` from the [Developer's Guide.](https://aahnik.github.io/wappdriver/dev/wappdriver/)

## Legal ⚖️

This project is distributed under [MIT License](https://github.com/aahnik/wappdriver/blob/main/LICENSE).

This code is in no way affiliated with, authorized, maintained, sponsored, or endorsed by WhatsApp or any of its affiliates or subsidiaries. This is an independent and unofficial software.




%prep
%autosetup -n wappdriver-0.6.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-wappdriver -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.6-1
- Package Spec generated