%global _empty_manifest_terminate_build 0
Name:		python-lc-sdk-python
Version:	0.3.6
Release:	1
Summary:	Package which lets to work with LiveChat API.
License:	Apache-2.0
URL:		https://github.com/livechat/lc-sdk-python
Source0:	https://mirrors.aliyun.com/pypi/web/packages/94/d6/617b9436cb2f0c9aa1a61e5970191373ab6eb08c48e77bae7f4ce7dc1bee/lc-sdk-python-0.3.6.tar.gz
BuildArch:	noarch

Requires:	python3-websocket-client
Requires:	python3-httpx
Requires:	python3-http2

%description
# LiveChat Platform API SDK for Python3

This Software Development Kit written in Python3 helps developers build external backend apps that extend LiveChat features. The SDK makes it easy to use Agent Chat API, Customer Chat API and Configuration API.

## Documentation

For protocol documentation of LiveChat APIs, please go to [LiveChat Platform Docs](https://developers.livechatinc.com/docs/).

For internal documentation of the SDK, please check: [Technical documentation](https://livechat.github.io/lc-sdk-python/index.html).

## Installation

### pip

```bash
pip install lc-sdk-python
```

## Usage

Usage examples can be found here:
[examples](https://github.com/livechat/lc-sdk-python/tree/master/examples)

## Feedback

​If you find any bugs or have trouble implementing the code on your own, please create an issue or contact us via e-mail: apiteam.qa@livechat.com.

## About LiveChat

LiveChat is an online customer service software with live support, help desk software, and web analytics capabilities. It's used by more than 32,000 companies all over the world. For more info, check out [LiveChat](https://livechat.com/).




%package -n python3-lc-sdk-python
Summary:	Package which lets to work with LiveChat API.
Provides:	python-lc-sdk-python
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-lc-sdk-python
# LiveChat Platform API SDK for Python3

This Software Development Kit written in Python3 helps developers build external backend apps that extend LiveChat features. The SDK makes it easy to use Agent Chat API, Customer Chat API and Configuration API.

## Documentation

For protocol documentation of LiveChat APIs, please go to [LiveChat Platform Docs](https://developers.livechatinc.com/docs/).

For internal documentation of the SDK, please check: [Technical documentation](https://livechat.github.io/lc-sdk-python/index.html).

## Installation

### pip

```bash
pip install lc-sdk-python
```

## Usage

Usage examples can be found here:
[examples](https://github.com/livechat/lc-sdk-python/tree/master/examples)

## Feedback

​If you find any bugs or have trouble implementing the code on your own, please create an issue or contact us via e-mail: apiteam.qa@livechat.com.

## About LiveChat

LiveChat is an online customer service software with live support, help desk software, and web analytics capabilities. It's used by more than 32,000 companies all over the world. For more info, check out [LiveChat](https://livechat.com/).




%package help
Summary:	Development documents and examples for lc-sdk-python
Provides:	python3-lc-sdk-python-doc
%description help
# LiveChat Platform API SDK for Python3

This Software Development Kit written in Python3 helps developers build external backend apps that extend LiveChat features. The SDK makes it easy to use Agent Chat API, Customer Chat API and Configuration API.

## Documentation

For protocol documentation of LiveChat APIs, please go to [LiveChat Platform Docs](https://developers.livechatinc.com/docs/).

For internal documentation of the SDK, please check: [Technical documentation](https://livechat.github.io/lc-sdk-python/index.html).

## Installation

### pip

```bash
pip install lc-sdk-python
```

## Usage

Usage examples can be found here:
[examples](https://github.com/livechat/lc-sdk-python/tree/master/examples)

## Feedback

​If you find any bugs or have trouble implementing the code on your own, please create an issue or contact us via e-mail: apiteam.qa@livechat.com.

## About LiveChat

LiveChat is an online customer service software with live support, help desk software, and web analytics capabilities. It's used by more than 32,000 companies all over the world. For more info, check out [LiveChat](https://livechat.com/).




%prep
%autosetup -n lc-sdk-python-0.3.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-lc-sdk-python -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.6-1
- Package Spec generated