%global _empty_manifest_terminate_build 0
Name: python-rtb-data
Version: 1.0.1
Release: 1
Summary: Data files for the Robotics Toolbox for Python.
License: MIT License
URL: https://github.com/petercorke/roboticstoolbox-python
Source0: https://mirrors.aliyun.com/pypi/web/packages/9e/da/3c7eae56fc32512e89eb239f7f7bb180764a4ca796c2e077166ed439fea9/rtb-data-1.0.1.tar.gz
BuildArch: noarch
%description
# Robotics Toolbox for Python - data files
[](https://badge.fury.io/py/rtb-data)
[](https://anaconda.org/conda-forge/rtb-datan)
 |
This package includes large data files associated with the Robotics Toolbox for Python (RTB-P).
|
## Rationale
The data files are provided as a separate package to work around disk space limitations on PyPI. Including these data with the RTB code adds nearly 200MB to every release, which will blow the PyPI limit quite quickly.
Since the data doesn't change very much, it's mostly robot models and a few data sets, it makes sense for it to be a standalone package.
## Package contents
| Folder | Purpose |
| ------ | ------------------------------ |
| data | miscellaneous STL files and data sets |
| meshes | STL mesh models for DH robots |
| xacro | URDF/xacro models for URDF robots |
## Accessing data within the package
The Toolbox function `path_to_datafile(file)` will return an absolute
`Path` to `file` which is relative to the root of the data package. For example
```
loadmat("data/map1.mat") # read rtbdata/data/map1.mat
loadmat("foo.dat") # read ./foo.dat
loadmat("~/foo.dat") # read $HOME/foo.dat
```
A matching local file takes precendence over a file in the data package.
## Installing the package
You don't need to explicitly install this package, it happens automatically when you when you install RTB-P
```
pip install roboticstoolbox-python
```
since it is a dependency.
%package -n python3-rtb-data
Summary: Data files for the Robotics Toolbox for Python.
Provides: python-rtb-data
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-rtb-data
# Robotics Toolbox for Python - data files
[](https://badge.fury.io/py/rtb-data)
[](https://anaconda.org/conda-forge/rtb-datan)
 |
This package includes large data files associated with the Robotics Toolbox for Python (RTB-P).
|
## Rationale
The data files are provided as a separate package to work around disk space limitations on PyPI. Including these data with the RTB code adds nearly 200MB to every release, which will blow the PyPI limit quite quickly.
Since the data doesn't change very much, it's mostly robot models and a few data sets, it makes sense for it to be a standalone package.
## Package contents
| Folder | Purpose |
| ------ | ------------------------------ |
| data | miscellaneous STL files and data sets |
| meshes | STL mesh models for DH robots |
| xacro | URDF/xacro models for URDF robots |
## Accessing data within the package
The Toolbox function `path_to_datafile(file)` will return an absolute
`Path` to `file` which is relative to the root of the data package. For example
```
loadmat("data/map1.mat") # read rtbdata/data/map1.mat
loadmat("foo.dat") # read ./foo.dat
loadmat("~/foo.dat") # read $HOME/foo.dat
```
A matching local file takes precendence over a file in the data package.
## Installing the package
You don't need to explicitly install this package, it happens automatically when you when you install RTB-P
```
pip install roboticstoolbox-python
```
since it is a dependency.
%package help
Summary: Development documents and examples for rtb-data
Provides: python3-rtb-data-doc
%description help
# Robotics Toolbox for Python - data files
[](https://badge.fury.io/py/rtb-data)
[](https://anaconda.org/conda-forge/rtb-datan)
 |
This package includes large data files associated with the Robotics Toolbox for Python (RTB-P).
|
## Rationale
The data files are provided as a separate package to work around disk space limitations on PyPI. Including these data with the RTB code adds nearly 200MB to every release, which will blow the PyPI limit quite quickly.
Since the data doesn't change very much, it's mostly robot models and a few data sets, it makes sense for it to be a standalone package.
## Package contents
| Folder | Purpose |
| ------ | ------------------------------ |
| data | miscellaneous STL files and data sets |
| meshes | STL mesh models for DH robots |
| xacro | URDF/xacro models for URDF robots |
## Accessing data within the package
The Toolbox function `path_to_datafile(file)` will return an absolute
`Path` to `file` which is relative to the root of the data package. For example
```
loadmat("data/map1.mat") # read rtbdata/data/map1.mat
loadmat("foo.dat") # read ./foo.dat
loadmat("~/foo.dat") # read $HOME/foo.dat
```
A matching local file takes precendence over a file in the data package.
## Installing the package
You don't need to explicitly install this package, it happens automatically when you when you install RTB-P
```
pip install roboticstoolbox-python
```
since it is a dependency.
%prep
%autosetup -n rtb-data-1.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-rtb-data -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.0.1-1
- Package Spec generated