%global _empty_manifest_terminate_build 0
Name: python-awesome-finder
Version: 1.2.3
Release: 1
Summary: A TUI based awesome curated list finder
License: MIT
URL: https://github.com/mingrammer/awesome-finder
Source0: https://mirrors.aliyun.com/pypi/web/packages/cf/2b/f87b327f4e8f55be237e6def13d699989961596e0b97e073ba2a6c566167/awesome-finder-1.2.3.tar.gz
BuildArch: noarch
Requires: python3-requests
%description
Awesome Finder
Search the awesome curated list without browser
> What does mean awesome? The awesome series provide a curated list of awesome frameworks, libraries, software and resources for a specific topic. An example is [awesome-python](https://github.com/vinta/awesome-python)
A TUI based finder for searching the awesome resources on awesome series such as `awesome-python`, `awesome-go` and so on.
With it, you can browse the awesome libraries, resources on your terminal without browser.
[![asciicast](https://asciinema.org/a/OOdH9rLVBvReK3K6n7pZvruf9.png)](https://asciinema.org/a/OOdH9rLVBvReK3K6n7pZvruf9)
## Installation
It supports **Python 3+** only.
```bash
pip install awesome-finder # or pip3 install awesome-finder
```
## Usage
```console
# Find awesome things from awesome-
awesome-hub
# Find awesome things from latest awesome- (not use cache)
awesome-hub -f (--force)
# Find awesome things with initial query
awesome-hub -q (--query) 'query string you want to search'
# Show help messages (can see supported awesome topics)
awesome-hub -h (--help)
```
There are some helpful key bindings:
| Key | Description |
| ----------------- | ---------------------------------------- |
| Key up (**↑**) | Scroll up |
| Key down (**↓**) | Scroll down |
| Key left (**←**) | Page up |
| Key right (**→**) | Page down |
| Enter (↵) | Open the selected awesome link on default browser |
| Esc | Close the awesome finder |
## Supported awesome topics
> *Updated: 2018-03-04*
These will be updated continuously
- awesome
- awesome-android
- awesome-elixir
- awesome-erlang
- awesome-go
- awesome-ios
- awesome-java
- awesome-javascript
- awesome-nodejs
- awesome-php
- awesome-python
- awesome-ruby
- awesome-rust
- awesome-scala
- awesome-swift
- awesome-vue
## Contributing
Details on [CONTRIBUTING](CONTRIBUTING.md)
## Changelog
Details on [CHANGELOG](CHANGELOG.md)
## TODO
* [ ] Query highlighting
* [x] Supports paging with Key left (←) and Key right (→)
* [ ] Smart parsing with hierachical structure
* [ ] Supports all awesome series
* [x] Supports initial query (example: `awesome python -q 'django oauth'`)
* [ ] Add options to open the Issue and Pull Request page of a specific awesome series
## License
[![FOSSA Status](https://app.fossa.io/api/projects/git%2Bgithub.com%2Fmingrammer%2Fawesome-finder.svg?type=large)](https://app.fossa.io/projects/git%2Bgithub.com%2Fmingrammer%2Fawesome-finder?ref=badge_large)
%package -n python3-awesome-finder
Summary: A TUI based awesome curated list finder
Provides: python-awesome-finder
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-awesome-finder
Awesome Finder
Search the awesome curated list without browser
> What does mean awesome? The awesome series provide a curated list of awesome frameworks, libraries, software and resources for a specific topic. An example is [awesome-python](https://github.com/vinta/awesome-python)
A TUI based finder for searching the awesome resources on awesome series such as `awesome-python`, `awesome-go` and so on.
With it, you can browse the awesome libraries, resources on your terminal without browser.
[![asciicast](https://asciinema.org/a/OOdH9rLVBvReK3K6n7pZvruf9.png)](https://asciinema.org/a/OOdH9rLVBvReK3K6n7pZvruf9)
## Installation
It supports **Python 3+** only.
```bash
pip install awesome-finder # or pip3 install awesome-finder
```
## Usage
```console
# Find awesome things from awesome-
awesome-hub
# Find awesome things from latest awesome- (not use cache)
awesome-hub -f (--force)
# Find awesome things with initial query
awesome-hub -q (--query) 'query string you want to search'
# Show help messages (can see supported awesome topics)
awesome-hub -h (--help)
```
There are some helpful key bindings:
| Key | Description |
| ----------------- | ---------------------------------------- |
| Key up (**↑**) | Scroll up |
| Key down (**↓**) | Scroll down |
| Key left (**←**) | Page up |
| Key right (**→**) | Page down |
| Enter (↵) | Open the selected awesome link on default browser |
| Esc | Close the awesome finder |
## Supported awesome topics
> *Updated: 2018-03-04*
These will be updated continuously
- awesome
- awesome-android
- awesome-elixir
- awesome-erlang
- awesome-go
- awesome-ios
- awesome-java
- awesome-javascript
- awesome-nodejs
- awesome-php
- awesome-python
- awesome-ruby
- awesome-rust
- awesome-scala
- awesome-swift
- awesome-vue
## Contributing
Details on [CONTRIBUTING](CONTRIBUTING.md)
## Changelog
Details on [CHANGELOG](CHANGELOG.md)
## TODO
* [ ] Query highlighting
* [x] Supports paging with Key left (←) and Key right (→)
* [ ] Smart parsing with hierachical structure
* [ ] Supports all awesome series
* [x] Supports initial query (example: `awesome python -q 'django oauth'`)
* [ ] Add options to open the Issue and Pull Request page of a specific awesome series
## License
[![FOSSA Status](https://app.fossa.io/api/projects/git%2Bgithub.com%2Fmingrammer%2Fawesome-finder.svg?type=large)](https://app.fossa.io/projects/git%2Bgithub.com%2Fmingrammer%2Fawesome-finder?ref=badge_large)
%package help
Summary: Development documents and examples for awesome-finder
Provides: python3-awesome-finder-doc
%description help
Awesome Finder
Search the awesome curated list without browser
> What does mean awesome? The awesome series provide a curated list of awesome frameworks, libraries, software and resources for a specific topic. An example is [awesome-python](https://github.com/vinta/awesome-python)
A TUI based finder for searching the awesome resources on awesome series such as `awesome-python`, `awesome-go` and so on.
With it, you can browse the awesome libraries, resources on your terminal without browser.
[![asciicast](https://asciinema.org/a/OOdH9rLVBvReK3K6n7pZvruf9.png)](https://asciinema.org/a/OOdH9rLVBvReK3K6n7pZvruf9)
## Installation
It supports **Python 3+** only.
```bash
pip install awesome-finder # or pip3 install awesome-finder
```
## Usage
```console
# Find awesome things from awesome-
awesome-hub
# Find awesome things from latest awesome- (not use cache)
awesome-hub -f (--force)
# Find awesome things with initial query
awesome-hub -q (--query) 'query string you want to search'
# Show help messages (can see supported awesome topics)
awesome-hub -h (--help)
```
There are some helpful key bindings:
| Key | Description |
| ----------------- | ---------------------------------------- |
| Key up (**↑**) | Scroll up |
| Key down (**↓**) | Scroll down |
| Key left (**←**) | Page up |
| Key right (**→**) | Page down |
| Enter (↵) | Open the selected awesome link on default browser |
| Esc | Close the awesome finder |
## Supported awesome topics
> *Updated: 2018-03-04*
These will be updated continuously
- awesome
- awesome-android
- awesome-elixir
- awesome-erlang
- awesome-go
- awesome-ios
- awesome-java
- awesome-javascript
- awesome-nodejs
- awesome-php
- awesome-python
- awesome-ruby
- awesome-rust
- awesome-scala
- awesome-swift
- awesome-vue
## Contributing
Details on [CONTRIBUTING](CONTRIBUTING.md)
## Changelog
Details on [CHANGELOG](CHANGELOG.md)
## TODO
* [ ] Query highlighting
* [x] Supports paging with Key left (←) and Key right (→)
* [ ] Smart parsing with hierachical structure
* [ ] Supports all awesome series
* [x] Supports initial query (example: `awesome python -q 'django oauth'`)
* [ ] Add options to open the Issue and Pull Request page of a specific awesome series
## License
[![FOSSA Status](https://app.fossa.io/api/projects/git%2Bgithub.com%2Fmingrammer%2Fawesome-finder.svg?type=large)](https://app.fossa.io/projects/git%2Bgithub.com%2Fmingrammer%2Fawesome-finder?ref=badge_large)
%prep
%autosetup -n awesome-finder-1.2.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-awesome-finder -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.2.3-1
- Package Spec generated