%global _empty_manifest_terminate_build 0
Name: python-adr-viewer
Version: 1.3.0
Release: 1
Summary: A visualisation tool for Architecture Decision Records
License: MIT
URL: https://github.com/mrwilson/adr-viewer
Source0: https://mirrors.aliyun.com/pypi/web/packages/a7/9d/f9fa91d28be99a47bc30abe4eef18052f1745a85cafc6971e4c2855e00c7/adr-viewer-1.3.0.tar.gz
BuildArch: noarch
%description
# adr-viewer
[![Build Status](https://travis-ci.org/mrwilson/adr-viewer.svg?branch=master)](https://travis-ci.org/mrwilson/adr-viewer)
Show off your Architecture Decision Records with an easy-to-navigate web page, either as a local web-server or generated static content.
## Examples
* Example above using Nat Pryce's [adr-tools](https://github.com/npryce/adr-tools) project
* This project exposes its own Architecture Decision Records [here](https://mrwilson.github.io/adr-viewer/index.html)
## Installation
### From PyPI
```bash
$ pip install adr-viewer
```
### From local build
adr-viewer requires Python 3.7 or higher (with Pip)
```bash
$ git clone https://github.com/mrwilson/adr-viewer
$ pip install -r requirements.txt
$ python setup.py install
```
## Usage
```bash
Usage: adr-viewer [OPTIONS]
Options:
--adr-path TEXT Directory containing ADR files. [default: doc/adr/]
--output TEXT File to write output to. [default: index.html]
--serve Serve content at http://localhost:8000/
--port INT Custom server port [default: 8000]
--help Show this message and exit.
```
The default for `--adr-path` is `doc/adr/` because this is the default path generated by `adr-tools`.
## Supported Record Types
%package -n python3-adr-viewer
Summary: A visualisation tool for Architecture Decision Records
Provides: python-adr-viewer
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-adr-viewer
# adr-viewer
[![Build Status](https://travis-ci.org/mrwilson/adr-viewer.svg?branch=master)](https://travis-ci.org/mrwilson/adr-viewer)
Show off your Architecture Decision Records with an easy-to-navigate web page, either as a local web-server or generated static content.
## Examples
* Example above using Nat Pryce's [adr-tools](https://github.com/npryce/adr-tools) project
* This project exposes its own Architecture Decision Records [here](https://mrwilson.github.io/adr-viewer/index.html)
## Installation
### From PyPI
```bash
$ pip install adr-viewer
```
### From local build
adr-viewer requires Python 3.7 or higher (with Pip)
```bash
$ git clone https://github.com/mrwilson/adr-viewer
$ pip install -r requirements.txt
$ python setup.py install
```
## Usage
```bash
Usage: adr-viewer [OPTIONS]
Options:
--adr-path TEXT Directory containing ADR files. [default: doc/adr/]
--output TEXT File to write output to. [default: index.html]
--serve Serve content at http://localhost:8000/
--port INT Custom server port [default: 8000]
--help Show this message and exit.
```
The default for `--adr-path` is `doc/adr/` because this is the default path generated by `adr-tools`.
## Supported Record Types
%package help
Summary: Development documents and examples for adr-viewer
Provides: python3-adr-viewer-doc
%description help
# adr-viewer
[![Build Status](https://travis-ci.org/mrwilson/adr-viewer.svg?branch=master)](https://travis-ci.org/mrwilson/adr-viewer)
Show off your Architecture Decision Records with an easy-to-navigate web page, either as a local web-server or generated static content.
## Examples
* Example above using Nat Pryce's [adr-tools](https://github.com/npryce/adr-tools) project
* This project exposes its own Architecture Decision Records [here](https://mrwilson.github.io/adr-viewer/index.html)
## Installation
### From PyPI
```bash
$ pip install adr-viewer
```
### From local build
adr-viewer requires Python 3.7 or higher (with Pip)
```bash
$ git clone https://github.com/mrwilson/adr-viewer
$ pip install -r requirements.txt
$ python setup.py install
```
## Usage
```bash
Usage: adr-viewer [OPTIONS]
Options:
--adr-path TEXT Directory containing ADR files. [default: doc/adr/]
--output TEXT File to write output to. [default: index.html]
--serve Serve content at http://localhost:8000/
--port INT Custom server port [default: 8000]
--help Show this message and exit.
```
The default for `--adr-path` is `doc/adr/` because this is the default path generated by `adr-tools`.
## Supported Record Types
%prep
%autosetup -n adr-viewer-1.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-adr-viewer -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.3.0-1
- Package Spec generated